Problème TinyMCE et IFrame (le retour du retour...)

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Problème TinyMCE et IFrame (le retour du retour...)

    bon-soir à tous,

    cela va bientôt faire un an que j'utilise Joomla et je n'avais jamais essayé
    de publier une vidéo "embeded" depuis la barre d'outils de l'éditeur TinyMCE.

    J'ai donc vérifier cette fonction car une personne pour qui j'ai
    fait un site se plaignait de na pas pouvoir le faire...

    Et là grosse grimace, après plusieurs essaies avec une video YouTube
    je suis forcé de constater le problème : l'éditeur refuse d'ajouter un code qu'il soit de type Iframe,
    Object ou autre...

    J'ai donc essayé avec DailyMotion... même defaut...

    la panique s'installe... je commence à chercher...

    Je désactive toutes les listes noires au niveau du filtrage de text,
    je paramètre le plugin TinyMCE de manière à ce qu'il n' y ai aucune balise prohibé...
    Je supprime la liste des balises prohibées des fichiers "tinymce.php" et "tinymce.xml"...

    là on se dite ça doit marcher... mais NON le problème persiste,
    dès que l'ont quitte l'onglet "source" de la pop-up d'ajout de média, le code s’efface

    là je cherche dans le forum... et je trouve une flopée de messages traitant de ce problème...
    ayant à chaque fois la réponse récurrente : "lache TinyMCE et utilise JCE !!"

    je veux bien utiliser JCE, le problème et que la plupart de fonctions populaires
    comme l'ajout de vidéos ou de smiley sont payantes... et je dois rester
    pour l'instant dans une optique de gratuité (promis je serai moins ra' quand mon activité commencera
    à ce développer)...

    Voilà donc je voudrais savoir si quelqu'un à une solution pour venir à bout de ce périple
    et arriver ENFIN à insérer des codes d'intégration avec TinyMCE .

    Merci d'avance pour vos réponses !!

    MICKAEL

  • #2
    Re : Problème TinyMCE et IFrame (le retour du retour...)

    Bonjour,
    Je supprime la liste des balises prohibées des fichiers "tinymce.php" et "tinymce.xml"...
    Hein ? tu as fait quoi ? Ça se règle tranquillement dans les paramètres du plugin, pas besoin de mettre les mains dans le code pour ça...

    Je désactive toutes les listes noires au niveau du filtrage de texte,
    Tu peux préciser exactement ce que tu as fait ? Il suffit de mettre les profils voulu à "aucun filtre" ...
    Schtroumpfe toi le Schtroumpf t'aidera.
    Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

    Commentaire


    • #3
      Re : Problème TinyMCE et IFrame (le retour du retour...)

      merci pour la réponse Grand Schtroumpf,

      Il suffit de mettre les profils voulu à "aucun filtre" ...
      C'est ce que j’ai fais

      Ça se règle tranquillement dans les paramètres du plugin
      C'est ce que j'ai fais aussi, mais malgré de multiples enregistrements
      les paramètres prohibés restaient en place...

      J'ai aussi essayé de les mettre à la fois dans prohibé et dans autorisé
      mais ça ne fonctionne pas mieux...

      Commentaire


      • #4
        Re : Problème TinyMCE et IFrame (le retour du retour...)

        Bonjour,
        J'ai aussi essayé de les mettre à la fois dans prohibé et dans autorisé
        mais ça ne fonctionne pas mieux...
        Et à ton avis, quel est le résultat de 2 contraintes contradictoires ?
        Pas de demande de support par MP.
        S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

        Commentaire


        • #5
          Re : Problème TinyMCE et IFrame (le retour du retour...)

          Re,
          d'autant qu'en modifiant le tinyMCE.XML, je ne vois pas comment tu as pu impacter la valeur des paramètres... J'ai fait plusieurs fois le test avec les versions >=1.6 compte tenu des nombreuses question remontant sur ce sujet en vidant les prohibés et mettant les filtres sur aucun, je n'ai aucun problème pour insérer avec TinyMCE des iframe ou des objets flash.
          Schtroumpfe toi le Schtroumpf t'aidera.
          Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

          Commentaire


          • #6
            Re : Problème TinyMCE et IFrame (le retour du retour...)

            je n'ai aucun problème pour insérer avec TinyMCE des iframes ou des objets flash
            Eh bien il me semble que chez moi ça fonctionnait AVANT, mais ça ne fonctionne plus maintenant...

            Ce qui me trouble c'est que j'ai le problème
            sur un site tout neuf... Je vais voir si je peu désinstaller et réinstaller TinyMCE, je vous retiens au courant d'ici à ce soir,

            bonne journée !!

            Commentaire


            • #7
              Re : Problème TinyMCE et IFrame (le retour du retour...)

              Bon ça ne fonctionne toujours pas,

              je me suis rabattu sur JCK Editor , qui me convient parfaitement bien notamment avec ces extensions ImageManager et MediaEmbed,
              en attendant de passer sous JCE...

              Mais le problème avec TinyMCE n'est toujours pas réglé... est ce que je dois quand même passer le topic en résolu ??

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins
              Travaille ...
              X