Joomladay francophone 2019 à Paris, les 8 et 9 mars 2019

Identifiant de sécurité invalide si Plugin Système - Cache activé

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Identifiant de sécurité invalide si Plugin Système - Cache activé

    Bonjour,

    Lorsque je veux me reconnecter sur mon site en front-end en m'étant déjà connecté/déconnecté une première fois, j'obtiens le message d'erreur "Identifiant de sécurité invalide" si le Plugin Système Cache est activé.

    C'est donc un problème de cache mais est-ce lié au paramétrage de mon navigateur (Firefox en l'occurrence).

    Merci

    Xavier

  • #2
    Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

    Bonjour,

    Le plugin Système cache ne devrait être publié que sur des sites relativement statiques (sans modification fréquentes) et sans avoir de login en frontal.
    Ce cache global provoque ce type de problème. Si tu veux utiliser un cache, désactives ce plugin système et actives le cache progressif dans la configuration Joomla!
    Pas de demande de support par MP.
    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

    Commentaire


    • #3
      Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

      Merci, je vais donc suivre ce judicieux conseil.

      Commentaire


      • #4
        Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

        Envoyé par jisse03 Voir le message
        Bonjour,

        Le plugin Système cache ne devrait être publié que sur des sites relativement statiques (sans modification fréquentes) et sans avoir de login en frontal.
        Ce cache global provoque ce type de problème. Si tu veux utiliser un cache, désactives ce plugin système et actives le cache progressif dans la configuration Joomla!
        Bonjour Jisse03,

        J'ai exactement le même problème sur mon site intranet. Je m'explique :
        C'est un site sous Joomla 2.5.3 avec une authentification à l'aide du login joomla et du plugin LDAP de joomla.
        Parfois les gens arrivent à se connecter sur le front end et parfois après avoir entré leur login et pass ils atterrissent sur une page totalement blanche avec ce message "Identifiant de sécurité invalide". Parfois également certaines personnes voient leur page de connexion se ré-affiché après avoir rentré leur login et pass et ce sans message d'erreur sur la page elle même. Je soupconne un problème de cache car lorsque je purge le cache + purge des fichiers expirées, j'arrive à me connecter avec mon login et pass. Mais quelques heures après, si je me déconnecte pour me re-connecter, je n'y arrive plus.

        Le plugin sytème-cahe est désactivé sur mon site et le cache progressif a été mis dans la partie configuration du back-end.

        J'ai cherché sur certains forum mais ils donnent des solutions pour du Joomla 1.5,1.6 et 1.7 mais pas pour du Joomla 2.5.

        As-tu une idée pour résoudre ce problème. Merci d'avance pour ton aide.

        Commentaire


        • #5
          Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

          En ce qui me concerne, plus de souci depuis que j'ai désactivé le plugin.

          Commentaire


          • #6
            Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

            Envoyé par abdenour Voir le message
            Le plugin sytème-cahe est désactivé sur mon site et le cache progressif a été mis dans la partie configuration du back-end.

            J'ai cherché sur certains forum mais ils donnent des solutions pour du Joomla 1.5,1.6 et 1.7 mais pas pour du Joomla 2.5.

            As-tu une idée pour résoudre ce problème. Merci d'avance pour ton aide.
            Essaies de désactiver le cache progressif, il est possible que ce cache progressif ait des interactions avec l'authentification LDAP (qui elle même est tributaire des caches du serveur LDAP).
            Pas de demande de support par MP.
            S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

            Commentaire


            • #7
              Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

              Merci Jisse03. Je remplace le cache progressif par quoi dans le menu déroulant ? Par cache désactivé ou cache conservateur ?

              Commentaire


              • #8
                Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

                Je viens de tester en mettant "Cache désactivé" dans le backend au niveau du menu configuration mais le problème reste toujours le même. Après plusieurs connexion / déconnexion réussi, a un certains moment lorsque j'essaie de me connecter pour la n'ème fois, j'obtiens ce message d'erreur "Identifiant de sécurité invalide".

                Commentaire


                • #9
                  Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

                  Envoyé par abdenour Voir le message
                  Je viens de tester en mettant "Cache désactivé" dans le backend au niveau du menu configuration mais le problème reste toujours le même. Après plusieurs connexion / déconnexion réussi, a un certains moment lorsque j'essaie de me connecter pour la n'ème fois, j'obtiens ce message d'erreur "Identifiant de sécurité invalide".
                  Dans ce cas, il faut commencer par suspecter ta configuration pour la connexion LDAP. Regardes ta config, et traces, surtout si ton serveur LDAP est sous windows.
                  Pas de demande de support par MP.
                  S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                  Commentaire


                  • #10
                    Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

                    J'ai modifié mesparamétrages en mettant le cache dans configuration en "Cache conservateur" et non "Cache progressif". De plus j'ai désactivé le plugin cache système. Pour le moment je n'ai pas rencontré de problème. J'attends de voir.

                    Commentaire


                    • #11
                      Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

                      Bonjour Jisse03,

                      Je viens de trouver d'où venait mon problème mais je n'arrive pas à le résoudre. Je résume.

                      J'ai 2 problèmes. Le premier est que lorsque j'indique mon login et mon mot de passe je suis renvoyé parfois sur la même page de login et ce sans avoir un message d'erreur.

                      Le deuxième est parfois lorsque je me connecte, je suis renvoyé sur une page blanche avec le message d'erreur suivant "Identifiant de sécurité invalide". Et c'est là que j'ai remarqué que l'url indiqué dans ma barre d'adresse était l'url que j'avais lors de la création de mon site en local. Je ne suis donc pas renvoyé vers la bonne url après avoir validé sur le bouton de connexion. Lors de la création de mon intranet j'avais comme url http://intranet.local. Or depuis que je suis passé en prod je dois avoir comme url http://intranet.ma-societe.fr. Je ne sais pas où je dois paramétrer ma nouvelle url. Pourtant dans le module de login j'ai bien indiqué ma nouvelle url de prod dans la page de redirection vers la page d'accueil ainsi que celle de déconnexion.

                      Pour le 1er problème je suppose que cela doit-être le même problème mais là je n'ai pas pu vérifier l'url. Ce que je peux constater c'est que lorsque je vide le cache de mon template (template acheté chez joomlart.com : JA Nex), j'arrive bien à me connecter au site via le LDAP mais quelque temps après je n'y arrive plus.

                      Dans mon fichier de log d'erreur j'ai le message d'erreur suivant :

                      2012-03-19 13:43:04 INFO 192.xxx.xxx.xx LDAP FAILURE: Impossible de se lier au serveur LDAP

                      Vois tu où je pourrais corriger ce problème, merci.
                      Dernière édition par abdenour à 19/03/2012, 15h01

                      Commentaire


                      • #12
                        Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

                        Envoyé par abdenour Voir le message
                        Le deuxième est parfois lorsque je me connecte, je suis renvoyé sur une page blanche avec le message d'erreur suivant "Identifiant de sécurité invalide". Et c'est là que j'ai remarqué que l'url indiqué dans ma barre d'adresse était l'url que j'avais lors de la création de mon site en local. Je ne suis donc pas renvoyé vers la bonne url après avoir validé sur le bouton de connexion. Lors de la création de mon intranet j'avais comme url http://intranet.local. Or depuis que je suis passé en prod je dois avoir comme url http://intranet.ma-societe.fr. Je ne sais pas où je dois paramétrer ma nouvelle url. Pourtant dans le module de login j'ai bien indiqué ma nouvelle url de prod dans la page de redirection vers la page d'accueil ainsi que celle de déconnexion.
                        Tu n'aurais pas par hasard mis quelque chose dans configuration.php, pour la valeur de live_site ?
                        Ou dans un composant quelconque ou un plugin.

                        Envoyé par abdenour Voir le message
                        Pour le 1er problème je suppose que cela doit-être le même problème mais là je n'ai pas pu vérifier l'url. Ce que je peux constater c'est que lorsque je vide le cache de mon template (template acheté chez joomlart.com : JA Nex), j'arrive bien à me connecter au site via le LDAP mais quelque temps après je n'y arrive plus.
                        Un template avec son propre cache, ah oui, ça doit être pour l'accélérer.

                        Envoyé par abdenour Voir le message
                        Dans mon fichier de log d'erreur j'ai le message d'erreur suivant :

                        2012-03-19 13:43:04 INFO 192.xxx.xxx.xx LDAP FAILURE: Impossible de se lier au serveur LDAP

                        Vois tu où je pourrais corriger ce problème, merci.
                        Pour le LDAP, la chose est claire, le serveur n'a pas pu être joint avant son timeout. Ce qui là est indépendant de Joomla! mais relatif au réseau complet de l'intranet.
                        Pas de demande de support par MP.
                        S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                        Commentaire


                        • #13
                          Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

                          La valeur live_site dans le fichier configuration.php est vide. Je n'ai rien mis. Je n'arrive pas à comprendre pourquoi je suis redirigé vers mon ancienne url lors de la connexion. Mise à part le plugin LDAP de joomla et le module de connexion, je n'ai rien mis comme url.

                          Commentaire


                          • #14
                            Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

                            Envoyé par abdenour Voir le message
                            La valeur live_site dans le fichier configuration.php est vide. Je n'ai rien mis. Je n'arrive pas à comprendre pourquoi je suis redirigé vers mon ancienne url lors de la connexion. Mise à part le plugin LDAP de joomla et le module de connexion, je n'ai rien mis comme url.
                            Regardes aussi à tout hasard dans le LDAP central lui-même si par hasard il ne trainerait pas une trace de l'ancienne URL.
                            Pas de demande de support par MP.
                            S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                            Commentaire


                            • #15
                              Re : Identifiant de sécurité invalide si Plugin Système - Cache activé

                              Non, je n'ai rien paramétré dans le LDAP au niveau de l'url du site.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X