Grosse galère !!!

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Grosse galère !!!

    Bonjour,

    En voulant modifier les paramètres SEO, je suis allé modifier le fichier haccess.txt en haccess comme indiqué sur certains sites.
    En programmant les SEO comme indiqué, je me suis retrouvé avec des erreurs 404 sur mes pages ! J'ai donc remodifié le fichier en rajoutant .txt !
    Problème, je ne pouvais plus me logger sur mon site avec mes identifiants, mais j'vais encore accès à mon administration. Certains menu avaient été modifiés et la norme EU-privacy ne s'affichait plus. Quand je voulait me logger, que le site soit en ligne ou hors-ligne, mes id et mdp n'avaient aucun effet.
    J'ai appelé 1&1 et ils m'ont dit que le fichier haccess n'avait aucune incidence et après 1h de recherche infructueuses à ne rien comprendre, j'ai fait une grosse connerie : j'ai remodifié la ligne : URLs explicites (SEF) en passant de oui à non (ou l'inverse) et, depuis, j'ai une page blanche quand j'essaie d'ouvrir la page de mon administration...

    La situation est-elle définitivement perdue, en dehors du fait que la modification du haccess.txt a modifié des paramètres bien que cela ne doive pas être le cas d'après 1&1 ?

    Merci d'avance pour vos réponses.

  • #2
    Re : Grosse galère !!!

    Un petit apéricube au saumon ?

    C'est .htaccess et non haccess, renomme le (n'oublie pas le . devant) et tu devrais retrouver ton admin pour désactiver le SEO (toutes les lignes), en passant tu peux aussi lire les infos-bulles, après tu peux renommer le .htaccess en htaccess.txt (sans le . devant)
    Christophe
    http://www.webcrea.fr

    Commentaire


    • #3
      Re : Grosse galère !!!

      Bonjour et bienvenue,

      En voulant modifier les paramètres SEO, je suis allé modifier le fichier haccess.txt en haccess comme indiqué sur certains sites.
      il faut renommer ce fichier .htaccess (avec un "." devant).

      La situation est-elle définitivement perdue, en dehors du fait que la modification du haccess.txt a modifié des paramètres bien que cela ne doive pas être le cas d'après 1&1 ?
      En te connectant par FTP, y-a-t-il encore un fichier htaccess à la racine de ton site ?

      Sinon, une solution serait également de remonter une sauvegarde.


      [Edit]Grillé par webcrea [/Edit]
      Le JoomlaDay 2019 c'est le 8 et 9 mars #jd19fr (plus d'infos)

      Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous : http://cinnk.com/joomla/3/le-livre-pour-tous

      Envie de lire sur Joomla!, mais pas que ? Cinnk magazine http://cinnk.com/magazine

      Créez votre boutique en ligne avec Joomla! & HikaShop http://cinnk.com/boutique/livres/cre...la-et-hikashop

      Commentaire


      • #4
        Re : Grosse galère !!!

        Envoyé par SimonG Voir le message
        [Edit]Grillé par webcrea [/Edit]
        un petit apéricube ?
        Christophe
        http://www.webcrea.fr

        Commentaire


        • #5
          Re : Grosse galère !!!

          Envoyé par webcrea Voir le message
          Un petit apéricube au saumon ?

          C'est .htaccess et non haccess, renomme le (n'oublie pas le . devant) et tu devrais retrouver ton admin pour désactiver le SEO (toutes les lignes), en passant tu peux aussi lire les infos-bulles, après tu peux renommer le .htaccess en htaccess.txt (sans le . devant)
          oui, c'est bien .htaccess, malheureusement, j'ai juste écris vite et le problème ne vient donc pas de là.
          donc je suis bloqué !
          on est passé par.htaccess et htaccess.txt et depuis que j'ai modifié cette ligne du SEO, c'est planté !!!

          Commentaire


          • #6
            Re : Grosse galère !!!

            oui, c'est .htaccess
            oui, le fichier est toujours là
            une sauvegarde de 1&1 ?

            merci pour votre aide

            Commentaire


            • #7
              Re : Grosse galère !!!

              tu as une url?
              Christophe
              http://www.webcrea.fr

              Commentaire


              • #8
                Re : Grosse galère !!!

                Les erreurs 404 ont toutes chances d'avoir été provoquées par un .htaccess incorrect pour la réécriture "au vol" (au besoin va chercher celui de ma faq - lien dans ma signature).
                Si tu ne t'en sors pas, il suffit que tu modifies avec un éditeur de texte simple (de préférence notepad++) le fichier configuration.php pour désactiver complètement la réécriture :
                public $sef = '0';
                public $sef_rewrite = '0';
                public $sef_suffix = '0';
                public $unicodeslugs = '0';
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                Commentaire


                • #9
                  Re : Grosse galère !!!

                  Envoyé par webcrea Voir le message
                  tu as une url?
                  http://van-et-ly-trading.fr/

                  Commentaire


                  • #10
                    Re : Grosse galère !!!

                    ça y est ça roule ?
                    Christophe
                    http://www.webcrea.fr

                    Commentaire


                    • #11
                      Re : Grosse galère !!!

                      Envoyé par RobertG Voir le message
                      Les erreurs 404 ont toutes chances d'avoir été provoquées par un .htaccess incorrect pour la réécriture "au vol" (au besoin va chercher celui de ma faq - lien dans ma signature).
                      Si tu ne t'en sors pas, il suffit que tu modifies avec un éditeur de texte simple (de préférence notepad++) le fichier configuration.php pour désactiver complètement la réécriture :
                      je vais essayer, merci

                      Commentaire


                      • #12
                        Re : Grosse galère !!!

                        Envoyé par webcrea Voir le message
                        ça y est ça roule ?
                        non, non ! ça ne va pas du tout !
                        j'ai ccès comme tout le monde au site car il est publié mais je n'ai toujours pas accès à mon administration !

                        Commentaire


                        • #13
                          Re : Grosse galère !!!

                          Envoyé par jcb30 Voir le message
                          non, non ! ça ne va pas du tout !
                          j'ai ccès comme tout le monde au site car il est publié mais je n'ai toujours pas accès à mon administration !
                          Tu as un message d'erreur quand tu tentes de te connecter ?
                          Le JoomlaDay 2019 c'est le 8 et 9 mars #jd19fr (plus d'infos)

                          Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous : http://cinnk.com/joomla/3/le-livre-pour-tous

                          Envie de lire sur Joomla!, mais pas que ? Cinnk magazine http://cinnk.com/magazine

                          Créez votre boutique en ligne avec Joomla! & HikaShop http://cinnk.com/boutique/livres/cre...la-et-hikashop

                          Commentaire


                          • #14
                            Re : Grosse galère !!!

                            Envoyé par RobertG Voir le message
                            Les erreurs 404 ont toutes chances d'avoir été provoquées par un .htaccess incorrect pour la réécriture "au vol" (au besoin va chercher celui de ma faq - lien dans ma signature).
                            Si tu ne t'en sors pas, il suffit que tu modifies avec un éditeur de texte simple (de préférence notepad++) le fichier configuration.php pour désactiver complètement la réécriture :
                            Voilà ce que j'ai quand j'affiche et édite le fichier configuration.php !!! et pour l'autre, effectivement, je ne m'en sors pas !
                            Cliquez sur l'image pour l'afficher en taille normale

Nom : pb joomla.jpg 
Affichages : 1 
Taille : 139,8 Ko 
ID : 1802508

                            Commentaire


                            • #15
                              Re : Grosse galère !!!

                              Envoyé par SimonG Voir le message
                              Tu as un message d'erreur quand tu tentes de te connecter ?
                              même pas ! il ne prend tout simplement pas mon login et mon mdp, la fenêtre se referme et je reste non enregistré !

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X