Apparition d'un "0" dans l'entête de mon site

Réduire
Ce sujet est fermé.
X
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Apparition d'un "0" dans l'entête de mon site

    Bonjour,

    Depuis quelques jours, un "0" est apparu dans l'entête de mon site. Tout à fait en haut à gauche de l'écran.
    Je n'arrive pas à l'enlever. Au départ, je pensais avoir laissé un "echo ..." quelque part dans mon code, mais j'ai passé en revue l'ensemble des fichiers que j'avais modifiés précédemment et je n'ai rien trouvé...
    J'ai désactivé aussi les derniers plug-in installés sur Joomla mais le "0" reste constamment...
    Il apparaît aussi dans la partie Administration...

    Pour voir ce comportement, voici l'adresse de mon site: tu.rugby-gradignan.fr

    Si quelqu'un a une idée? Car je bloque depuis quelques temps maintenant...

    Merci d'avance!!

  • #2
    Re : Apparition d'un "0" dans l'entête de mon site

    Bjr,

    Tu as du installer un plugin topofthepage, il apparaitrait que cela soit lui le fautif, désactives le pour confirmer et si ok, cherches de ce côté.

    Commentaire


    • #3
      Re : Apparition d'un "0" dans l'entête de mon site

      Merci pour ta réponse rapide!
      Je l'ai déjà désactivé mais ça ne change rien... Toujours le même problème...
      Si je le désinstalle peut être ?

      Commentaire


      • #4
        Re : Apparition d'un "0" dans l'entête de mon site

        Tu n'as pas un plugin gérant les JS et CSS ?
        Ce qui est curieux, c'est que le code-source de la page par CTRL+U est différent de celui de Firebug ou des outils webmaster de Chrome !
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          Re : Apparition d'un "0" dans l'entête de mon site

          Bonjour,

          L'erreur est dans le head de la page, dans le smeta property
          Code HTML:
          <meta property="og:title" content="RCG - Accueil"/>
            0
            <meta property="og:description" content="" />
          Ce zéro facétieux a du être introduit quelque part dans le template (ou dans un truc gérant les meta).
          Pas de demande de support par MP.
          S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

          Commentaire


          • #6
            Re : Apparition d'un &quot;0&quot; dans l'entête de mon site

            J'ai le plug-in Firebug pour les JS et CSS.
            J'ai pu voir que c'était dans le head de la page grâce à lui oui... Mais impossible de savoir comment il y apparaît. Je suis même allé voir dans librairies > joomla > document > html > renderer > head.php mais je n'ai rien trouvé d'anormal...

            Commentaire


            • #7
              Re : Apparition d'un &quot;0&quot; dans l'entête de mon site

              En fait, Firebug me précise qu'il est juste après la balise body:

              0
              <meta content="RCG - Accueil" property="og:description">
              <meta content="fr_FR" property="og:locale">
              <meta content="" property="og:site_name">
              <meta content="" property="fb:admins">
              <meta content="" property="fb:app_id">

              Commentaire


              • #8
                Re : Apparition d'un &quot;0&quot; dans l'entête de mon site

                Des meta n'yant rien à faire après le body, ça sent un plugin d'insertion de ce genre de méta complètement en folie.
                Pas de demande de support par MP.
                S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                Commentaire


                • #9
                  Re : Apparition d'un &quot;0&quot; dans l'entête de mon site

                  Bonjour,

                  J'ai trouvé d'où venait mon problème. En effet, un plugin (Al Plugin Facebook Comment) insère des meta juste après le body (:O !!)
                  En le désactivant le "0" est partis.
                  J'ai donc dû retoucher le code du plugin afin de résoudre cette affreuse anomalie!!
                  Merci à tous pour votre aide.

                  Commentaire

                  Annonce

                  Réduire
                  1 sur 2 < >

                  C'est [Réglé] et on n'en parle plus ?

                  A quoi ça sert ?
                  La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                  Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                  Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                  Comment ajouter la mention [Réglé] à votre discussion ?
                  1 - Aller sur votre discussion et éditer votre premier message :


                  2 - Cliquer sur la liste déroulante Préfixe.

                  3 - Choisir le préfixe [Réglé].


                  4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                  2 sur 2 < >

                  Assistance au forum - Outil de publication d'infos de votre site

                  Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                  Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                  Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                  UTILISER À VOS PROPRES RISQUES :
                  L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                  Problèmes connus :
                  FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                  Installation :

                  1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                  Archive zip : https://github.com/AFUJ/FPA/zipball/master

                  2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                  3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                  4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                  5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                  6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                  et remplacer www. votresite .com par votre nom de domaine


                  Exemples:
                  Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/
                  Pour executer le script: http://www..com/fpa-fr.php

                  Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                  Télécharger le script fpa-fr.php dans: /public_html/cms/
                  Pour executer le script: http://www..com/cms/fpa-fr.php

                  En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                  Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                  Voir plus
                  Voir moins
                  Travaille ...
                  X