mes icônes et images jouent à cache-cache

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] mes icônes et images jouent à cache-cache

    lorsque j'actualise une page mes icônes et images disparaissent

    Cliquez sur l'image pour l'afficher en taille normale

Nom : Sans titre-.jpg 
Affichages : 1 
Taille : 26,1 Ko 
ID : 1820163

    Cliquez sur l'image pour l'afficher en taille normale

Nom : Sans titre.jpg 
Affichages : 1 
Taille : 24,8 Ko 
ID : 1820164

    en purgeant le cache ça réapparait
    une solution ?

    bonne journée
    Dernière édition par Sergio à 07/03/2014, 10h13


  • #2
    Re : mes icônes et images jouent à cache-cache

    Un peu de précisions ne nuirait pas. Merci de lire ce post et en tenir compte :

    http://forum.joomla.fr/showthread.php?185340-Comment-bien-exposer-son-probl%C3%A8me"
    Lorsque l'on se cogne la tête contre un pot et que cela sonne creux, ça n'est pas forcément le pot qui est vide.
    Confucius

    Commentaire


    • #3
      Re : mes icônes et images jouent à cache-cache

      Envoyé par lesoutier Voir le message
      Un peu de précisions ne nuirait pas.
      Version de Joomla : 2.5.19
      Template utilisé : Allrounder

      par exemple quand j'ouvre cet article une première fois tout s'affiche correctement
      quand j'actualise mes icônes jouent à cache-cache

      dans le plugin Système - Cache de Joomla j'ai activ ou désactivé le cache du navigateur
      ça ne change rien
      Dernière édition par Sergio à 07/03/2014, 08h10

      Commentaire


      • #4
        Re : mes icônes et images jouent à cache-cache

        Bonjour,

        je ne pense pas que ce sont tes images qui jouent à cache cache comme tu dis, mais le composant qui génère la carte (et les icônes correspondantes ?) qui dysfonctionne. Quand on regarde (avec firebug par exemple) le source généré, on s'aperçoit que le composant a généré une image (carte de la promenade) et qu'il l'a affiché et qu'il référence un lien vers cette image (ex : /images/2014/cartes-IGN/2014-03-01-----carte-----.jpg) sauf que ce lien pointe vers nulle part, quand on rafraîchit la page, au lieu de recalculer et re générer l'image (la carte) il essaie d'accéder (optimisation du temps de calcul : c'est louable) à celle qui est en principe stocké dans le répertoire images/année/cartes-IGN etc, mais ne la trouve pas.

        Quand on regarde en détail on voit que le chemin stocké dans le code HTML généré et donc rappelé lors du rafraichissement utilise une mauvaise base. Je m'explique, que ce soit pour la carte ou pour les icônes, étoiles de difficultés etc etc, le chemin de l'image dans le HTML est référencé comme dit plus haut : images/2014/cartes-IGN/ etc etc
        ce qui en fait un emplacement relatif à l'article affiché, alors que l'emplacement réel de ces images est racinedusite/images/2014/cartes-IGN etc etc
        si, avec firebug on rajoute le '/' devant l'url de référence de ses images, elles réapparaissent instantanément à l'écran. Peut être tout simplement un problème de paramétrage de ton composant
        Dernière édition par PieceOfCake à 07/03/2014, 09h04
        Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

        Commentaire


        • #5
          Re : mes icônes et images jouent à cache-cache

          Envoyé par PieceOfCake Voir le message
          le composant qui génère la carte (et les icônes correspondantes ?) qui dysfonctionne
          pourquoi y a-t-il le même problème sur les pages où le plugin ne fonctionne pas ?
          exemple ICI

          j'ai désactivé le plugin, vidé tous les caches et c'est pareil

          je voudrais être sûr avant de faire remonter le problème au concepteur du plugin
          (plugin GPXTrackMap)
          Dernière édition par Sergio à 07/03/2014, 09h25

          Commentaire


          • #6
            Re : mes icônes et images jouent à cache-cache

            Même problème mais avec un effet de bord curieux!

            la première fois, l'image affichée a comme définition <img href="/images etc etc
            après le rafraichissement, la même image a comme définition <im href="images etc etc

            sans le / devant le répertoire image, donc faisant ainsi référence à la page courante. J'ai du mal à comprendre pourquoi le chemin change sur l'opération de rafraichissement. Peut être pas lié au comportement d'un plugin, mais à celui du template ou à une paramétrie erronée quelque part.

            Es tu sûr de la version des plugins et composants que tu utilises ?
            Tu dis avoir désactive le plugin de cache (sage résolution, il n'est utile que dans des cas très ciblés et pose plein de problèmes collatéraux), mais utilises tu le cache Joomla ou les caches des plugins sur la page et comment l'as tu (ou les as tu) paramétré dans ce cas ?
            Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

            Commentaire


            • #7
              Re : mes icônes et images jouent à cache-cache

              Envoyé par PieceOfCake Voir le message
              Peut être pas lié au comportement d'un plugin, mais à celui du template
              j'ai modifié le template c'est encore pareil



              Envoyé par PieceOfCake Voir le message
              Es tu sûr de la version des plugins et composants que tu utilises ?
              sûr ? ça veut dire à jour ? oui
              et ce ne sont que des Composants Plugins Modules de http://extensions.joomla.org/


              Envoyé par PieceOfCake Voir le message
              Tu dis avoir désactive le plugin de cache (sage résolution, il n'est utile que dans des cas très ciblés et pose plein de problèmes collatéraux), mais utilises tu le cache Joomla ou les caches des plugins sur la page et comment l'as tu (ou les as tu) paramétré dans ce cas ?
              alors dans ce plugin Système-Cache j'avais désactivé le cache du navigateur mais ça continuait
              j'ai désactivé complètement le plugin et voilà que ça fonctionne à nouveau !!
              problème réglé

              mais pourquoi ce plugin ne fonctionne pas ???

              Commentaire


              • #8
                Re : mes icônes et images jouent à cache-cache

                ouh là comme tu y vas fort.

                Le plugin de cache fonctionne parfaitement. Le problème est que son maniement est très délicat. Je te propose de lire cet article (basé sur Joomla 1.7, mais il y a le pendant sur le même site pour Joomla 3, pas pour Joomla 2.5, mais tu pourras transposer je pense) :
                http://alphadesign.fr/joomla/tutorie...-explique.html

                Ensuite, si le problème est réglé, merci de passer le post en résolu

                Cordialement
                Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins

                Partenaire de l'association

                Réduire

                Hébergeur Web PlanetHoster
                Travaille ...
                X