Problème de cache des métas quand plusieurs templates

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Problème de cache des métas quand plusieurs templates

    Je rencontre un problème qui risque de nuire à mon référencement,
    et ce problème est le même sur mon site joomla 1.7 que sur le joomla 1.5

    J'ai un site à 3 templates:
    - un template general
    - un template pour tablette
    - un template pour mobile

    J'ai créé 3 menus:
    - un menu general avec un lien vers la page d'accueil générale (page d'accueil au format blog)
    - un menu tablette avec un lien vers la page d'accueil tablette (page d'accueil au format blog) - itemid 390
    - un menu mobile avec un lien vers la page d'accueil mobile (page d'accueil au format blog) - itemid 389

    J'ai mis en place un plugin qui redirige vers le bon template selon le user agent de l'utilisateur,
    if($tablet ){
    $app->setTemplate("tablet");
    $this->itemid=390;
    $menu->setDefault($this->itemid,'*');
    }elseif($mobile){
    $app->setTemplate("mobile");
    $this->itemid=389;
    $menu->setDefault($this->itemid,'*');
    }

    Mon plugin de redirection marche parfaitement il redirige bien vers le bon template,
    le problème est que la balise title et les balises metas se mettent en cache, exemple:
    je suis sur ma tablette, j'appelle mon site et j'ai le title "mon site optimisé pour tablette", si je vais sur mon mobile que j'appelle mon site : j'ai bien le template pour mobile mais le title est "mon site optimisé pour tablette", si je vide le cache joomla et que je rappelle le site sur mon mobile, j'ai bien comme title "mon site optimisé pour mobile" et si je vais ensuite sur ma tablette le title devient "mon site optimisé pour mobile" bien que le template soit celui de la tablette... il en va de même pour les metas description et les metas keywords...


    Au niveau de la gestion de mon cache:
    J'ai un cache conservateur par fichiers
    les modules de menu ont le cache désactivé
    et le plugin system cache est désactivé

    Si quelqu'un a déjà eu ce problème, je veux bien qu'il éclaire ma lanterne
    car je ne vois pas quoi faire de plus pour résoudre ce problème,
    j'ai peur que ça perturbe mon réfrencement si les metas pris en compte pour le site général sont un coup ceux pour le site mobile et le coup d'après pour le site tablette, et la fois d'après ceux du site général,

    merci par avance à quiconque aura une info utile

  • #2
    Re : Problème de cache des métas quand plusieurs templates

    Bonjour,

    Est-ce qu'on peut voir le site ?
    Est-ce que le cache est réellement nécessaire ? Je ne pense pas qu'il soit mieux gérable que ça, malheureusement.

    J'ai trouvé quelques explications sur les redirections assez intéressantes : http://googlewebmastercentral.blogsp...rsions-of.html

    (Si vous avez un site en 1.7, il faudrait aussi le mettre à jour.)
    Sekator.ch, créateur de sites web : http://sekator.ch

    Commentaire


    • #3
      Re : Problème de cache des métas quand plusieurs templates

      Salut,

      Par quels moyens as-tu renseigné ces balises pour chaque template ?

      Commentaire


      • #4
        Re : Problème de cache des métas quand plusieurs templates

        Envoyé par alanp Voir le message
        Bonjour,

        Est-ce qu'on peut voir le site ?
        Est-ce que le cache est réellement nécessaire ? Je ne pense pas qu'il soit mieux gérable que ça, malheureusement.


        (Si vous avez un site en 1.7, il faudrait aussi le mettre à jour.)
        Bonjour,

        voici l'url de mon site:

        http://www.jeu-test-ma-memoire.com/

        et pour répondre à ta question de part la taille des menus, je ne peux malheureusement pas me passer du cache

        Commentaire


        • #5
          Re : Problème de cache des métas quand plusieurs templates

          Envoyé par kursus Voir le message
          Salut,

          Par quels moyens as-tu renseigné ces balises pour chaque template ?
          Salut,

          En fait, après vérification, le problème ne porte que sur la balise title, car les metas descriptions et keywords sont celles de la config générale, et pour renseigner les balises title je l'ai fait au niveau de chaque item de menu correspondant aux différentes home (dans paramètres système):
          - home générale - title: "Jeux et tests de mémoire en ligne"
          - home tablette - title: "Jeux de memory pour tablette"
          - home mobile - title: "Jeux de memory pour smartphone"
          qui sont toutes les 3 de type "Page d'accueil au format blog"

          merci pour vos réponses

          Commentaire


          • #6
            Re : Problème de cache des métas quand plusieurs templates

            Quelle est la page par défaut du site ? Vu que tu ne peux pas en choisir plus d'une.

            Sinon ton site est en 1.5 là ?!

            Commentaire


            • #7
              Re : Problème de cache des métas quand plusieurs templates

              Envoyé par kursus Voir le message
              Quelle est la page par défaut du site ? Vu que tu ne peux pas en choisir plus d'une.

              Sinon ton site est en 1.5 là ?!

              l'accueil par défaut c'est la home générale,

              effectivement ce site est en 1.5 mais j'ai le même problème sur la version anglaise qui elle est sur un joomla 1.7 :
              http://www.memozor.com

              Commentaire


              • #8
                Re : Problème de cache des métas quand plusieurs templates

                Comment effectues-tu la détection du device ? Poste ton code.

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins

                Partenaire de l'association

                Réduire

                Hébergeur Web PlanetHoster
                Travaille ...
                X