Google m'indique des liens mort, que je n'ai pas crée avec Xmap

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Google m'indique des liens mort, que je n'ai pas crée avec Xmap

    Bonjour, je me tourne vers le forum une fois de plus, car je ne trouve pas la raison de mon problème.

    Depuis quelque temps déjà, Google m'indique des URL introuvable.
    Et c'est bien normal, car ces URL n'excites pas. En les lisant je me suis aperçu que c’était un mélange d'URL Français & Anglais.
    Mon site:
    www.location-lanjulien.fr en version 2.5.14
    Paramètres SEO:

    Réécriture d'URL en clair (SEF): Oui
    Réécriture au 'vol' des URL: Oui
    Ajouter un suffixe aux URL: Non
    Alias Unicode: Non

    Mon site fonctionne sous deux langues FR & EN.

    Voici mon plan xmap:
    http://www.location-lanjulien.fr/ind...component&id=1

    Déjà premier problème: il n'affiche que les liens d'une des deux langues;
    Quand mon site est ouvert en Français, il m'affiche que les liens FR.
    Si je bascule mon site en Anglais et que je rafraichis mon Xmap, il n’affiche que les URL en EN.

    deuxième problème:
    Sous google, je trouve des Url, avec le début en anglais et la fin en Français:

    http://www.location-lanjulien.fr/en/...s-reservations


    J'ai essayer en désactivant la réécriture et en vidant le cache, mais après plusieurs mois rien ne change.

    Ces problèmes sont apparue, après la migration de mon site chez OVH.
    J'avais du, à cette époque désactivé et réactiver mes Réécriture URL et vider le cache, pour que mon site fonctionne correctement.

    J'ai aussi refait un plan de site mais aucun changement non plus.


    Quelqu'un a une idée???

    Merci d'avance
    Dernière édition par tygweno29 à 16/11/2013, 11h31

  • #2
    Re : Google m'indique des liens mort, que je n'ai pas crée avec Xmap

    Bonjour,

    Voir cette discussion http://joomla.vargas.co.cr/en/forum?...03b57&start=10
    Pas de demande de support par MP.
    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

    Commentaire


    • #3
      Re : Google m'indique des liens mort, que je n'ai pas crée avec Xmap

      Envoyé par jisse03 Voir le message
      bonjour
      voir aussi la doc de l'auteur sur le multilinguisme (en anglais)
      http://www.jooxmap.com/documentation...temap-xml.html

      et mes réflexions ici http://www.jooxmap.com/forum/general...t-working.html
      il semble que l'on puisse supprimer des liens vers des pages inexistantes (sans doute à tort all languages) sur l'interface du composant
      ---> ajout après tests
      apres quelques tests, il vaut mieux supprimer le mauvais parametrage cause de l'erreur :des liens de menu en "toutes langues" qui provoquent ces pages inexistantes
      bon courage
      Dernière édition par effidoc à 17/11/2013, 11h19

      Commentaire


      • #4
        Re : Google m'indique des liens mort, que je n'ai pas crée avec Xmap

        Bonsoir, merci de votre réactivité
        J'ai lus vos infos et j'ai donc rajouté ce qui suis à .htaccess*
        ################################################## ########
        # English sitemap
        RewriteCond %{REQUEST_URI} ^/en/sitemap.xml
        RewriteRule .* /index.php?option=com_xmap&id=1&view=xml&lang=en

        # français sitemap
        RewriteCond %{REQUEST_URI} ^/fr/sitemap.xml
        RewriteRule .* /index.php?option=com_xmap&id=1&view=xml&lang=fr
        ################################################## ########
        Pour info voici le type de liens que je trouve sur google admin
        http://www.location-lanjulien.fr/en/...s-reservations
        http://www.location-lanjulien.fr/en/acces/la-maison

        Exemple: acces et la-maison sont deux menus du même niveau en Français et ils se retrouvent à la suite sur le language en Anglais!!

        Une Belle salade URL!!!!

        Pourtant mon xmap ne me montre pas d'URL de ce genre????

        Je vais bien voir si cela change quelque chose!!
        Dernière édition par tygweno29 à 18/11/2013, 19h37

        Commentaire


        • #5
          Re : Google m'indique des liens mort, que je n'ai pas crée avec Xmap

          Bonsoir,
          j'ai la même chose :
          sans doute due à une anomalie que j'ai signalé dans le forum des langues, : si un internaute trouve votre page en francais dans google et que sa langue est l'anglais, le répertoire anglais se glisse dans l'url et provoque une erreur 404.
          le moderateur du forum m'a dit que c'était de ma faute, que chez lui avec ses 18 langues tout était nickel ; mais je ne suis pas du tout convaincue.

          du coup j'utilise le composant redirection (natif joomla avec plugin) vers la page en anglais pour éviter ces pages 404.
          d'ailleurs un conseil : ayez en haut de votre page d'erreur les liens de menus de votre site et le module de langue pour que l'internaute puisse continuer à naviguer dans votre site. et inscire 404 ne parle pas au touriste moyen, expliquez lui plutot ce qui se passe et conseillez lui d'utiliser le menu.

          Commentaire

          Annonce

          Réduire
          1 sur 2 < >

          C'est [Réglé] et on n'en parle plus ?

          A quoi ça sert ?
          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
          Comment ajouter la mention [Réglé] à votre discussion ?
          1 - Aller sur votre discussion et éditer votre premier message :


          2 - Cliquer sur la liste déroulante Préfixe.

          3 - Choisir le préfixe [Réglé].


          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

          2 sur 2 < >

          Assistance au forum - Outil de publication d'infos de votre site

          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

          UTILISER À VOS PROPRES RISQUES :
          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

          Problèmes connus :
          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

          Installation :

          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

          Archive zip : https://github.com/AFUJ/FPA/zipball/master

          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
          et remplacer www. votresite .com par votre nom de domaine


          Exemples:
          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/
          Pour executer le script: http://www..com/fpa-fr.php

          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/cms/
          Pour executer le script: http://www..com/cms/fpa-fr.php

          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
          Voir plus
          Voir moins

          Partenaire de l'association

          Réduire

          Hébergeur Web PlanetHoster
          Travaille ...
          X