Réécriture d'URL dans les articles ??!!

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Réécriture d'URL dans les articles ??!!

    Bonjour à tous,

    je ne sais pas trop si je poste dans le bon forum, mais il me semble que mon problème vient du SEF, si je ne suis pas au bon endroit, merci de déplacer ce post

    Voici le problème:
    j'ai écrit un article sur mon site foo.fr, et dans cet article, j'ai un lien de téléchargement pour une application iPhone, comme ceci:

    Code HTML:
    <a href="itms-services://?action=download-manifest&amp;url=http://foo.fr/dir/app.plist"><img src="dir/app.png" border="0" title="Télécharger l'appli" width="100" height="100" align="center" /></a>
    J'enregistre mon article, et quand je clique sur le lien sur le site, l'url vers laquelle je tends est la suivante:
    Code HTML:
    foo.fr/itms-services://foo.fr?action=download-manifest&amp;url=http://foo.fr/dir/app.plist
    Et quand je retourne sur l'article (backend) je me rends compte que l'URL a été réécrite lors de l'enregistrement, quoi que je fasse, l'article enregistre toujours:
    Code HTML:
    itms-services://foo.fr?action=download-manifest&amp;url=http://foo.fr/dir/app.plist
    Il y a donc une double réécriture:
    - la première à l'enregistrement de l'article (qui rajoute itms-services://foo.fr?action....)
    - la seconde, quand je clique sur le lien (qui rajoute foo.fr/itms-services://....)

    SEF est activé sur mon site, et je soupçonne fortement que la réécriture vienne de lui (et/ou des règles htaccess liées)

    Avez-vous une idée pour régler ce problème?

    Merci d'avance
    Dernière édition par Raz-X à 24/02/2014, 14h11

  • #2
    Re : Réécriture d'URL dans les articles ??!!

    Bonjour,

    a mon avis il n'y a pas de rapport avec SEF activé mais plutot un problème avec l'éditeur
    Quel éditeur utilises tu par defaut ?
    Met tu bien le http:// dans ton lien ?
    “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr
    Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérer à l'AFUJ https://www.joomla.fr/association/adherer

    Commentaire


    • #3
      Re : Réécriture d'URL dans les articles ??!!

      Bonjour,

      Le problème vient des règles de validation du code HTML dans l'éditeur.
      Basculer en mode HTML d el'éditeur pour inssérer ce type de lien, et enregistrer sans rebasculer dans l'éditeur WySIWYG.

      Ou s'il s'agit de JCE en tant qu'éditeur, passer dans la configuration du profil standard administrateur, et désactiver le nettoyage de code sur ce profil.
      Pas de demande de support par MP.
      S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

      Commentaire


      • #4
        Re : Réécriture d'URL dans les articles ??!!

        Merci de vos réponses

        @manu93fr: justement, c'est n'est pas une url en "http:" mais bien "itms-services" qui est interprété sur iOS pour réaliser le téléchargement et l'installation des applications.

        @jisse03: Je regarde du côté de l'éditeur et vient donner le résultat (l'aditeur est TinyMCE)

        Commentaire


        • #5
          Re : Réécriture d'URL dans les articles ??!!

          Bon, première étape validée!
          le foo.fr qui s'intercalait dans itms-services://foo.fr?action... a disparu, cela venait bien de l'éditeur WYSIWYG (que j'ai désactivé au passage)

          Cependant, il me reste toujours le problème du foo.fr/itms-services qui vient s'ajouter au moment où je clique sur le lien dans l'article, et là, je suis presque sûr que ça vient de SEF... Sûrement une règle à ajouter dans le htaccess pour que la réécriture ne se fasse pas dans ce cas précis... (Quand je regarde dans l'éditeur, l'url renseignée est la bonne, même après enregistrement, c'est donc après que ça se passe).

          J'ai regardé l'url dans mon article, et le foo.fr est déjà présent au début de l'url quand la page est chargée, la réécriture doit se faire au moment de la génération de la page :S

          Une idée?
          Dernière édition par Raz-X à 24/02/2014, 14h36

          Commentaire


          • #6
            Re : Réécriture d'URL dans les articles ??!!

            Mes doutes sont confirmés:

            quand je désactive le plugin SEF de Joomla, tout fonctionne correctement.
            J'ai lu quelques posts sur internet qui soulèvent une incompatibilité de certains plugins SEF avec les liens itms-services (entre autres). Je vais essayer avec d'autres plugins SEF (sh404SEF, joomSEF...) en attendant que des génies se manifestent sur ce post .

            Je vous tiens au courant des mes avancées

            Commentaire


            • #7
              Re : Réécriture d'URL dans les articles ??!!

              http://stackoverflow.com/questions/8...p-distribution traite de ce problème, et du ? qui doit être encodé.
              Pas de demande de support par MP.
              S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

              Commentaire


              • #8
                Re : Réécriture d'URL dans les articles ??!!

                et en prime, une autre suggestion http://stackoverflow.com/questions/4...vices-protocol
                Pas de demande de support par MP.
                S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X