Qui veut tester mtupdate avec Mootools Core 1.2.5 ?

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Qui veut tester mtupdate avec Mootools Core 1.2.5 ?

    Bonjour,

    j'ai updaté le fichier mootools.js dans le plugin mtupdate
    --> /plugins/system/mtupgrade/mootools.js
    avec Mootools Core 1.2.5

    Le fichier modifié est là :
    http://www.box.net/shared/crm8h31o91
    Le fichier zippé est là :
    http://www.box.net/shared/hqurhfhjpk

    Le fichier est de 116K+-, comme le précédent

    L'annonce de l'update est là :
    http://mootools.net/blog/
    L'adresse de téléchargement de core.js 1.2.5 est là
    http://mootools.net/download
    La description des modifs appliquées à Mootools Core.js est

    Perso, j'ai testé sur les grands classiques en back et front sur la 1.5.20:
    modal, tooltip, accordion
    Sur des scripts externes (maximenu_ck , pixSearch, par exemple)
    Tout ce qui fonctionnait, fonctionne.
    Tout ce qui pose problème, continue à poser pb.

    Si je pouvais avoir des retours de test ....
    ce serait top.

    Merci.

    NB : explication de mtupdate
    le plug mtupdate override le fichier mootools.js de
    /media/system/js/mootools.js
    avec le fichier mootools.js de
    /plugins/system/mtupgrade/mootools.js
    qui comprend core.js, une version allégée de more.js et un script d'upgrade de 1.12 vers 1.2

    tout ceci dans le même fichier, à 116k +-
    et avec une activation dudit fichier (qui remplace l'ancien) en front et en back

    j'ai simplement remplacé la partie core 1.2.4.x, par le nouveau core 1.2.5
    Dernière édition par ghazal à 18/09/2010, 14h43
    “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

  • #2
    on va essayer de faire ça, mais comme tu as déjà testé mes extensions... lol
    Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
    http://www.template-creator.com Outil de création de templates
    Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

    Commentaire


    • #3
      bug mtupgrade

      Bonjour,
      Merci tout d'abord pour cette contribution.
      je remonte le topic car je n'arrive pas à activer le plugin sans que mon site ne soient rempli d'erreurs JS (mootools et (ou) jquery). (joom 1.5.22)

      Composants et Modules installés qui semblent mer....

      Fabrik
      goboslide
      kunena
      xmap

      (tous dans leurs dernières version)

      Avez vous des infos complémentaires à propos de votre Maj ?

      Merci d'avance
      N'oubliez pas de passer vos post en "réglé" c'est très utile à celui qui cherche, ...et qui se perd http://forum.joomla.fr/announcement.php?f=133 mais trouvera grâce à vous
      profil : http://quelprestataire.fr/robert-suzanne+texier"

      Commentaire


      • #4
        Bonjour,

        Petit mot pour te dire "Désolé" mais je dois passer mon tour; je suis à 125% pris sur autre chose et cela ne me sera pas possible.

        Bon courage pour déloger les bestioles.
        Christophe (cavo789)
        Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
        Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
        Mes logiciels OpenSource : https://www.avonture.be

        Commentaire


        • #5
          mootools 1.2.5

          Merci quand même pour la réponse

          Bon ben j'ai testé la bête

          sur mon bac à sable

          http://beta.web-conception.eu

          Il y a un peu du mieux


          goboslide semble préférer mais j'ai encore ces 2 erreurs

          Code HTML:
          Erreur*: jQuery.kunena_cookie is not a function
          Fichier Source*: http://beta.web-conception.eu/components/com_kunena/template/default/js/kunenaforum.min.js
          Ligne*: 135
          
          if (jQuery.kunena_cookie("upshrink_" + imgId) == 1) 
          ---------------------------------------------------------------------------
          Code:
          Erreur*: Browser.Engine is undefined
          Fichier Source*: http://beta.web-conception.eu/plugins/system/mtupgrade/mootools.js
          Ligne*: 132
          
          var c=function(m){return(g[m]||(g[m]={}));};var h=function(o,m){if(!o){return;}var n=o.uid;if(m!==true){m=false;}if(Browser.Engine.trident){if(o.clearAttributes){var r=m&&o.cloneNode(false);
          --------------------------------------------------------------------------

          Le remove mootools 1.1 de kuneana est activé mais le désactiver ne semble pas améliorer la sauce

          Browser.Engine is undefined
          n'apparait pas sur toutes les pages

          Il y a peut-être un rapport avec les toolstips de Glossary

          Fabrik semble mieux fonctionner , c'est déjà ça.

          Si il y a d'autres retours d'expérience je suis preneur

          Tous mes tests sont faits avec FF 3.6 et firebug
          N'oubliez pas de passer vos post en "réglé" c'est très utile à celui qui cherche, ...et qui se perd http://forum.joomla.fr/announcement.php?f=133 mais trouvera grâce à vous
          profil : http://quelprestataire.fr/robert-suzanne+texier"

          Commentaire


          • #6
            Je rectifie Goboslide part encore en vrille
            N'oubliez pas de passer vos post en "réglé" c'est très utile à celui qui cherche, ...et qui se perd http://forum.joomla.fr/announcement.php?f=133 mais trouvera grâce à vous
            profil : http://quelprestataire.fr/robert-suzanne+texier"

            Commentaire


            • #7
              Grr, je viens d'écrire un long message de réponse qui est parti en fumée GRRR
              Je recommence.

              @abmag
              Merci pour tes retours.
              Après avoir distribué ce fichier à droite à gauche, tu es le premier à prendre la peine de signaler des erreurs .
              Je rectifie Goboslide part encore en vrille
              Un lien d'erreur à montrer ?

              Kunena
              As-tu updaté vers la derniere version 1.6.1 ?
              Normalement, annoncée comme jQuery-free.

              Je t'envoie la suite de mes remarques dans un moment. Je dois y aller.
              “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

              Commentaire


              • #8
                Grr, je viens d'écrire un long message de réponse qui est parti en fumée GRRR
                ça , ça fait toujours raler !

                Je te remercie de ta réponse malgré tout rapide

                Je suis étonné que tu n'ais pas eu plus de retours, les problèmes liés à js sont tellement récurrents (faut dire que je cause pas trop le java script)

                Mon site de prod est la http://www.web-conception.eu (update mootools est désactivé)
                le bac a sable est la http://beta.web-conception.eu (je réactive updt mootols -le tien et un module goboslide)

                Je n'ai pas ugradé kunena en 1.6, j'ai du le hacker pas mal pour le rentrer dans ma colonne centrale de 500px, mais je pense que je vais devoir y passer (il est en 1.5.3)

                Une nouvelle version de CB vient de sortir je l'installerai sans doute demain mais CB ne semble pas poser de problème

                Si tu as besoin d'un compte admin pour le bac a sable, confirme le moi, je te l'envoie par MP

                Merci d'avance
                Dernière édition par abmag à 30/11/2010, 20h37
                N'oubliez pas de passer vos post en "réglé" c'est très utile à celui qui cherche, ...et qui se perd http://forum.joomla.fr/announcement.php?f=133 mais trouvera grâce à vous
                profil : http://quelprestataire.fr/robert-suzanne+texier"

                Commentaire


                • #9
                  Envoyé par abmag Voir le message
                  Je rectifie Goboslide part encore en vrille
                  En fait j'ai l'impression que quand j'active goboslide maintenant, c'est la console de firebug qui perd les pédales
                  N'oubliez pas de passer vos post en "réglé" c'est très utile à celui qui cherche, ...et qui se perd http://forum.joomla.fr/announcement.php?f=133 mais trouvera grâce à vous
                  profil : http://quelprestataire.fr/robert-suzanne+texier"

                  Commentaire


                  • #10
                    salut abmag !
                    petite question, as-tu besoin d'updater ta version de mootools ? tu as une extension qui le demande? c'est juste comme ça, parce que si tu le fais juste pour le plaisir c'est du travail inutile.
                    j'ai vu le browser engine en erreur, par contre tes urls sont fausses ! merci de les mettre à jour...
                    Vive Joomla! http://www.joomlack.fr Tutoriels et extensions pour Joomla!. Livre création de template Joomla de plus de 200 pages.
                    http://www.template-creator.com Outil de création de templates
                    Module Maximenu CK - Megamenu, multicolonnes, chargement de module, description de lien, deroulement animé - Compatible Virtuemart, Hikashop

                    Commentaire


                    • #11
                      Bonsoir CEd1870

                      Envoyé par ced1870 Voir le message
                      salut abmag !
                      petite question, as-tu besoin d'updater ta version de mootools ? tu as une extension qui le demande? c'est juste comme ça, parce que si tu le fais juste pour le plaisir c'est du travail inutile.
                      Cela fait un bout de temps que j'en avais marre de voir les erreurs JS sur mon site (et d'autres), le post de Ghazal m'a donné envie de m'y repencher (mais bon je vais essayer de ne pas chuter) surtout que ce nouveau plug de Joomla m'en créait de nouvelles.
                      De plus les erreur JS sont assez pénalisantes avec IE qui demande a chaque fois si on doit continuer les script (suivant le réglage bien sur mais les utilisteur lambda n'ont pas accès à ce réglage, et ça la fout un peu mal d'afficher des erreurs JS quand on vend du site internet
                      Envoyé par ced1870 Voir le message
                      j'ai vu le browser engine en erreur, par contre tes urls sont fausses ! merci de les mettre à jour...
                      Merci de me l'avoir signalé, il est grand temps que j'aille me coucher
                      N'oubliez pas de passer vos post en "réglé" c'est très utile à celui qui cherche, ...et qui se perd http://forum.joomla.fr/announcement.php?f=133 mais trouvera grâce à vous
                      profil : http://quelprestataire.fr/robert-suzanne+texier"

                      Commentaire


                      • #12
                        Bon, je reprends :
                        * le comp com_glossary
                        components/com_glossary/nicetitle.js

                        c'est un script js antique qui prend encore en compte Netscape ...hem...

                        Exemple ici : http://beta.web-conception.eu/bureau...ureau-en-ligne
                        avec l'erreur Moo sur les browsers.
                        Essaye de commenter/enlever ce morceau de code sur nicetitle.js pour tester :
                        (bon sang, le code ne passe pas sur ce forum, reGRRR
                        je le colle sur un autre serveur, ici :
                        https://gist.github.com/722235 )
                        Tu enlèves tout le code indiqué dans mon exemple du fichier nicetitle.js
                        (que tu conserves dans son intégralité qq part, au cas ou ca fout le souk, lol)
                        On verra comme cela si l'erreur vient d'une incompatibilité avec les fonctions browsers de Moo.

                        *goboslide
                        je ne connais pas
                        re : donne un lien où cela se trouve

                        @++
                        “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

                        Commentaire


                        • #13
                          Petit ajout pour voir l'erreur Kunena, il faut aller dans le menu forum client http://beta.web-conception.eu/support
                          N'oubliez pas de passer vos post en "réglé" c'est très utile à celui qui cherche, ...et qui se perd http://forum.joomla.fr/announcement.php?f=133 mais trouvera grâce à vous
                          profil : http://quelprestataire.fr/robert-suzanne+texier"

                          Commentaire


                          • #14
                            re: erreur Kunena
                            j'ai vu ton forum, mais le mieux ce serait de mettre à jour vers la dernière version de Kunena, pensée pour mieux fonctionner avec Mootools.
                            “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

                            Commentaire


                            • #15
                              Merci Ghazal,

                              Il y a donc bien un problème avec glossary (je me doutais un peu à la lecture du script que le machin avait un côté antédéluvien).
                              Je vais tester tes propals demain car là j'ai les yeux qui commencent à faire des 8

                              Goboslide c'est la banière animée

                              http://www.joohopia.com/joomla-modules.html

                              La version installée est la version free

                              Il existe maintenant une version pro payante, peut-être est-elle plus stable.

                              Ceci dit j'ai l'impression qu'a part l'erreur

                              Pseudo-classe ou pseudo-élément « first » inconnu.
                              Code:
                              : jQuery('#slideshow_15 DIV:first');
                              Il se comporte beaucoup mieux
                              N'oubliez pas de passer vos post en "réglé" c'est très utile à celui qui cherche, ...et qui se perd http://forum.joomla.fr/announcement.php?f=133 mais trouvera grâce à vous
                              profil : http://quelprestataire.fr/robert-suzanne+texier"

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X