afficher un text sur une image

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] afficher un text sur une image

    bonjour
    je souhaite afficher un text sur une image?

    aprés la creation de l'image avec ces dimension elle affiche un charabia
    comment proceder
    merci d'avance
    Connaitre son ignorance est la meilleure part de la connaissance.

  • #2
    Tu peux donner plus d'explications sur ce que tu fais actuellement et ce qui se produit ?
    Qu'affiche l'image ? Peux-tu nous montrer une copie d'écran ?
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      merci bien de la rapidité , voila ce que je reçoit en sortie

      �PNG  ��� IHDR������������n����PLTE�dd����*������IDATX��� 1 �0����5��B����)�v�"r�"�"��� ��.�V]S������y�E��z���`"2���r9��� ���η�M0;���ƞ�f/�A_A���� �؅R݄��J�u7�W�n�,+5 f�#ގ�OU.���������� 5�1������IEND�B`�
      Connaitre son ignorance est la meilleure part de la connaissance.

      Commentaire


      • #4
        Il y a manifestement un problème avec l'image elle-même, pour que ce soit son code qui soit affiché. As-tu essayé avec une autre ?
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          Bonjour,

          Au vue de ce que tu donnes, tu n'affiches pas l'image mais tu l'édites, c'est comme si tu l'ouvrais avec Notepad !

          A+

          Commentaire


          • #6
            +1 pour zepelin.

            Au moment où tu génères le fichier image, tu sembles après coup faire un echo $img. Le browser étant occupé à recevoir du texte de la part de ton serveur; il considère l'image comme étant du textect non comme étant une image.

            Avant d'envoyer l'image vers le client, tu dois coder ceci

            Code PHP:
            Header ("Content-type: image/png"); 
            Christophe (cavo789)
            Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
            Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
            Mes logiciels OpenSource : https://www.avonture.be

            Commentaire


            • #7
              désolé de ce retard de ma réponse
              j'ai deja specifier le header avant la creation de page
              header ("Content-type: image/jpeg");
              tjrs probléme
              je crois que je pass à coté d'un trcu!
              Connaitre son ignorance est la meilleure part de la connaissance.

              Commentaire


              • #8
                Ci-après un lien vers un source que j'ai utilisé pour mon calendrier sportif : http://www.scri8e.com/h/stpats/Shamr...rcle-DAVES.txt

                Il permet de dessiner une puce de couleur.
                Christophe (cavo789)
                Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
                Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
                Mes logiciels OpenSource : https://www.avonture.be

                Commentaire


                • #9
                  merci bien mais le lien ne fonctionne pas
                  Connaitre son ignorance est la meilleure part de la connaissance.

                  Commentaire


                  • #10
                    bon voila
                    dans mon model j'ai creer une fonction pour generer l'image

                    function getimage($email){

                    }
                    j'appel la function depuis ma vue
                    $image=$model->getimage()
                    $this->assignRef('image',$image);
                    dans la page default nous avons
                    echo $image
                    mais ça fonctionne pas!!!!!
                    Connaitre son ignorance est la meilleure part de la connaissance.

                    Commentaire


                    • #11
                      bonjour
                      c'est regeler pas trés propre mais c'est deja ça!
                      http://mtodorovic.developpez.com/php...=page_3#LIII-2
                      http://www.siteduzero.com/tutoriel-3...es-en-php.html
                      merci à tous
                      Connaitre son ignorance est la meilleure part de la connaissance.

                      Commentaire


                      • #12
                        Bonjour,
                        ce que tu as montré plus haut est l'exact résultat du echo $image, c'est à dire l'affichage sous forme de texte de l'image comme l'ont dit Zepelin et Cavo. Si ce qu tu veux afficher c'est l'image elle même, tu dois fait un truc comme :
                        Code:
                        echo '<img src="'.$CheminCompletVersMonImage.'" />';
                        la difficulté pour toi étant de remplir $CheminCompletVersMonImage (voire avant de mettre l'image quelque part) puisque si je suis bien elle est incluse dans un objet message.
                        Schtroumpfe toi le Schtroumpf t'aidera.
                        Je ne schtroumpfe pas aux demandes de schtroumpf par MP.

                        Commentaire


                        • #13
                          merci grand Grand Schtroumpf
                          c'etait presque ça , mais j'ai opter vers une meilleur solution c'est la création de l'image aprés l"insertion !
                          generer une image du mail parexemple et lui faire appel dans la vue ( moins de ressource du système ).
                          Connaitre son ignorance est la meilleure part de la connaissance.

                          Commentaire


                          • #14
                            je profite pour poser une question qui demeure inexpliquée
                            je je creer une image avec imagecreate et j'essaye de l'afficher dans la vue sa ne marche pas?
                            le texte bizarre que sa genere est dus a la bibliothèque GD,meme en spécifiant le head au navigateur?
                            Connaitre son ignorance est la meilleure part de la connaissance.

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X