Affichage introuvable quand j'utilise no_html=1 pour afficher une vue

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Affichage introuvable quand j'utilise no_html=1 pour afficher une vue

    Salut le forum,

    Je développe un composant pour un client et j'ai un souci. J'essaie d'écrire une vue qui génère un flux RSS.

    J'ai développé la vue sans souci, la sortie est correcte (un XML de flux RSS bien standard) mais il faut maintenant que je l'affiche sans HTML autour, évidemment. J'utilise comme URL pour afficher "/index.php?rss&tmpl=component" et ça sort bien le composant seul, sans menus ni modules. Par contre la sortie est toujours entourée d'une page HTML standard avec des balises <html>, <head>, etc. Il faut que j'arrive à enlever ça pour que mon XML soit ok. J'essaie alors d'utiliser cette URL : "/index.php?rss&tmpl=component&no_html=1" mais quand je fais ça, j'ai une erreur 500 "Affichage introuvable". Je ne comprends pas.

    Le composant s'appelle com_reco.
    La vue s'appelle RecoViewHomepage.
    Dans le view.html.php, je change le layout par défaut ("default.php") avec ces lignes de code :

    Code:
    		if(isset($_REQUEST["rss"])) $tpl="rss"; 
    		parent::display($tpl);
    Sans le no_html dans l'URL, ça fonctionne et le layout "default_rss.php" est bien chargé depuis le répertoire tmpl.
    Avec le no_html ajouté, j'ai une erreur 500 "Affichage introuvable".

    Quelqu'un peut-il m'aider?
    Merci d'avance !

  • #2
    Re : Affichage introuvable quand j'utilise no_html=1 pour afficher une vue

    Bonjour,

    Le mieux est de créer un fichier view.xml.php voir le lien suivant pour plus d'infos : http://docs.joomla.org/Handling_the_..._Ajax_requests

    De mémoire, je crois qu'il faut ajouter format=xml dans le lien pour qu'il aille chercher la bonne vue.

    Damien

    Damien
    www.Crac-Design.com

    Commentaire


    • #3
      Re : Affichage introuvable quand j'utilise no_html=1 pour afficher une vue

      Bonjour

      +1 avec ZDamienZ; tu dois juste mettre &format=xml ou &format=raw et développer le view.xxx.php correspondant.

      Sauf erreur de ma part, &no_html=1 est un reliquat de Joomla 1.0. Il serait grand temps d'oublier cette antiquité :-)
      Christophe (cavo789)
      Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
      Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
      Mes logiciels OpenSource : https://www.avonture.be

      Commentaire


      • #4
        Re : Affichage introuvable quand j'utilise no_html=1 pour afficher une vue

        ok donc effectivement, no_html=1 est une relique, à ne plus utiliser (désoléééééééé! ;-))

        Et donc ça fonctionne mais attention, c'est subtil, malgré tout.
        - dans la requète : format=xml (pour faciliter la déclaration du MIME type, plus sûr que format=raw)
        - la vue appelée est bien view.xml.php du coup, mais attention, sans autre intervention elle appelle le layout par défaut
        - donc bien ajouter la même ligne ( if(isset($_REQUEST["rss"])) $tpl="rss"; ) dans le view si on veut charger un autre layout

        Et maintenant ça maaaaaaaarche!
        Merci le forum :-)

        Commentaire


        • #5
          Re : Affichage introuvable quand j'utilise no_html=1 pour afficher une vue

          Envoyé par guzabi Voir le message
          $_REQUEST["rss"]
          Aaargh... Encore une vieille bestiole

          JRequest::getCmd('rss') est bien meilleur.

          http://docs.joomla.org/JRequest::getCmd/11.1
          Christophe (cavo789)
          Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
          Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
          Mes logiciels OpenSource : https://www.avonture.be

          Commentaire


          • #6
            Re : Affichage introuvable quand j'utilise no_html=1 pour afficher une vue

            Ouiiiii je sais, j'ai fait ça vite :-)
            Allez, je le fais bien, maintenant :-)

            Commentaire


            • #7
              Re : Affichage introuvable quand j'utilise no_html=1 pour afficher une vue

              Envoyé par guzabi Voir le message
              Ouiiiii je sais, j'ai fait ça vite :-)
              Et que je ne te reprenne plus, hein, à programmer "à la Joomla 1.0" car sinon cela va chauffer pour ton matricule



              (pour ceux qui lirait ce post : il faut absolument éviter $_REQUEST qui n'est pas sécurisé. Joomla met à disposition JRequest:: qui permet d'obtenir la même information mais de manière sécurisée et ça, c'est bien meilleur pour la protextion de votre site)
              Christophe (cavo789)
              Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
              Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
              Mes logiciels OpenSource : https://www.avonture.be

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins

              Partenaire de l'association

              Réduire

              Hébergeur Web PlanetHoster
              Travaille ...
              X