Un souci dans la création de mes tables lors de l'installation de mon composant

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Un souci dans la création de mes tables lors de l'installation de mon composant

    Bonjour

    J'obtiens un message disant que mon sql est vide à tel ligne (qiue je n'ai pas)
    Voici le code sql de mes tables
    Code:
    CREATE TABLE IF NOT EXISTS `#__gest_joueurs_` (
      `ID` int(11) NOT NULL AUTO_INCREMENT,
      
      `asset_id` INT(10) UNSIGNED NOT NULL DEFAULT '0',
      
      `Nom_du_joueur` int(11) NOT NULL,
      `Nom_Cache` varchar(255) NOT NULL,
      `Date_Naiss` date NOT NULL,
      `telephone` varchar(255),  
      `Groupe` varchar(255),
      `Email` varchar(255),
      `Responsable` VARCHAR(255)  ,
      `created_by` INT(11)  NOT NULL ,
      PRIMARY KEY (`ID`)
    )DEFAULT COLLATE=utf8_general_ci; ;
    CREATE TABLE IF NOT EXISTS `#__gest_equipe_` (
    `id` int(11) UNSIGNED NOT NULL AUTO_INCREMENT,
    
    `asset_id` INT(10) UNSIGNED NOT NULL DEFAULT '0',
    
    `equipe` VARCHAR(255)  NOT NULL ,
    `created_by` INT(11)  NOT NULL ,
    PRIMARY KEY (`id`)
    ) DEFAULT COLLATE=utf8_general_ci;
    CREATE TABLE IF NOT EXISTS `#__gest_match_` (
    `id` int(11) UNSIGNED NOT NULL AUTO_INCREMENT,
    
    `asset_id` INT(10) UNSIGNED NOT NULL DEFAULT '0',
    
    `ordering` INT(11)  NOT NULL ,
    `date` DATE NOT NULL ,
    `equipe` INT NOT NULL ,
    `A_domicile` VARCHAR(255) ,
    `Heure_Depart` VARCHAR(255) ,
    `Lieu_match` VARCHAR(255) ,
    `Heure_Rencontre` VARCHAR(255) ,
    `joueur_1` VARCHAR(255) ,
    `joueur_2` VARCHAR(255)  ,
    `joueur_3` VARCHAR(255)  ,
    `joueur_4` VARCHAR(255)  ,
    `joueur_5` VARCHAR(255)  ,
    `joueur_6` VARCHAR(255)  ,
    `joueur_7` VARCHAR(255)  ,
    `joueur_8` VARCHAR(255)  ,
    `joueur_10` VARCHAR(255)  ,
    `joueur_9` VARCHAR(255)  ,
    `joueur_11` VARCHAR(255)  ,
    `joueur_12` VARCHAR(255)  ,
    `joueur_13` VARCHAR(255)  ,
    `joueur_14` VARCHAR(255)  ,
    `Respons_1` VARCHAR(255)  ,
    `Respons_2` VARCHAR(255)  ,
    `Respons_3` VARCHAR(255)  ,
    `Assist_1` VARCHAR(255)  ,
    `Commentaires` VARCHAR(255)  ,
    `created_by` INT(11)  NOT NULL ,
    PRIMARY KEY (`id`)
    ) DEFAULT COLLATE=utf8_general_ci;
    CREATE TABLE IF NOT EXISTS `#__gest_Terrain_` (
    `id` int(11) UNSIGNED NOT NULL AUTO_INCREMENT,
    
    `asset_id` INT(10) UNSIGNED NOT NULL DEFAULT '0',
    
    `Ville` VARCHAR(255)  NOT NULL ,
    `Code_Postal` VARCHAR(255)  NOT NULL ,
    `Adresse` VARCHAR(255)  NOT NULL ,
    `created_by` INT(11)  NOT NULL ,
    PRIMARY KEY (`id`)
    ) DEFAULT COLLATE=utf8_general_ci;
    Voyez vous une erreur pouvant résulter de ce message.

    Merci
    Merci de votre aide

    Cordialement à tous

    La connaissance est l'évolution de l'homme...

  • #2
    Re : Un souci dans la création de mes tables lors de l'installation de mon composant

    mets le préfixe et non #_ qui est pris en charge en passant par joomla mais pas directement dans phpmyadmin
    Christophe
    http://www.webcrea.fr

    Commentaire


    • #3
      Re : Un souci dans la création de mes tables lors de l'installation de mon composant

      Je mets le nom de mon composant à la place du dièse aussi bien pour l'installation local que distante. C'est cela.
      Merci de votre aide

      Cordialement à tous

      La connaissance est l'évolution de l'homme...

      Commentaire


      • #4
        Re : Un souci dans la création de mes tables lors de l'installation de mon composant

        Un question je me posais sur ma base. Dans la table matchs, j'ai un champ nommé 'date' de format DATE. cela ne devrait pas poser de problème ?
        Merci de votre aide

        Cordialement à tous

        La connaissance est l'évolution de l'homme...

        Commentaire


        • #5
          Re : Un souci dans la création de mes tables lors de l'installation de mon composant

          Pas de souci si le nom de champ est entouré de '

          ceci dit ce n'est en général pas une bonne idée de nommer des champs en utilisant des mots réservés
          Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

          Commentaire


          • #6
            Re : Un souci dans la création de mes tables lors de l'installation de mon composant

            Envoyé par PieceOfCake Voir le message
            Pas de souci si le nom de champ est entouré de '

            ceci dit ce n'est en général pas une bonne idée de nommer des champs en utilisant des mots réservés
            Bonjour,

            En SQL standard, DATE est un mot réservé, qui génère une erreur.
            Sous MySQL, en encadrant le nom du champ de backticks, il peut passer.
            Mais c'est la pire chose à faire que d'utiliser un mot-réservé, en particulier maintenant que Joomla! tente une compatibilité multi SGBD, un champ utilisant un mot réservé est absolument non portable en SQL standard.
            Pas de demande de support par MP.
            S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

            Commentaire


            • #7
              Re : Un souci dans la création de mes tables lors de l'installation de mon composant

              Ok je me doutais du commentaire grâce au remarque de dreamviewer qui me mettait le champ d'un autre façon.

              - - - Mise à jour - - -

              Et concernant la réponse apporter webcrea une réponse
              Merci de votre aide

              Cordialement à tous

              La connaissance est l'évolution de l'homme...

              Commentaire


              • #8
                Re : Un souci dans la création de mes tables lors de l'installation de mon composant

                Nota le préfixe est le nom de mon composant avec com_ devant ou uniquement le nom du composant ou le préfixe de la base de donnees et du site
                Dernière édition par BXDRAKAR à 20/03/2014, 14h59
                Merci de votre aide

                Cordialement à tous

                La connaissance est l'évolution de l'homme...

                Commentaire


                • #9
                  Re : Un souci dans la création de mes tables lors de l'installation de mon composant

                  J'ai toujours l erreur suivante
                  Code:
                          JInstaller: :Install: erreur SQL Fonction DB échouée avec le numéro d'erreur 1065
                          Query was empty SQL=;
                          SQL =
                  
                          ;
                  
                          Installation d'un composant : erreur SQL du fichier Fonction DB échouée avec le numéro d'erreur 1065
                          Query was empty SQL=;
                          SQL =
                  
                          ;
                  Merci de votre aide

                  Cordialement à tous

                  La connaissance est l'évolution de l'homme...

                  Commentaire


                  • #10
                    Re : Un souci dans la création de mes tables lors de l'installation de mon composant

                    Envoyé par BXDRAKAR Voir le message
                    Nota le préfixe est le nom de mon composant avec com_ devant ou uniquement le nom du composant ou le préfixe de la base de donnees et du site
                    ?? non le préfixe dont parle webcrea est celui qui a été affecté (aléatoirement) par Joomla lors de la création du site (ou manuellement par toi).
                    Si tu ne le connais pas, tu vas le trouver dans le fichier configuration.php contenu dans la variable $dbprefix. il est placé devant chaque nom de table pour éviter les confusions lorsque plusieurs sites Joomla sont hébergés dans la même base de données mySQL physique
                    Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

                    Commentaire


                    • #11
                      Re : Un souci dans la création de mes tables lors de l'installation de mon composant

                      Cette erreur signifie que la requete SQL est vide, donc que ton installeur ne la trouve pas
                      Pas de demande de support par MP.
                      S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X