Questions AllEvents

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Questions AllEvents

    Bonjour,

    D’abord, félicitations à Christophe pour sa très belle réalisation de AllEvents. Je découvre cette application depuis quelques temps et je la trouve très bien faite, puissante et en plus gratuite, c’est vraiment pas cher.
    Malheureusement je vais aussi ramener mon grain de sel à la suite des petits copains qui ont déjà signalé des problèmes avec FireFox, car j’ai à peu près les mêmes, plus d’autres pas encore évoqués et qui ont peut-être un lien ou pas.

    J’utilise en local comme sur le serveur Joomla ! 1.5.25 et la dernière version de FF chez moi et au bureau :
    - impossible de sauvegarder un évènement, aucun bouton ne répond, ni le bouton retour AR alors que tout fonctionne correctement avec IE (damned !) ; impossible également d’afficher le texte des descriptions ; mais je viens de découvrir que Christophe (cavo789) a fait une suggestion qui a l’air de marcher et que je vais essayer en modifiant le fichier browser.php du composant.

    Mais j’ai aussi en magasin :
    - Dans édition d’un formulaire, la liste déroulante pour « Formulaire d'inscription tiers » ne déroule pas ; il est alors préconisé dans la bulle d’aide d’aller dans les paramètres généraux de AE et dans l’onglet « Global », d’aller dans paramètres avancés et d’activer le « support des plugins » ; cela fonctionnait bien avec SportingEvents, mais ce choix n’apparaît plus dans AE (du moins dans mon backend tel qu’il est aujourd’hui). Késako ?
    - Impossible de sauvegarder le formulaire ou de revenir en arrière : kéblo FF !!! il faut repasser par le choix du composant et les modifs ne sont pas enregistrées
    - Avec IE, les boutons apparaissent verticalement, les uns sous les autres au lieu d’être répartis sur la page : bizarre ! Répartition curieuse aussi avec FF.

    Une autre fonction me pose problème avec FF comme avec IE :
    - impossible d’avoir le choix des inscriptions en ligne sur le frontend, même avec les permissions requises (pb d’installation ? Pourtant refaite 3 fois, ou d’affichage, encore ?) et l’évènement semble pourtant correctement paramétré pour le permettre ; c’est pas FF qui fait ça, c’est pareil avec IE ; j’ai peut-être pas tout compris : voir sur http://www.vvwebsite.com choix « Nouveauté ».

    J’espère ne pas vous avoir trop gavés d’un coup ; j’ai déjà bien fouillé tous ces problèmes, c’est donc un peu forcé et contraint que je m’épands sur le forum, ce qui n’est pas dans mes habitudes. Mais je ne trouve pas de solution. Je vais continuer à chercher et si j’ai du nouveau, promis, je vous en fais part. En attendant, si les « grosses têtes » ont des solutions, qu’ils n’hésitent pas.

    Merci d’avance à tous et bonne année.

    Argol

  • #2
    Re : Questions AllEvents

    Bonjour Argol et merci pour ton appréciation. Je me permets de déplacer ton post pour créer une nouvelle discussion car tes questions sont nombreuses et plus dans la lignée de la discussion que tu as utilisée.

    Envoyé par Argol Voir le message
    Dans édition d’un formulaire, la liste déroulante pour « Formulaire d'inscription tiers » ne déroule pas ; il est alors préconisé dans la bulle d’aide d’aller dans les paramètres généraux de AE et dans l’onglet « Global », d’aller dans paramètres avancés et d’activer le « support des plugins » ; cela fonctionnait bien avec SportingEvents, mais ce choix n’apparaît plus dans AE (du moins dans mon backend tel qu’il est aujourd’hui). Késako ?
    La bulle d'aide n'est plus adaptée; je devrais revoir le texte. La notion "Support des plugins" n'est plus nécessaire car j'ai adopté une autre façon de faire qui ne fait plus planter des plugins tiers comme ceux de Phoca.

    Pour répondre à ta question : tu as installé le plugin AllEvents - Formulaires ? Si pas, faut commencer par là.
    Tu l'as installé ? Quel est le composant de gestion de formulaire que tu as configuré ? Imaginons CKForms : as-tu bien CKForms d'installer sur ton site et, aussi, as-tu installé et publié le plugin content de CKForms ?

    Voici une explication sur le fonctionnement du plugin http://avonture.be/allevents/accueil...gin_formulaire

    Envoyé par Argol Voir le message
    Impossible de sauvegarder le formulaire ou de revenir en arrière : kéblo FF !!! il faut repasser par le choix du composant et les modifs ne sont pas enregistrées
    Pas compris. Pourrais-tu poster une capture d'écran et/ou donner plus de détails ?

    Envoyé par Argol Voir le message
    Avec IE, les boutons apparaissent verticalement, les uns sous les autres au lieu d’être répartis sur la page : bizarre ! Répartition curieuse aussi avec FF.
    Pourrais-tu poster une capture d'écran ?

    Tu parles de quel formulaire ? AllEvents ? Frontend ou backend ?

    Envoyé par Argol Voir le message
    impossible d’avoir le choix des inscriptions en ligne sur le frontend, même avec les permissions requises (pb d’installation ? Pourtant refaite 3 fois, ou d’affichage, encore ?) et l’évènement semble pourtant correctement paramétré pour le permettre ; c’est pas FF qui fait ça, c’est pareil avec IE ; j’ai peut-être pas tout compris : voir sur http://www.vvwebsite.com choix « Nouveauté ».
    Si je comprends bien ta question, voici la réponse : http://avonture.be/allevents/accueil...on_non_affiche

    Envoyé par Argol Voir le message
    J’espère ne pas vous avoir trop gavés d’un coup ; j’ai déjà bien fouillé tous ces problèmes, c’est donc un peu forcé et contraint que je m’épands sur le forum, ce qui n’est pas dans mes habitudes. Mais je ne trouve pas de solution. Je vais continuer à chercher et si j’ai du nouveau, promis, je vous en fais part. En attendant, si les « grosses têtes » ont des solutions, qu’ils n’hésitent pas.
    Pas de soucis mais as-tu consulté mon blog ? Plus de 300 articles s'y trouvent...
    Christophe (cavo789)
    Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
    Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
    Mes logiciels OpenSource : https://www.avonture.be

    Commentaire


    • #3
      Re : Questions AllEvents

      [QUOTE=cavo789;821181]Bonjour Argol et merci pour ton appréciation. Je me permets de déplacer ton post pour créer une nouvelle discussion car tes questions sont nombreuses et plus dans la lignée de la discussion que tu as utilisée.

      La bulle d'aide n'est plus adaptée; je devrais revoir le texte. La notion "Support des plugins" n'est plus nécessaire car j'ai adopté une autre façon de faire qui ne fait plus planter des plugins tiers comme ceux de Phoca.

      Merci, bien noté.
      Dernière édition par Argol à 13/01/2012, 19h47

      Commentaire


      • #4
        Re : Questions AllEvents

        Pour répondre à ta question : tu as installé le plugin AllEvents - Formulaires ? Si pas, faut commencer par là.
        Tu l'as installé ? Quel est le composant de gestion de formulaire que tu as configuré ? Imaginons CKForms : as-tu bien CKForms d'installer sur ton site et, aussi, as-tu installé et publié le plugin content de CKForms ?

        Voici une explication sur le fonctionnement du plugin http://avonture.be/allevents/accueil...gin_formulaire

        Plugin AE installé : oui
        CKForms installé, plugin publié : oui
        Je revérifie tout et je te tiens au courant

        Commentaire


        • #5
          Re : Questions AllEvents

          Pas compris. Pourrais-tu poster une capture d'écran et/ou donner plus de détails ?
          Pourrais-tu poster une capture d'écran ?
          Tu parles de quel formulaire ? AllEvents ? Frontend ou backend ?

          Pb réglé, problème d'affichage avec FF qui ne se produit pas avec IE -> voir ta solution par le fichier browser.php

          Commentaire


          • #6
            Re : Questions AllEvents

            Si je comprends bien ta question, voici la réponse : http://avonture.be/allevents/accueil...on_non_affiche

            Je vais suivre les indications présentées avec ce lien et je te dirais le résultat.

            Commentaire


            • #7
              Re : Questions AllEvents

              Pas de soucis mais as-tu consulté mon blog ? Plus de 300 articles s'y trouvent...[/QUOTE]

              Oui, bien sûr, longuement, mais sans doute par encore assez. Je découvre AllEvents et il est qd même assez complexe, donc j'ai encore des progrès à faire.
              Merci pour ta réactivité, ta disponibilité et ta compétence.
              Long way
              Argol

              Commentaire


              • #8
                Re : Questions AllEvents

                Envoyé par Argol Voir le message
                Pour répondre à ta question : tu as installé le plugin AllEvents - Formulaires ? Si pas, faut commencer par là.
                Tu l'as installé ? Quel est le composant de gestion de formulaire que tu as configuré ? Imaginons CKForms : as-tu bien CKForms d'installer sur ton site et, aussi, as-tu installé et publié le plugin content de CKForms ?

                Voici une explication sur le fonctionnement du plugin http://avonture.be/allevents/accueil...gin_formulaire

                Plugin AE installé : oui
                CKForms installé, plugin publié : oui
                Je revérifie tout et je te tiens au courant
                En fait, le problème c'est que je n'arrive pas à avoir l'onglet "Inscription" dans le frontend, même avec le formulaire standard et les 3 boutons de AE. Rien, alors que je peux faire apparaître le lieu, l'album photo ou les liens ; mais pas l'inscription!!!
                J'ai vérifié 100 fois tous les paramètres selon tes recommandations et les articles du blog (je les connais désormais par coeur) mais rien n'y fait. Je vais laisser décanter et y revenir plus tard.
                Tu peux aller voir sur mon site : www.vvwebsite.com, choix AllEvents, évènement "Test" par exemple et tous les autres idem.
                Merci pour l'aide à venir.
                Argol

                Commentaire


                • #9
                  Re : Questions AllEvents

                  Bonjour

                  En mode debug, j'obtiens une erreur javascript au niveau d'un fichier javascript de ... Google et de Facebook.

                  uncaught exception: Error: Permission refusée à <http://www.facebook.com> d'obtenir la propriété Proxy.InstallTrigger
                  Permission denied to access property 'null'

                  L'appel à FB et à Google se fait au niveau des boutons qui apparaissent en haut de la page. Pour tester le formulaire d'inscription, il ne faut pas avoir d'erreur JS sous peine de blocage. Faudrait donc désactiver ces boutons. Tu peux le faire dans les paramètres globaux de AllEvents, onglet Barre d'outils.

                  Pour activer le mode debug, sous Firefox, il suffit d'afficher ta page puis d'appuyer sur la touche F12 du clavier. Idem pour Chrome et IE. Dans l'onglet console, si tu as des erreurs, elles seront en rouge.

                  Si tu le souhaites, communique-moi un accès à ton administration et je fais le test pour toi courant de week-end. Tu peux m'envoyer un message privé.

                  Bye.
                  Christophe (cavo789)
                  Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
                  Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
                  Mes logiciels OpenSource : https://www.avonture.be

                  Commentaire


                  • #10
                    Re : Questions AllEvents

                    Envoyé par cavo789 Voir le message
                    Bonjour

                    En mode debug, j'obtiens une erreur javascript au niveau d'un fichier javascript de ... Google et de Facebook.

                    uncaught exception: Error: Permission refusée à <http://www.facebook.com> d'obtenir la propriété Proxy.InstallTrigger
                    Permission denied to access property 'null'

                    L'appel à FB et à Google se fait au niveau des boutons qui apparaissent en haut de la page. Pour tester le formulaire d'inscription, il ne faut pas avoir d'erreur JS sous peine de blocage. Faudrait donc désactiver ces boutons. Tu peux le faire dans les paramètres globaux de AllEvents, onglet Barre d'outils.

                    Pour activer le mode debug, sous Firefox, il suffit d'afficher ta page puis d'appuyer sur la touche F12 du clavier. Idem pour Chrome et IE. Dans l'onglet console, si tu as des erreurs, elles seront en rouge.

                    Si tu le souhaites, communique-moi un accès à ton administration et je fais le test pour toi courant de week-end. Tu peux m'envoyer un message privé.

                    Bye.
                    Merci Cristophe de suivre l'affaire comme tu fais, c'est sans doute par passion mais aussi parce que tu es surement un chic type. stop pommade, faudrait pas que ça fasse faux cul. Mais c'est dit.

                    J'ai suivi tes consignes et désactivé les boutons FB et Google et d'autres avec, mais ça ne change rien!

                    J'ai fait F12 et obtenu des indications d'erreurs mais que je ne sais pas bien interpréter, encore moins résoudre. Je vois ce que ça veut dire, coté CSS, HTML, console et autre, mais pas assez balaise pour y trouver mon compte. Faut pas se croire ce qu'on est pas.

                    Je t'ai créé un compte pour aller sur mon site, je te transmets ça en mess privé. Merci bp pour ce que tu pourras faire.

                    Comme j'ai fouillé pas mal le logiciel, sous toutes ses coutures, j'ai relevé quelques pb supplémentaires, que je n'ai pas su résoudre, et qui sont peut-être quand même pertinents à te faire remonter (j'espère saouler personne et seulement faire avancer le shmilblic).

                    1/ impossible de sauver une modif de localisation (IE et FF)

                    2/ choix photo donne (pareil pour IE et FF) :
                    AllEvents abnormal shutdown
                    It seems that AllEvents has encountered a failure like a fatal error. If you are French speaking, please report the error on the AllEvents forum otherwise use the support page.
                    Get more info on the AllEvents developer website
                    Array
                    (
                    [type] => 1
                    [message] => Call to undefined method JToolBar::getName()
                    [file] => /web/vvwebsite/www/components/com_allevents/helpers/view.php
                    [line] => 70
                    )

                    donc pas de lien avec l'album lié à l'évènement, pas de téléchargement possible et tutti quanti

                    3/ pas possible upload vignette dans nouvel évènement (bouton dossier ou racine inopérant)

                    4/ impossible éditer "description" dans nouvel évènement (IE et FF) [comment perso : je n'ai pas encore fait la maj dans browser.php pour voir si ça solutionne ce pb)

                    Et pour finir, comment ajouter un nouveau formulaire tiers dans le plugin (saisie impossible); par exemple ChronoForms que j'utilise déjà ?

                    Sorry les gens, ça fait du taf pour ceux qui suivent (merci aussi pour son post à Sten007) ; j'espère que je n'ai pas pris des glaçons pour des icebergs et que j'éviterai la honte des solutions trop évidentes.
                    Christophe, je voudrais pas gâcher ton we (ces bugs m'ont vérolé le sommeil de la nuit dernière), ni que tu nous fasses un AVC devant ton ordi. Ya pas le feu au lac comme disent les suisses.
                    Merci à tous.

                    Carpen diem
                    Vivian

                    Commentaire


                    • #11
                      Re : Questions AllEvents

                      Christophe,

                      Je n'ai pas eu de réponse à ma dernière question, concernant l'affichage de l'onglet réservation. C'est un problème technique, de temps, ou autre ? Aurais-tu lâché l'affaire. Merci de la suite que tu pourras donner et excuses la relance si ça te pose problème.
                      A te lire
                      Argol

                      Commentaire


                      • #12
                        Re : Questions AllEvents

                        Bonjour

                        Envoyé par Argol Voir le message
                        C'est un problème technique, de temps, ou autre ? Aurais-tu lâché l'affaire. Merci de la suite que tu pourras donner et excuses la relance si ça te pose problème.
                        Juste la difficulté d'être au champs et au moulin : j'ai énormément de boulot et il devient tout juste impossible à débogger la version 1.1b (celle que tu utilises) pour la raison que je suis occupé sur la nouvelle version et que, seul à tout faire, c'est tout simplement impossible.

                        Envoyé par Argol Voir le message

                        Array
                        (
                        [type] => 1
                        [message] => Call to undefined method JToolBar::getName()
                        [file] => /web/vvwebsite/www/components/com_allevents/helpers/view.php
                        [line] => 70
                        )
                        Je vais contrôller si j'ai ce problème dans la nouvelle version en cours et si oui, corriger le tir.
                        Christophe (cavo789)
                        Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
                        Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
                        Mes logiciels OpenSource : https://www.avonture.be

                        Commentaire


                        • #13
                          Re : Questions AllEvents

                          Je m'étais un peu douté de quelque chose comme ça ; pour moi ça n'a pas de caractère d'urgence, tant qu'un de ces jours j'arrive à régler ce problème (j'ai encore fouillé depuis, mais rien n'y fait). Fais comme tu as à faire et ce sera bien.
                          Courage!

                          Commentaire


                          • #14
                            Re : Questions AllEvents

                            S'agissant d'une erreur (de la pire espère ici puisque c'est une erreur fatale); nul doute : je vais écraser la bestiole.

                            Si tu es en local, tu peux toujours télécharger la version alpha disponible sur mon site. Il s'agit de la version sur laquelle je travaille et le bug y sera donc écrasé en premier lieu

                            Bonne journée.
                            Christophe (cavo789)
                            Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
                            Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
                            Mes logiciels OpenSource : https://www.avonture.be

                            Commentaire


                            • #15
                              Re : Questions AllEvents

                              Merci Christophe, je vais essayer ta version alpha. Mais sans m'en réjouir, je suis rassuré de n'avoir pas été seulement le blaireau de service, et si ma petite contribution a pu t'être utile, j'en suis satisfait.
                              Bon courage pour la suite.
                              VV

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X