pourquoi monsite est transformé en monsite/fr

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] pourquoi monsite est transformé en monsite/fr

    Bonjour
    j'ai une question qui va paraitre stupide aux experts mais je sèche

    j'ai plusieurs sites qui tournent et le dernier crée s'est transformé en monsite.fr.
    Je n'arrive pas a virer le /fr
    j'ai regardé au niveau des langues, le paramètrage est identique pour tous les sites.
    J'ai rapatrié tous les sites en local et le problème existe en local, (MAMP) donc ne vient pas de l'hébergeur.
    Je suis en Joomla 3.8.7

    Un petit coup de main pour me guider afin de corriger ce /fr

    Merci

  • #2
    Bonjour,

    Avez-vous regardé dans le plugin "filtre de langue", paramètre "enlever le code langue de l'URL" ?

    Avez-vous mis votre site en "Réécriture d'URL en clair (SEF) dans "Configuration/onglet Site/paramètres SEO ?

    Pascal
    If anything can go wrong, it will...
    If I can help, I will ..https://conseilgouz.com

    Commentaire


    • #3
      Bonjour,

      Le site me semble être passé en multilangue.
      Regardez la doc pour passer en mutilangue afin de savoir ce qu'il ne faut pas faire
      https://docs.joomla.org/J3.x:Setup_a...ingual_Site/fr
      Un message d’erreur sur votre site Joomla, consultez la base de connaissance https://kb.joomla.fr
      ---
      UP, un plugin "couteau suisse" à découvrir sur https//up.lomart.fr
      bgMax
      , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ... sur http://lomart.fr/extensions

      Commentaire


      • #4
        Je pensais avoir réglé ce problème
        pascal merci pour vos questions.
        Le plugin filtre de langue est marqué comme système et je ne peux pas le modifier (sais pas comment faire )
        Concernant Configuration/onglet Site/paramètres SEO, la réécriture d'URL est en clair (SEF).

        ...Je vais lire ce que lomart à indiqué.... et la j'ai trouvé comment faire ce que vous m'aviez indiqué plugin "filtre de langue", paramètre "enlever le code langue de l'URL" et j'ai pu modifier le paramètre.

        Merci à tous les deux

        Bonne soirée.
        Dernière édition par original à 01/07/2018, 18h11 Raison: Problème revenu avec la 3.8.10

        Commentaire


        • #5
          Retour du problème
          Avec le passage à la 3.8.10 le problème est revenu
          et impossible de supprimer le /fr qui se rajoute aux autres pages hors page d'accueil.

          - Dans le plugin "filtre de langue", paramètre "enlever le code langue de l'URL" est actif

          - Dans "Configuration/onglet Site/paramètres SEO , Réécriture d'URL en clair (SEF) est actif

          Si je ne publie pas le plugin filtre de langue, le site marche mais avec le rajout de /fr
          Si je le publie, mauvaise pioche le site propose de visiter /fr/page cherchée

          je n'y comprends rien.
          un petit coup de pouce SVP

          Commentaire


          • #6
            bonsoir,
            est ce que les sites ont besoin d'etre en multilangue ?
            des liens vers les sites en question pourraient nous guider vers une piste
            “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr
            Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérer à l'AFUJ https://www.joomla.fr/association/adherer

            Commentaire


            • #7
              Le site doit-il être seulement en français ?
              Quelles sont les langues installées ?
              Quels sont les Tag des langues installées (en-GB, ...) ?
              Quelles sont les langues de contenu publiées ?
              Ces langues ont-elles bien les mêmes tag de langue que les langues installées ?
              Tous les services pour les sites Joomla! : sécurité, nettoyage de sites piratés, hébergement, SEO, applications Fabrik, migration, compatibilité mobiles, accessibilité, ...
              Administrateur certifié Joomla! 3
              https://www.betterweb.fr/services

              Commentaire


              • #8
                Bonjour
                merci à tous les deux pour votre intérêt à mon pb.
                le site : yyy.com
                le site n'a pas besoin d’être en multi langue puisqu’il n'est qu'en français
                Les langues installées sont anglais (par défaut à l'installation )
                et français
                voir image jointe 1
                tags en-GB et fr-FR
                langue de contenu seulement français

                Concernant la langue de contenu, seul francais est actif voir image jointe 2.

                espérant avoir répondu à vos questions.
                Dernière édition par original à 03/07/2018, 10h27

                Commentaire


                • #9
                  A moins qu'il y ait utilisation d'une xtension SEF comme SH404SEF qui aurait enregistré les adresses réécrites en incluant "fr", je ne vois aucune raison pour que la désactivation du plugin filtre de langue ajoute systématiquement ce "fr" dans les adresses.
                  "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                  Commentaire


                  • #10
                    Bonjour,
                    tu dois dépublier les plugin de langues ... et vider TOUS tes caches ... car normalement, c'est ce plugin de langue qui rajoute par defaut le/fr ou /en
                    Cliquez sur l'image pour l'afficher en taille normale

Nom : plugin_langues.png 
Affichages : 1 
Taille : 58,6 Ko 
ID : 1984147
                    “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr
                    Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérer à l'AFUJ https://www.joomla.fr/association/adherer

                    Commentaire


                    • #11
                      Merci RobertG
                      c'était bien SH404SEF que j'avais laissé qui semait ce désordre.
                      filtre de langue et code langue étaient désactivés.
                      enfin c'est réglé sur la version locale de mon site.
                      En distant, curieusement cela ne marche pas.....

                      ce /fr reste plein de mystères.
                      Je vais essayer de faire un backup du site local qui semble marcher pour le réinstaller en distant.
                      Et enfin çà marche sur le site distant


                      Merci à tous
                      Bonne journée
                      Dernière édition par original à 03/07/2018, 10h28

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins
                      Travaille ...
                      X