Erreur 500 sur accès aux "Modules"

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Erreur 500 sur accès aux "Modules"

    Mon environnement: J 3.9.3, Advanced Module Manager

    Bonjour,

    Depuis ce matin, je ne peux pas accéder si je clique dans le mode "Administration" sur "Extensions > Modules". J'obtiens le message:

    Code HTML:
    500: Unknown column 'pages' in 'order clause' Unknown column 'pages' in 'order clause'
    Par contre, j'accède sans problème aux "Plugins", "Articles", etc...

    Question: comment remettre en ordre ceci ?

    Merci pour votre aide.
    Dernière édition par lendrevi à 12/03/2019, 14h33

  • #2
    Je viens de réinstaller l'extension "Advanced Module Manager", mais sans résultat apparent !

    Commentaire


    • #3
      Bonjour,

      Avez-vous essayé "Extensions'/Gérer/Base de données et bouton "Correction", en haut à gauche ?

      Pascal
      Les JoomlaDays Paris 2019, c'était du 8 au 9 mars... J'y étais et vous ?

      If anything can go wrong, it will...
      If I can help, I will ..https://conseilgouz.com

      Commentaire


      • #4
        Bonjour.

        As-tu essayé de réparer la base de données depuis l'admin ? Il semblerait que ça puisse suffire pour remettre ça en ordre.


        Mer**, ce pmleconte, c'est qu'il est rapide…
        Cordialement.
        __
        Eddy !!!
        Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

        Commentaire


        • #5
          Bonjour,
          ou réinstaller le core de joomla en allant dans le composant de mise à jour
          Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

          Commentaire


          • #6
            Merci à vous tous. Absent pour l’instant, je tenterai d’appliquer vos conseils ce soir.

            Commentaire


            • #7
              Je viens d'appliquer vos conseils:

              1. en tentant "Extensions > Gérer > Base de données: on me répond "La structure des tables de la base de données est à jour". Et si je clique nénamoins sur "Correction" ... c'est sans effet notoire. Et l'ennui est toujours là: impossible d'accèder à "Extensions > Modules" (erreur 500),

              2. comme on m'annonce la màj disponible en J 3.94, je l'applique. Tout se passe bien, je vérifie à nouveau la BDD: même message Ok. Nouveau test d'accès aux modules: toujours impossible (erreur 500).

              Aïe !!!

              Commentaire


              • #8
                Essayez de passer en mode "développement" : https://kb.joomla.fr/procedures/debu...-developpement

                Vous devez avoir une extension qui cause ce problème. S'il s'agit bien de "Advanced Modules Manager", essayez de le désinstaller.

                Pascal
                Les JoomlaDays Paris 2019, c'était du 8 au 9 mars... J'y étais et vous ?

                If anything can go wrong, it will...
                If I can help, I will ..https://conseilgouz.com

                Commentaire


                • #9
                  Envoyé par pmleconte Voir le message
                  Essayez de passer en mode "développement" : https://kb.joomla.fr/procedures/debu...-developpement

                  Vous devez avoir une extension qui cause ce problème. S'il s'agit bien de "Advanced Modules Manager", essayez de le désinstaller.

                  Pascal
                  Je suis donc passé en mode "serveur > développement".
                  Mais je n'ai rien de plus comme infos quand je tente d'accéder à mes modules (toujours erreur 500 sans m'en dire plus). Et beaucoup plus grave: je n'ai plus accès à la "configuration" (je voulais également modifier: "système > débogage système à OUI).
                  J'ai le message: Error 503 Service Unavailable

                  Service Unavailable Guru Meditation:

                  XID: 608770610

                  Varnish cache server

                  Commentaire


                  • #10
                    Bonjour,
                    c'est donc une "vraie" erreur 500 .... il faudra aller consulter tes logs serveur (ceux de ton hébergeur)

                    Pour les autres points, il faut bien lire les liens qu'on te donne, tu peux aussi changer ça directement via FTP dans le fichier configuration.php (méthode FTP)
                    Dernière édition par manu93fr à 12/03/2019, 18h19
                    Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

                    Commentaire


                    • #11
                      1. Petite évolution: si je tente "Système > Configuration", je n'ai plus cette erreur 503 service unavailable mais un écran totalement blanc !
                      2. J'ai regardé les logs du serveur: aucune erreur 500 "vraie" recensée !
                      3. par FTP, j'ai modifié les paramètres: système/erreur à '1' et le niveau de messages d'erreurs à 'maximum'. Mais le résultat est nul: que je tente tout affichage côté administration ou de lancer le site en frontend, j'obtiens touujours une page vierge.

                      Quel pépin !
                      Dernière édition par lendrevi à 12/03/2019, 19h25

                      Commentaire


                      • #12
                        Envoyé par manu93fr Voir le message
                        Bonjour,
                        c'est donc une "vraie" erreur 500 .... il faudra aller consulter tes logs serveur (ceux de ton hébergeur)

                        Pour les autres points, il faut bien lire les liens qu'on te donne, tu peux aussi changer ça directement via FTP dans le fichier configuration.php (méthode FTP)
                        Merci pour le conseil FTP. Mais je le connaissais et l'avais déjà fait, sans aucun résultat tangible.

                        Commentaire


                        • #13
                          Hello.

                          C'est une exception php générée par Joomla suite à une erreur de requête sql.

                          Je pense à une requête générée par un plugin spécifique où l'on peut définir en tapant un tag, un ordre (type articles anywhere) mais en admin, c'est un peu surprenant.

                          Regarde dans les logs de Joomla et mysql.

                          Active aussi le débogage système pour avoir la pile des appels (système > configuration > onglet système > débogage système) et les requêtes sql.
                          A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                          Rejoignez le Joomla Users Groupe Alsace...
                          roland_d_alsace va-t-il devenir roland_du_grand_est ?

                          Commentaire


                          • #14
                            Envoyé par roland_d_alsace Voir le message
                            Hello.

                            C'est une exception php générée par Joomla suite à une erreur de requête sql.

                            Je pense à une requête générée par un plugin spécifique où l'on peut définir en tapant un tag, un ordre (type articles anywhere) mais en admin, c'est un peu surprenant.

                            Regarde dans les logs de Joomla et mysql.

                            Active aussi le débogage système pour avoir la pile des appels (système > configuration > onglet système > débogage système) et les requêtes sql.
                            C'est gentil tous ces bons conseils, Roland. Mais j'ai déjà activé le débogage système: et je n'obtiens quoi que je fasse que des écrans totalement blancs.
                            Dernière édition par lendrevi à 12/03/2019, 20h02

                            Commentaire


                            • #15
                              Je viens d'obtenir plus d'infos intéressantes sur cette erreur 500 obtenue en mode admin par "Extensions > Modules":

                              Code HTML:
                              500 Unknown column 'pages' in 'order clause' Unknown column 'pages' in 'order clause'
                              /home/lendrevie/entreprises.tousenvoiture.com/administrator/components/com_advancedmodules/views/modules/view.html.php:68
                              Dommage que l'extension "Advanced Modules Manager" ne m'en dise pas plus ? Je sais qu'on pourrait le paramétrer pour qu'il soit plus bavard: mais pour celà, encore faudrait-il que je puisse accéder en mode admin à la gestion des modules ! Et je ne peux pas.
                              Dernière édition par lendrevi à 12/03/2019, 20h24

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X