Joomla n'envoie plus le mail avec le lien d'activation à un nouvel utilisateur

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Joomla n'envoie plus le mail avec le lien d'activation à un nouvel utilisateur

    Bonjour la communauté,

    J'ai un problème au niveau de l'envoi du mail contenant le lien d'activation à un utilisateur venant de faire une demande de création de compte. Le processus est le suivant :
    - le nouvel utilisateur entre dans le menu Connexion puis, puisqu'il n'a pas de compte, clique sur "Pas encore de compte"
    - il renseigne les différents champs Nom, identifiant, mot de passe, adresse mail etc. puis valide en cliquant sur "s'inscrire"
    - un message s'affiche sur sa page Web lui disant ceci : "Votre compte a été créé et un lien d'activation vous a été adressé par e-mail à l'adresse que vous avez donnée. Notez que vous devrez activer ce compte en cliquant sur le lien d'activation, puis un administrateur devra valider votre compte avant que vous puissiez vous connecter."
    C'est là que ça coince, aucun mail n'est envoyé à l'utilisateur bien que le message s'affiche sur sa page Web.
    Le processus complet de création de compte a déjà fonctionné de nombreuses fois, je ne fais depuis plusieurs mois que de mettre à jour Joomla quand une nouvelle version arrive.
    Actuellement, je contourne le problème en activant à la main le compte et en envoyant moi-même un message mais cela n'est pas satisfaisant.

    J'ai vérifié partout si j'étais bien admin et si j'avais bien tous les droits mais je n'ai rien trouvé. J'ai dû louper quelque chose ou faire une fausse manip à un moment mais je ne reste sec.
    En désespoir de cause, je poste ici une demande d'aide. Si quelqu'un à une solution ou au moins une piste de recherche à me donner, je lui serais infiniment reconnaissant.

    Merci d'avance pour votre aide.

    PSud

  • #2
    Le pense avoir trouvé d'où ça vient : les mails de validation envoyés sur des boites aux lettres Free sont rejetés car considérés comme des spams. Je viens de faire une création de compte en prenant un utilisateur ayant une boite aux lettres gmail.com et le processus s'est déroulé correctement jusqu'au bout. Ce problème de mails détectés comme spam m'est déjà arrivé. J'avais pris contact avec Free, il y a une procédure qui permet d'envoyer un faux spam pour que Free ne le rejette plus. Mais la fois précédente j'avais un mail m'indiquant l'arrivée d'un spam or cette fois rien? Je vais creuser le problème avec Free.

    PSud

    Commentaire


    • #3
      Bonjour,

      Veux-tu dire que le nouvel inscrit ne reçoit pas ce mail d'activation alors que l'administrateur est informé ou que ni l'un ni l'autre n'en reçoit ?

      PS : la sécurité de certains serveurs de messagerie nécessite que l'adresse du mail du site soit sur le nom de domaine de celui-ci
      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

      Commentaire


      • #4
        Envoyé par RobertG Voir le message
        Bonjour,

        Veux-tu dire que le nouvel inscrit ne reçoit pas ce mail d'activation alors que l'administrateur est informé ou que ni l'un ni l'autre n'en reçoit ?

        PS : la sécurité de certains serveurs de messagerie nécessite que l'adresse du mail du site soit sur le nom de domaine de celui-ci
        Bonjour RobertG,

        Quand ça fonctionne, le nouvel inscrit reçoit un mail contenant un lien d'activation, l'administrateur du site ne reçoit rien. Ensuite quand le nouvel utilisateur a cliqué sur le lien d'activation, alors l'administrateur reçoit un message l'informant d'une demande de création de compte et un lien d'activation. L'administrateur affecte le nouvel utilisateur à un groupe puis clique sur le lien. Le nouvel utilisateur reçoit alors un mail l'informant que son copte est validé et qu'il peut se connecter.

        Je fais le test de création d'un compte avec un utilisateur ayant une boite aux lettres @gmail.com, tout fonctionne bien.
        Je fais le test de création d'un compte avec un utilisateur ayant une boite aux lettres @free.fr, l'utilisateur ne reçoit pas le premier mail mais contrairement à quand j'ai eu le problème de spam avec Free, je ne reçois aucun message me disant que le mail est rejeté. Rien ne m'avertit que ça n'a pas marché.

        PS. Que veux-tu dire par "certains serveurs de messagerie nécessite que l'adresse du mail du site soit sur le nom de domaine de celui-ci" ?

        Je précise que tout à déjà fonctionné très bien même avec des boites aux lettres @free.fr

        Cldt

        Commentaire


        • #5
          Je veux dire que si ton site a pour nom de domaine tartampion.tld, l'adresse d'envoi dans la configuration des mails du site doit être en @tartampion.tld pour que certains serveurs (ça a été le cas de Gmail récemment) ne rejettent pas les messages envoyés par le site.

          Précision : ce n'est nécessaire que si les messages sont envoyés par la fonction PHP mail
          Dernière édition par RobertG à 01/07/2019, 11h44
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

          Commentaire


          • #6
            Merci, je vais regarder ça cet aprem.
            Cldt

            Commentaire


            • #7
              Je viens de regarder, l'email du site est bien configuré comme tu l'as dit. Ce qui coince ce sont les messages envoyés à un utilisateur dont l'adresse mail est @free.fr, tout du moins pour le test que j'ai réalisé. Avec @gmail.com tout marche bien tant les mails vers l'administrateur du site que ceux vers l'utilisateur en gmail.com
              Curieux, non ?

              Commentaire


              • #8
                Le problème doit donc se situer au niveau du serveur Free. Les mails ne passent-ils pas en boîte spam ?
                Normalement, s'ils sont rejetés, tu dois recevoir un avis de non-remise, comme tu en as déjà eu.
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                Commentaire


                • #9
                  Envoyé par RobertG Voir le message
                  Le problème doit donc se situer au niveau du serveur Free. Les mails ne passent-ils pas en boîte spam ?
                  Normalement, s'ils sont rejetés, tu dois recevoir un avis de non-remise, comme tu en as déjà eu.
                  Pas d'avis de non remise comme l'autre fois. C'est curieux, il faut que je teste plus.
                  A suivre
                  Cldt

                  Commentaire


                  • #10
                    Je viens d'essayer avec la boite aux lettres Free de ma femme, aucun message rçu par elle. Existe-t-il un log qui trace tous les mails envoyés par le site ?

                    Commentaire


                    • #11
                      Certains serveurs génèrent un fichier d'envoi des mails qui est accessible à l'administrateur, d'autres pas.
                      Mais si Joomla! crée le compte et ne signale pas d'erreur d'envoi, c'est qu'il a transmis le message au serveur et que le serveur l'a accepté. Ce qui se passe ensuite est du ressort du serveur lui-même.
                      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                      Commentaire


                      • #12
                        J'ai trouvé le fichier log des mails. Les mails vers les boites aux lettres Free sont bien indiqués comme envoyés sans message d'erreur. Je vais regarder du côté de Free.
                        A suivre

                        Commentaire


                        • #13
                          Bonjour,

                          L'envoi de mail pour certains serveurs mutualisés est bloqué depuis leur adresse ip donc tous les sites hébergés sur le serveur avec la même ip subissent la même punition. D'où la nécessité d'avoir une ip dédié pour certains sites et un bon réglage spf, dkim.

                          Dans votre cas, il faut vérifier si l'ip du serveur n'est pas blacklisté comme indiqué sur le lien :
                          https://postmaster.free.fr/#mon_ip_est_elle_bloquee
                          il y a l'explication pour déblacklister au besoin

                          Quelques rappels pour l'envoi de mail :
                          - utiliser une adresse mail existante pour l'expedition avec le même nom de domaine ( exemple : noreply @ nomdusite.com )
                          - n'oubliez pas de paramétrer correctement le SPF, DKIM et DMARC ( Au besoin, demander à votre hébergeur )
                          - tester votre configuration (obtenez un 10/10) via https://www.mail-tester.com/
                          - rechercher si votre nom de domaine n'est pas blacklisté par d'autres serveurs antispam : https://mxtoolbox.com/blacklists.aspx

                          En théorie, votre adresse d'expedition doit recevoir les erreurs à défaut d'une adresse de rebond.
                          Si les envois vers free sont bloqués alors le mail doit pouvoir être retourné à cette adresse afin d'indiquer le problème.

                          Quelques réponses pour free et le blacklistage : https://vulgumtechus.com/Adresse_ema...9e_sur_free.fr

                          Le conseil que je donnerai c'est d'utiliser une ip spécifique pour le site, d'être certain de la bonne configuration de spf et dkim ( c'est le minimum ! ).

                          En cas de grande difficulté sur la gestion de mails sur le serveur, il ne faut pas hésiter à utiliser une adresse relais smtp afin d'eviter tout problème. Par exemple, mailjet le propose même dans son offre gratuite : https://fr.mailjet.com/email-transactionnel/ avec une extension spécifique pour joomla : extensions.joomla.org/extension/mailjet-email-marketing/
                          Dernière édition par daneel à 02/07/2019, 23h50
                          pmleconte likes this.
                          Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

                          Commentaire


                          • #14
                            Merci daneel pour cette réponse très très dense. Je vais regarder tout ça dès demain.
                            Cordialement
                            PSud

                            Commentaire


                            • #15
                              Quelques tests ce matin suite aux conseils de daneel m'ont montré que le site n'était pas dans la liste noire de Free et que les mails envoyés n'étaient pas considérés comme des spams. Le mystère restait donc entier jusqu'en fin de matinée où j'ai reçu une avalanche de mails envoyés par mon site pour toutes les tentatives de créations de cote que j'ai faites hier. Bien évidemment, les liens de validation des comptes n'étaient plus valides mais ce n'étaient que pour faire des tests. Donc mes procédures fonctionnent bien, c'est le serveur de mail de Free qui fait de la rétention de mails !!!
                              Je vais refaire un test et reviens ici donner le résultat.
                              Cldt

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X