Connexion panneau admin impossible après transfert du site

Réduire
Ce sujet est fermé.
X
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Connexion panneau admin impossible après transfert du site

    Bonjour à toutes et à tous.
    Depuis quelques temps, je n'arrête pas de découvrir notre fameux Joomla . Aujourd'hui, j'ai presque fini mon site fait sur un serveur local avec ampps, et comme je suis un peu en vacance je pense le terminer chez mon cousin! Ainsi je l'avais sauvegardé avec Akeeba backup et emporté l'archive dans mon clé usb. Arrivé chez lui, j'avais pris le pc [o.k] , installe ammps [o.k], restaure le site [o.k], visualise le site [o.k], vérifie les données dans phpmyadmin [o.k], et là grand soucis: je n'arrive pas à accéder au panneau de configuration Joomla pourtant j'ai belle et bien vérifié que mon login et mot de passe sont correctes, et j'ai même réinstallé ampps et recommencer la restauration mais toujours pareils. Après avoir entrée mon login et pass puis sur connexion, la page se rafraichie mais je suis toujours coincé sur la page de connexion où on m'invite à nouveau de rentrer mon login/pass.
    Cliquez sur l'image pour l'afficher en taille normale

Nom : Capture.jpg 
Affichages : 1 
Taille : 10,6 Ko 
ID : 1820775
    Pour info il n'y a pas le moindre message d'erreur.
    Alors si quelqu'un pourrai m'aider svp car ça me rends un peu peur surtout le moment où je mettrai mon site en ligne et que je ne peux pas accéder au panneau admin.
    En attendant merci d'avance à tous! Je passerai plus de temps sur le forum jusqu'à que ce que ce problème soit résolu!
    PS: J'utilise joomla 3.3.6
    config: win7 64,ram 4go, cpu g2030
    Dernière édition par antonely93 à 22/10/2014, 14h05
    Si vous ne réussissez pas du premier coup, appelez ça version 1.0

  • #2
    Re : Connexion panneau admin impossible après transfert du site

    Re Bonjour tout le monde! Je vois que j'ai pas encore eu de réponse mais bon je pense que le problème c'est résolu tout seul! Je ne sais pas comment ni pourquoi! J'ai beau bidouillé ma base sur phpmyadmin car j'ai vu sur le la toile qu'il faut faire certaine manip sur ce dernier:
    - table: prefixe_user > modifier le mot de passe et le crypter md5, ajouter un nouveau utilisateur ...
    - table: prefixe_extension > activer les plu-gins d’authentification (joomla, user ... )
    - lancer une requête sql permettant de réinitialiser le pass admin

    En outre j'ai beau changer de logiciel de dev local, j'ai tout essayé: wamp, ampps, easyphp, xamp, uwamp, server2gpo mais toujours pareils!
    Bon je me suis dis qu'il faut que je prie un peu! J'ai désinstallé mon dernier logiciel de dev et après une pause de qlqs heures. J'ai décidé de réinstaller wampserver et de recommencer à 0.
    -Durant la restauration j'ai changer un peu certaines informations ainsi voici mes captures étape/étape au cas où une autre personne aurait le même problème que moi!
    1- Cliquez sur l'image pour l'afficher en taille normale

Nom : mon dossier.jpg 
Affichages : 1 
Taille : 33,9 Ko 
ID : 1803783
    2-Cliquez sur l'image pour l'afficher en taille normale

Nom : 2.jpg 
Affichages : 1 
Taille : 15,0 Ko 
ID : 1803784
    3-Cliquez sur l'image pour l'afficher en taille normale

Nom : 3.PNG 
Affichages : 1 
Taille : 17,5 Ko 
ID : 1803785
    4-Cliquez sur l'image pour l'afficher en taille normale

Nom : 4.jpg 
Affichages : 1 
Taille : 22,2 Ko 
ID : 1803786
    5- Cliquez sur l'image pour l'afficher en taille normale

Nom : 5.jpg 
Affichages : 1 
Taille : 15,3 Ko 
ID : 1803787
    6-Cliquez sur l'image pour l'afficher en taille normale

Nom : 6.jpg 
Affichages : 1 
Taille : 21,1 Ko 
ID : 1803788
    7-Cliquez sur l'image pour l'afficher en taille normale

Nom : 7.jpg 
Affichages : 1 
Taille : 20,9 Ko 
ID : 1803789 (je précise, il faut supprimer le rep d'installation)

    Pour mes anciennes paramètres (panneau admin non accessible): j'avais mis (fig 6) localhost/joomla sur cookie domain et /joomla sur cookie path
    - sur super user setting j'avais pas changé de mot de passe (mais il indique que si on ne change pas le mot de passe, le mot de passe orignal sera utilisé)
    --- j'ai pas coché override tmp

    Pour mes nouvelles paramètres (voir les fig étape/étape), et j'ai aussi changé le mot de passe sur fig6
    Ce soir je vais re-désinstaller wamp et utilisé ampps si cela va toujours fonctionner! Sur ce, je vous tiendrai au courant!
    Mais je me demande vraiment quelles paramètres je vais faire lors de la mise en ligne
    Dernière édition par antonely93 à 23/10/2014, 06h05
    Si vous ne réussissez pas du premier coup, appelez ça version 1.0

    Commentaire


    • #3
      Re : Connexion panneau admin impossible après transfert du site

      Salut,
      non, tu n'as pas tout essayé :
      la pile/stack multi-supports proposée par Bitnami.
      LOL.

      Install Joomla!, Download Joomla!
      https://bitnami.com/stack/joomla/installer

      Plus sérieusement, cette "pile" est très pratique et très simple à installer.
      Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter lla base de connaissance : https://kb.joomla.fr

      Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

      Commentaire


      • #4
        Re : Connexion panneau admin impossible après transfert du site

        salut à toi Ghazal! Merci pour ta réponse! si si j'avais déjà utilisé le truc de bitnami mais le problème c'est quand j'entre dans le panneau de phpmyadmin bcp de fonctionnalités sont absentes comme la création d'une nouvelle BD et plus encore (si non y aurait-il un moyen de les activées?). La base de données elle même je ne la trouve pas! Il n'y a que deux BD et quand je les parcours je vois que c'est pas vraiment les BD de joomla (peut-être qu'elle est cachée qlq part! mais où?). Comme je suis de nouveau ici j'utilise maintenant ampps et ça roule à merveille! hi3
        Si vous ne réussissez pas du premier coup, appelez ça version 1.0

        Commentaire


        • #5
          Re : Connexion panneau admin impossible après transfert du site

          FYI.
          J'ai fait un tuto, ou plutôt une marche à suivre, ici, #post 9 :

          Joomla 3.3 / Bitnami Stacks - Quel répertoire installer mes fichiers d'installation ?
          http://forum.joomla.fr/showthread.ph...hlight=bitnami

          Si ca t'amuse et si tu as le temps, ca m'intéresserait d'ailleurs que tu me donnes un avis sur ce tuto, pour l'améliorer si il y a besoin.
          Sinon, pas grave.
          Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter lla base de connaissance : https://kb.joomla.fr

          Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

          Commentaire


          • #6
            Re : Connexion panneau admin impossible après transfert du site

            Bien sûr que je vais voir ton tuto! je te passerai ma note!
            Si vous ne réussissez pas du premier coup, appelez ça version 1.0

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins

            Partenaire de l'association

            Réduire

            Hébergeur Web PlanetHoster
            Travaille ...
            X