impossible d'accéder à un article "Veuillez d'abord vous identifier"...

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] impossible d'accéder à un article "Veuillez d'abord vous identifier"...

    Bonjour à tous

    Bon et bien je jette l'éponge un peu frustré et j'en appelle à votre aide.
    J'utilise mon site depuis déjà un bon moment, joomla 3.6.5, tout fonctionne à merveille. Aujourd'hui je rajoute un bête article déjà préparé depuis un moment, plus qu'à le publier après quelques modifs, je mets un lien de menu et...
    impossible de voir l'article en ligne... à la place simplement "veuillez vous identifier"...
    Je regarde les droits d'abord de l'article puis du lien... tout en "public"...
    bref je ne comprend rien... que s'est il passé ???
    Merci d'avance de vos conseils !
    Romain

  • #2
    Bonjour,

    Joomla 3.6.5 était votre 1ere version Joomla, j'espère, car nous sommes en 3.9.12 (3.9.13 prévu mardi prochain).

    Votre lien de menu est "tout public", mais son parent l'est-il aussi ?

    Pascal
    If anything can go wrong, it will...
    If I can help, I will ..https://conseilgouz.com

    Commentaire


    • #3
      Bonjour.

      Voir aussi peut-être au niveau de la catégorie dans laquelle l'article est placé…
      Cordialement.
      __
      Eddy !!!
      Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

      Commentaire


      • #4
        Merci pour vos réponses ! Oui 3.65 d'origine bien sûr.
        La catégorie de l'article est en "public" et le lien de menu du parent en "public"...
        A se tirer les cheveux (ou ce qu'il en reste

        Commentaire


        • #5
          A vrai dire je n'ai jamais rien mis hors de "public" je ne comprend pas d'ou vient ce message soudain ? C'est comme si on cherchait à commander sur la boutique hikashop, mais aucun rapport, je n'ai jamais eu le souci auparavant...

          Commentaire


          • #6
            Je pense à quelque chose : dois je purger les urls de sh404sef lorsque je crée comme cela un nouvel article/menu ?
            Je ne me souviens plus si la manip est risquée ou pas...
            Dernière édition par romainduf à 01/11/2019, 00h36

            Commentaire


            • #7
              Envoyé par romainduf Voir le message
              Je pense à quelque chose : dois je purger les urls de sh404sef lorsque je crée comme cela un nouvel article/menu ?
              Je ne me souviens plus si la manip est risquée ou pas...
              Bonsoir, je ne sais pas si cette action est "risquée" ... je ne pense pas .... mais ce qui est VRAIMENT risqué c'est de ne pas suivre les mises a jour Joomla et celles des extensions que tu as installées !!!
              Il faudrait donc commencer par là non ? Bien évidemment, on fait régulièrement des sauvegardes complètes du site au fur et a mesure

              Une url du site est souvent conseillée pour comprendre le souci ...
              Dernière édition par manu93fr à 02/11/2019, 01h35
              Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

              Commentaire


              • #8
                Merci Manu pour ton conseil. Oui oui... tu as raison... mais la dernière fois que je m'y suis attelé, ca m'a couté 2 semaines de travail à temps plein pour que tout fonctionne...
                Là il s'agit d'un site commercial en production, je suis très méfiant... Du coup oui je m'en occuperai mais après la période de Noel...
                Voici donc l'adresse du lien, je l'ai remis en ligne provisoirement. Si on va sur cet autre lien on voit deux "conférences", impossible d'accéder à la première...
                Après la mise à jour c'est bien, mais comment expliquer qu'un site qui fonctionne nickel depuis pas mal de temps présente tout d'un coup un soucis de la sorte ? Je ne comprend pas en quoi une mise à jour résoudrait le problème puisque j'arrivais à écrire des articles et à les mettre en ligne jusqu'il y a peu...
                Bref mystérieux....

                Commentaire


                • #9
                  Le fait qu'un site se mette "tout d'un coup" a avoir un comportement inhabituel n'est jamais un bon signe. Ce n'est pas nécessairement l'indication de quelque chose de très grave, mais c'est à éclaircir en priorité avant, éventuellement, à ce que cela prenne de plus grands proportions.
                  Je comprends que la période de Noël est importante pour une boutique en ligne mais c'est aussi la période où on voudrait qu'il fonctionne à 100 %.
                  Comme indiqué plus haut, faire les mises à jour (de Joomla! ET des extensions) est primordial, surtout qu'il existe plusieurs failles de sécurité importantes qui ont été corrigées depuis la version 3.6. De plus, votre site tourne sous PHP 5.5 qui n'est vraiment pas sécurisé non plus. Vous devriez voir avec votre hébergeur si vous avez la possibilité de passer en PHP 7.2 ou 7.3.
                  Attention aussi à NGinx : je crois que Joomla! est censé fonctionner correctement avec ce type de serveur Web, mais Apache est sans doute préférable pour la compatibilité.
                  Enfin, dans la mesure où il s'agit d'un site commercial en production et de problèmes sérieux, je vous recommanderais de faire appel à un prestataire professionnel si vous n'êtes pas sûr à 100 % de ce qu'il y a lieu de faire.
                  romainduf likes this.
                  Tous les services pour les sites Joomla! : sécurité, nettoyage de sites piratés, hébergement, SEO, applications Fabrik, migration, compatibilité mobiles, accessibilité, ...
                  Administrateur certifié Joomla! 3
                  https://www.betterweb.fr/services

                  Commentaire


                  • #10
                    Envoyé par romainduf Voir le message
                    Merci Manu pour ton conseil. Oui oui... tu as raison... mais la dernière fois que je m'y suis attelé, ca m'a couté 2 semaines de travail à temps plein pour que tout fonctionne...
                    Bonjour.
                    C'est bizarre pcq de mon côté je mets à jour tous mes sites et toutes mes extensions tous les jours... et c'est vraiment exceptionnel qu'il y ait un problème (et encore, si j'attendais une semaine avant de faire les mises à jour, 90% du temps j'aurais évité le problème. Mais mon but est aussi de donner du retour).
                    Je crois que plus on attend, plus on risque d'avoir de "vrais" problèmes.
                    Et puis, avec un backup pris juste avant la mise à jour, dans le pire des cas si un problème devait survenir, ça prend 2 minutes de remettre la version avant mise à jour (et ensuite de s'enquérir du problème).
                    Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter lla base de connaissance : https://kb.joomla.fr

                    Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez régulièrement ? Alors adhérer à l'AFUJ : https://www.joomla.fr/association/adherer

                    Présentations : slides.woluweb.be | Coordonnées complètes : www.woluweb.be

                    Commentaire


                    • #11
                      Hello.

                      Ce type de comportement signifie en général que le lien de menu est un alias qui renvoi vers un autre lien (d'itemId différent) affecté à un niveau d'accès auquel l'utilisateur courant n'a pas accès et qu'il n'est pas identifié ($user->get('id') == 0 voir fin de la vidéo...).

                      Sinon (blocage au niveau d'accès de l'article ou de la catégorie) tu aurais un message "403 vous n'êtes pas autorisé à accéder à cette ressource".
                      Dernière édition par roland_d_alsace à 02/11/2019, 21h12
                      romainduf likes this.
                      A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                      Rejoignez le Joomla Users Groupe Alsace...
                      roland_d_alsace va-t-il devenir roland_du_grand_est ?

                      Commentaire


                      • #12
                        Envoyé par roland_d_alsace Voir le message
                        Hello.

                        Ce type de comportement signifie en général que le lien de menu est un alias qui renvoi vers un autre lien (d'itemId différent) affecté à un niveau d'accès auquel l'utilisateur courant n'a pas accès et qu'il n'est pas identifié
                        Merci Roland ! Ton message m'a mis sur la piste ! Je ne crois pas qu'une mise à jour aurait solutionné le problème. Il s'agit d'un article en fait assez ancien que je n'avais jamais publié, et il y avait pour une raison obscure un souci au niveau de son id... Du coup la solution simplissime : faire une copie de l'article, effacer l'article d'origine, faire pointer le lien de menu vers le nouvel article... problème réglé

                        Pour les autres messages concernant la mise à jour, oui vous avez infiniment raison mais... là je suis en plus de mon travail à 100% sur la construction de ma maison et je n'ai plus un kopek... Alors oui il faudrait il faudrait... Je m'en occuperai quand j'aurai les ressources. Il est tout à fait possible que la mise à jour se passe bien, mais mes derniers souvenirs de mise à jour comme ca étaient plutot cauchemardesque. Quant à payer quelqu'un oui c'est très bien... mais où je trouve les sous là dans l'immédiat ? J'ai à peine de quoi payer mon carrelage
                        Et pour répondre à jfque oui mon hébergeur gère php7+ sous apache il ne devrait pas y avoir de soucis.

                        Commentaire


                        • #13
                          Bonsoir,
                          Alors oui il faudrait il faudrait... Je m'en occuperai quand j'aurai les ressources. Il est tout à fait possible que la mise à jour se passe bien, mais mes derniers souvenirs de mise à jour comme ca étaient plutot cauchemardesque.
                          Là, tu es dans l'erreur, je peux comprendre la peur de tout casser, mais voila, la peur n'évite pas le danger ... c'est bien connu

                          Si tu n'es pas a l'aise avec les sauvegardes, les transferts, les restaurations de sites ... il va te falloir te former, t'entrainer. La bonne nouvelle, c'est que c'est totalement GRATUIT avec un serveur local

                          https://kb.joomla.fr/procedures/sauvegarder-site-joomla
                          Akeeba backup est une extension INCONTOURNABLE dans le monde Joomla ... une fois que tu auras saisi le principe ... ta peur disparaitra a JAMAIS et tu seras beaucoup plus confiant et serein coté mises a jour
                          Dernière édition par manu93fr à 04/11/2019, 00h38
                          Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

                          Commentaire


                          • #14
                            Merci Manu, oui j'ai l'habitude de faire les sauvegardes à mano, c'est plutot simple, je n'ai jamais essayé akeeba mais effectivement ca doit aller encore mieux Et j'ai déjà passé pas mal de temps en serveur local en général je fais ca avant de mettre en ligne les grosses mises à jour (genre le prochain joomla 4, qui sera peut être pas complement rétrocompatible ?)

                            Commentaire


                            • #15
                              Envoyé par romainduf Voir le message
                              Merci Manu, oui j'ai l'habitude de faire les sauvegardes à mano, c'est plutot simple, je n'ai jamais essayé akeeba mais effectivement ca doit aller encore mieux Et j'ai déjà passé pas mal de temps en serveur local en général je fais ca avant de mettre en ligne les grosses mises à jour (genre le prochain joomla 4, qui sera peut être pas complement rétrocompatible ?)
                              Il ne risque pas de l'être pour toi si tu restes en version 3.6 alors qu'on en est au version 3.9
                              Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X