Pas de pagination sur un blog d'une catégorie parente ?

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • elchecmoi
    a répondu
    Ca maaaaaaaaaarche ! (je cherche pour mettre en réglé, je vais trouver…)

    J'ai mis le temps à trouver la cause du problème étant donné que j'étais allée retoucher un peu tous les paramètres des différents onglets, y-compris dans la paramètres d'articles, bref je reproduis mon process + ou - :

    Pour l'histoire de l'onglet "Catégorie" dans le lien de menu, à part mettre la liste des catégories avec éventuellement le nombre d'articles par catégorie, pas vu de changement.

    Dans mon lien de menu onglet "paramètres", tout en bas j'ai mis pour liens non autorisés "utiliser les paramètres des articles" (va savoir si ça a changé qq ch),

    puis retournée sur l'onglet "affichage du blog", j'ai mis "0" pour articles en pleine largeur, 4 pour les intros

    Et je pense que la cause vient du fait qu'il faille afficher la position de pagination, car dès que je la masque, la pagination disparait et j'ai à nouveau tous mes articles : bingo !

    MERCI BEAUCOUP de t'être penché sur mon problème Woluweb ! Je suis certaine que je n'aurais pas trouvé sans ton intervention. ¡Muchas gracias! Comme quoi l'interaction humaine… ;-)

    Laisser un commentaire:


  • woluweb
    a répondu
    Regarde aussi dans les autre onglets.
    Exemple : sur le 2e onglet ("catégorie") il y a p ex

    Subcategory Levels

    Laisser un commentaire:


  • elchecmoi
    a répondu
    Envoyé par woluweb Voir le message
    euh, normalement la pagination devrait fonctionner...

    Le bon réflexe, c'est toujours de d'abord tester sur Protostar (pcq parfois et même souvent, certains templates n'implémentent pas toutes les fonctionnalités ).

    Donc mets la page sous protostar et si le problème est le même, alors on poursuit les recherches...
    Ah, ça me rassure un peu ! (que ça devrait fonctionner)

    J'ai mis le lien de menu avec Protostar comme template par défaut, cela ne semble rien changer…

    Je supprime le cache, attends un peu pour être sûre, j'ai pourtant bien mes 5 intros d'articles dans l'onglet affichage du blog de ce lien de menu (capture à l'appui).

    Alors j'avoue avoir précédemment installé Page-builder-pro, puis désinstallé, puis réinstallé page-builder-lite que j'ai désactivé et finirai par désinstaller. Cela pourrait-il être la cause du dysfonctionnement ?
    Fichiers joints
    Dernière édition par elchecmoi à 21/01/2021, 14h43

    Laisser un commentaire:


  • woluweb
    a répondu
    euh, normalement la pagination devrait fonctionner...

    Le bon réflexe, c'est toujours de d'abord tester sur Protostar (pcq parfois et même souvent, certains templates n'implémentent pas toutes les fonctionnalités ).

    Donc mets la page sous protostar et si le problème est le même, alors on poursuit les recherches...

    Laisser un commentaire:


  • elchecmoi
    a répondu
    Envoyé par woluweb Voir le message
    Je ne vois pas exactement ce qu'on est supposé obtenir sur base du lien.
    En tout cas, il y a des options dans le menu pour spécifier jusqu'à quel niveau il doit "plonger" dans les sous-catégories si je me souviens bien.
    Et on peut spécifier l'ordre etc.
    Merci pour ta réponse et ton intérêt Woluweb !
    On est supposé avoir une pagination en bas pour atteindre la page 2, car j'ai réglé le menu pour n'afficher que 5 iintros d'articles en pleine largeur (là il y en a 6).
    Aussi ce menu est un lien sur un blog d'une catégorie parente ("Carnets de route", qui est parente des catégories des pays – Suisse, Italie, etc.) sachant qu'il n'y a aucun article directement dans la catégorie parente, tous les articles sont dans ses sous-catégories, à savoir les pays (Suisse, Italie, etc.).
    J'ai donc réglé mon lien de menu pour qu'il n'affiche qu'à partir du niveau 2 du menu principal (niveau 1 étant "Carnets de route"), et qui inclut toutes les sous-catégories (de toute façon il n'y que 2 niveaux de catégories).
    Je ne trouve pas comment pallier le problème pour que cette page ne fasse pas 10 km de haut à mi-parcours du tour du monde. J'aurais préféré avoir cette page blog "Carnets de route" avec maximum 12 introductions d'article par page (sachant qu'il n'y aura guère plus de 3/4 articles par pays à priori).
    J'ai tenté plein de choses, voilà pourquoi je me suis permise de poster, voir si je prends le problème du mauvais bout ou ???

    Laisser un commentaire:


  • woluweb
    a répondu
    Je ne vois pas exactement ce qu'on est supposé obtenir sur base du lien.
    En tout cas, il y a des options dans le menu pour spécifier jusqu'à quel niveau il doit "plonger" dans les sous-catégories si je me souviens bien.
    Et on peut spécifier l'ordre etc.

    Laisser un commentaire:


  • Pas de pagination sur un blog d'une catégorie parente ?

    Bonjour à tous,

    J'ai tenté par tous les moyens d'essayer d'avoir un blog d'introductions d'articles de différentes catégories que j'ai rassemblées sous une catégorie parente. Je remarque que la pagination ne fonctionne que pour les catégories d'articles mais pas pour les parentes.
    Y-aurait-il un moyen de contrer ce problème ?

    (Pr info. : Joomla 3.9.24, template Helix ultimate
    Site de prod et page concernée : http://news.caracteristic.fr/carnets-de-route)

    Merci par avance pour votre/vos réponse(s).
    Céline
    Dernière édition par elchecmoi à 21/01/2021, 17h41

Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X