Le bouton "Sauvegarder" ne fonctionne pas en frontend

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Steph8211
    a répondu
    Re : Le bouton "Sauvegarder" ne fonctionne pas en frontend

    Après avoir examiné l'élément avec firefox, je me suis aperçu qu'avec le template "Beez3" sur lequel ça fonctionne il est écrit :

    <button class="btn btn-primary" onclick="Joomla.submitbutton('article.save')" type="button">Sauvegarder</button>

    alors que mon template fait apparaitre la ligne suivante :

    <button class="btn btn-primary dd-button" onclick="Joomla.submitbutton('article.save')" type="button">Sauvegarder</button>

    J'ai trouvé le script qui correspond dans le fichier "edit.php" du template mais le code est identique à celui du template "Beez3" C'est à dire : <button class="btn btn-primary" onclick="Joomla.submitbutton('article.save')" type="button">Sauvegarder</button>
    qu'est-ce que c'est qui peut bien faire apparaitre le "dd-button" ??

    Laisser un commentaire:


  • Steph8211
    a répondu
    Re : Le bouton &quot;Sauvegarder&quot; ne fonctionne pas en frontend

    Merci pour ta réponse mais je ne suis pas très calé dans ce domaine la. Qu'est-ce que JS?...JavaScript?
    Pour mon template, pas de mise a jour.
    Comment fait-on pour vider les caches joomla?
    Dernière édition par Steph8211 à 06/03/2016, 19h33

    Laisser un commentaire:


  • zepelin57
    a répondu
    Re : Le bouton &quot;Sauvegarder&quot; ne fonctionne pas en frontend

    Bonjour,

    Assurément un conflit JS, là il faut chercher lequel pose problème via Inspecter élément du navigateur et console JS. Voir du côté de ton template si il n'y en a pas de màj. Ne pas oublier aussi après coup de vider les caches Joomla et navigateur.

    Laisser un commentaire:


  • Le bouton "Sauvegarder" ne fonctionne pas en frontend

    Bonjour,

    Je viens vers vous car je rencontre un petit problème.

    Lorsque je suis en frontend, je clique sur "modifier" sur l'article que je souhaite modifier.

    L'éditeur s'ouvre correctement mais lorsque j'ai terminé la modification de mon article, je ne peut pas le sauvegarder.
    Seul le bouton "Annuler" a un effet.

    Si je met le template par "Beez3" les deux bontons fonctionnent correctement. Pourquoi lorsque j'utilise un autre template je ne peut plus sauvegarder?

    Si ca peut aider, j'ai trouvé sur un forum comment afficher le message d'erreur lié au bouton.
    Ce message est le suivant : "TypeError: document.formvalidator is null"

    Merci d'avance.

Annonce

Réduire
Aucune annonce pour le moment.

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X