Joomladay francophone 2018 à Paris 18 et 19 mai

Tags a disparu de mon menu composants et d'autres composant erronés s'y sont installé

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Tags a disparu de mon menu composants et d'autres composant erronés s'y sont installé

    Bonjour,

    Dan mon joomla 3.4.5, j'ai perdu les Tags dans mon menu composants (mais le composants est bien là et fonctionne), de même quelques composants exotique y apparaissent et donnent une erreur 404 (Composant introuvable), par exemple tcpdf et virtuemart-aio.
    Comment puis-je reconstruire un menu composant fonctionnel et y retrouver mes Tags.

    Merci.

  • #2
    Re : Tags a disparu de mon menu composants et d'autres composant erronés s'y sont ins

    Bonjour,

    Il est fort probable que ce composant n'a pas disparu tout seul, de la même manière que les autres ne sont pas apparus non plus d'un coup de baguette magique.

    Quelle est la (les ?) dernière opération que tu as effectué alors que tout fonctionnait bien encore ?
    Appliques tu les consignes de sécurité standard et habituelle toutes bêtes comme (au hasard) faire une sauvegarde régulière de son site ?

    Quand à savoir ce qui s'est passé sur ton site, avec la pléthore d'informations que tu nous donnes, ça me semble .... diifficile

    Cordialement
    Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

    Commentaire


    • #3
      Re : Tags a disparu de mon menu composants et d'autres composant erronés s'y sont ins

      Bonjour,

      Merci de ta réponse.
      J'avoue n'avoir pas remarqué quand le composant Tags a disparu du menu et comme j'ai fait pas mal de mises à jour (dont Joomla) ces derniers temps, je n'ai pas remarqué à quel occasion cela est arrivé.
      Ce que je voudrai maintenant c'est reconstruire le menu composant de façon "normal".
      J'ai bien été faire un tour dans la base de joomla et particulièrement dans la table _menu, mais j'ai un peu peur de faire des dégats.
      N'y aurait-il pas une méthode pour reconstruire ce menu de façon plus sûre.
      Merci

      Commentaire


      • #4
        Re : Tags a disparu de mon menu composants et d'autres composant erronés s'y sont ins

        Bonsoir,
        N'y aurait-il pas une méthode pour reconstruire ce menu de façon plus sûre.
        Récupérer une sauvegarde est la meilleure sinon la seule solution viable. Puis de refaire les mises à jour en surveillant la survenance de l'anomalie.
        Toucher à la table #__menu implique de gérer ses dépendances.
        Avec Ghazal et Manu93fr nous guiderons les Grands Débutants au https://www.joomladay.fr/ le 19 mai à Paris
        ---
        UP, un plugin "couteau suisse" à découvrir sur https//up.lomart.fr
        bgMax
        , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ...
        plein de nouveaux modules et plugins sur http://lomart.fr/extensions

        Commentaire


        • #5
          Re : Tags a disparu de mon menu composants et d'autres composant erronés s'y sont ins

          +1 avec Lomart

          et si tu n'as pas fait de sauvegarde par toi-même, peut être ton hébergeur a t il pallié à tes défaillances. Le contacter pour savoir comment restaurer les sauvegardes que lui n'a pas manqué de faire
          Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

          Commentaire


          • #6
            Re : Tags a disparu de mon menu composants et d'autres composant erronés s'y sont ins

            Merci de ces réponses.
            Ne sachant pas trop quand le problème est intervenu, je vais tenter du côté des sauvegardes et voir si ça corrige le problème.
            Sinon... je devrai mettre le nez dans la base _ menu.

            Commentaire


            • #7
              Re : Tags a disparu de mon menu composants et d'autres composant erronés s'y sont ins

              Tu peux aussi réessayer une réinstallation de la dernière version Joomla! en mise à jour sur elle-même :
              de même quelques composants exotique y apparaissent et donnent une erreur 404 (Composant introuvable), par exemple tcpdf et virtuemart-aio.
              Si ces deux composants sont apparus dans ton menu composant, c'est probablement que :
              1) tu les as installé
              2) ou bien que l'installation de la dernière mise à jour Joomla! comportait des éléments corrompus (A propos comemnt as tu fait cette installation : direct, par extension > installation ... ?)
              Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

              Commentaire


              • #8
                Re : Tags a disparu de mon menu composants et d'autres composant erronés s'y sont ins

                J'ai déjà fait une mise à jour de joomla (de 3.4.4 à 3.4.5) en direct (via le composant "Mise à jour de Joomla!") qui n'a rien changé au problème.
                Les erreurs sont bien dans la base _menu (pas d'item de menu com_tags et 2 items pour tpdf et virtuemart-aio), il est donc normal qu'une mise à jour ne touche pas à la base de données et je ne suis pas sûr qu'une réinstallation le fera (à moins de faire une réinstallation après suppression du site ce qui ne m'enchante pas !).
                Oui j'ai bien installé virtuemart-aio et tcpdf (mais ça n'explique pas l'erreur 404 quand je clique sur la menu correspondant).
                Dernière édition par agrach à 01/11/2015, 15h29

                Commentaire


                • #9
                  Re : Tags a disparu de mon menu composants et d'autres composant erronés s'y sont ins

                  Non je n'ai pas parlé de réinstallation après suppression !

                  Mais bien de réinstallation de la version sur elle-même, au cas où (cela arrive), le composant installé était dégradé (zip défectueux ou problème lors de l'installation).

                  Si tcpdf et virtuemart sont présents deux fois dans la base de données, il est probable que seul l'un des deux à un lien vérolé (d'où l'erreur 404). Suggestions :

                  1) Sauvegarder la base totalement (avant de la mettre dans un état pire encore)
                  2) dans la table ##_menus ne pas supprimer les articles concernant tcpdf et virtuemart, mais metrtre la valeur 0 dans la colonne published de l'une des deux occurrences de tcpdf et de virtuemart. Vider le cache, tester. Si ça ne marche pas mieux, remettre 1 dans published et refaire l'opération avec l'autre occurrence.

                  Pour le composant tags, il est natif depuis la v3 de Joomla! on ne peut donc pas le réinstaller à part. Il reste toutefois une solution, celle consistant à dézipper une version 3.4.5 de Joomla! sur un disque local supprimer le répertoire installation et envoyer le reste à l'emplacement adéquat du site de production via FTP

                  Bien penser à faire une sauvegarde intégrale avant de procéder !!
                  Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

                  Commentaire


                  • #10
                    Re : Tags a disparu de mon menu composants et d'autres composant erronés s'y sont ins

                    Bonsoir,

                    Les problèmes se trouvant bien dans la base de données, toute réinstallation ne touchant pas à la base de données ne règle pas le problème.
                    J'ai récupéré 2 sauvegardes mais le problème devait être antérieur, rien n'a été réglé.
                    Je me suis mal exprimé, il n'y a qu'un item pour tcpdf et pour virtuemart-aio.
                    Ces deux modules sont installé par virtueMart. J'ai fait une installation de VirtueMart sur un autre site et j'ai le même problème avec ces deux modules, ils pointent aussi sur une erreur 404.
                    Finalement j'ai modifié ma table _menu :
                    - j'ai viré ces deux modules (je tenterai une nouvelle installation un peu plus tard).
                    - j'ai ajouté un item Tags en recopiant l'item com_finder et en corrigeant l'id du composant trouvé dans la table _extension et en mettant class:tags dans le champs img.
                    Maintenant tout fonctionne correctement.
                    Je suis le seul à avoir ces problèmes avec les composants tcpdf et vurtuemart-aio ?
                    Pour moi, le problème est résolu.
                    Merci beaucoup

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins
                    Travaille ...
                    X