Module de recherches

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Module de recherches

    Bonjour,

    J'ai un problème avec le module de recherches. Si on fait une recherche j'ai ce message " #0 Using $this when not in object context"


    Voici l'URL du site.http://www.sgl2.lanaudiere.net, faites une recherche de n'importe quoi, la page vous aurez l'erreur, de plus, aucun menu affiché et le background de la page n'y est plus.
    La configuration du serveur:
    INFORMATIONS DU SITE
    • OS Linux s
    • PHP 7.1.11-0ubuntu0.17.10.1
    • MySQLi 5.7.20-0ubuntu0.17.10.1
    • Heure 05:24
    • Cache Désactivé
    • Gzip Désactivé
    Est-ce possible que la cause est PHP7?

    Merci.

  • #2
    Bonjour,

    Ce type d'erreur existait en 3.8.8 à cause du module "images aléatoires". Donc, quelle version Joomla utilisez-vous ?

    Pascal
    If anything can go wrong, it will...If I can help, I will ..https://conseilgouz.com

    Commentaire


    • #3
      Envoyé par pmleconte Voir le message
      Bonjour,

      Ce type d'erreur existait en 3.8.8 à cause du module "images aléatoires". Donc, quelle version Joomla utilisez-vous ?

      Pascal
      En ce moment. Version 3.8.8.1. Une mise à jour est disponible 3.8.10. J'ai désactivé le module en question, le problème est toujours présent.
      Dernière édition par garnut à 20/07/2018, 10h54

      Commentaire


      • #4
        Bonjour,
        En ce moment. Version 3.8.8.1. Une mise à jour est disponible 3.8.10
        ok .. et elle est faite ? Vous etes bien en 3.8.10 ou vous etes resté en 3.8.8 ?
        Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer
        Cette année, le JoomlaDay FR a lieu à Bruxelles, les 20 et 21 mai 2022, plus d'infos et inscriptions : www.joomladay.fr

        Commentaire


        • #5
          J'ai essayé de faire la mise à jour et évidemment Akeeba back-up fait une sauvegarde avant. Sauf que là tout à foiré, plus rien en admin (voir image jointe).

          Commentaire


          • #6
            Bonjour,

            Il faut passer en mode debug developpement pour identifier le fautif : https://kb.joomla.fr/procedures/debu...-developpement
            puis désactiver l'extension concernée : https://kb.joomla.fr/procedures/comm...-une-extension

            L'autre solution est de récupérer la sauvegarde akeeba pour restaurer le site : https://kb.joomla.fr/procedures/sauvegarder-site-joomla
            UP, le plugin universel à découvrir sur https//up.lomart.fr
            bgMax
            , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ... sur http://lomart.fr/extensions

            Commentaire


            • #7
              Envoyé par lomart Voir le message
              Bonjour,

              Il faut passer en mode debug developpement pour identifier le fautif : https://kb.joomla.fr/procedures/debu...-developpement
              puis désactiver l'extension concernée : https://kb.joomla.fr/procedures/comm...-une-extension

              L'autre solution est de récupérer la sauvegarde akeeba pour restaurer le site : https://kb.joomla.fr/procedures/sauvegarder-site-joomla


              Je vais essayer tout ça. Je vous reviens là dessus. Merci beaucoup.

              Commentaire


              • #8
                J'ai modifié Configuration.php pour dévelopment, par la suite j'avais deux plugs in d'affichés, je les ai désactivé dans PhpMyAdmin. Mais toujours impossible d'avoir accès à l'administration, en revanche, le site fonctionne. J'ai exporté ma base de données au cas ou. Ma question maintenant, avant de réinstaller le tout avec une sauvegarde, il y a t'il un autre moyen de retrouver l'administration?

                Commentaire


                • #9
                  J'ai tout réinstallé, c'est à dire mes copies de sauvegardes Akeeba, donc deux récupérations. Aucune ne me permet l'accès à l'admin. J'ai toujours " Une erreur s'est produite

                  0 Call to a member function get() on null " . Est-ce que le problème vient du serveur, plus précisemment PhpMyAdmin? Un peu coincé dans mon affaire.

                  Commentaire


                  • #10
                    Bonjour,
                    Est-ce possible que la cause est PHP7?
                    mets le serveur sur une version php5.6 et tu le sauras

                    est ce que toutes tes extensions étaient a jour ? Template compris ...
                    Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérez à l'AFUJ https://www.joomla.fr/association/adherer
                    Cette année, le JoomlaDay FR a lieu à Bruxelles, les 20 et 21 mai 2022, plus d'infos et inscriptions : www.joomladay.fr

                    Commentaire


                    • #11
                      En cherchant sur le forum j'ai trouvé quelques post qui ressemblent au miens, j'ai découvert une fonction que je connaissais pas "Debug". Donc j'ai modifié le config.php et voici ce que j'ai. J'imagine que cette image parle un peu plus pour vous situer.

                      Merci.

                      Commentaire


                      • #12
                        Envoyé par manu93fr Voir le message
                        Bonjour,

                        mets le serveur sur une version php5.6 et tu le sauras

                        est ce que toutes tes extensions étaient a jour ? Template compris ...
                        Je vais essayer de changer de version PHP, le problème est que que ce n'est pas vraiment un hébergeur professionnel qui héberge le site, il y a pas de Cpanel ou Plesk. Je dois faire de la manipulation sur Ubuntu, genre me connecter avec Putty et appliquer les commandes Sudo, Apt-get install et bla bla bla. Vous voyez le problème. Pour ce qui est des extensions, tout fonctionnait au moment de faire une sauvegarde Akeeba, je n'ai pas touché aux templates.
                        Dernière édition par garnut à 05/08/2018, 11h42

                        Commentaire

                        Annonce

                        Réduire
                        1 sur 2 < >

                        C'est [Réglé] et on n'en parle plus ?

                        A quoi ça sert ?
                        La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                        Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                        Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                        Comment ajouter la mention [Réglé] à votre discussion ?
                        1 - Aller sur votre discussion et éditer votre premier message :


                        2 - Cliquer sur la liste déroulante Préfixe.

                        3 - Choisir le préfixe [Réglé].


                        4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                        2 sur 2 < >

                        Assistance au forum - Outil de publication d'infos de votre site

                        Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                        Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                        Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                        UTILISER À VOS PROPRES RISQUES :
                        L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                        Problèmes connus :
                        FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                        Installation :

                        1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                        Archive zip : https://github.com/AFUJ/FPA/zipball/master

                        2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                        3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                        4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                        5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                        6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                        et remplacer www. votresite .com par votre nom de domaine


                        Exemples:
                        Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/
                        Pour executer le script: http://www..com/fpa-fr.php

                        Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                        Télécharger le script fpa-fr.php dans: /public_html/cms/
                        Pour executer le script: http://www..com/cms/fpa-fr.php

                        En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                        Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                        Voir plus
                        Voir moins

                        Partenaire de l'association

                        Réduire

                        Hébergeur Web PlanetHoster
                        Travaille ...
                        X