Installation plugin impossible à partir du web

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Installation plugin impossible à partir du web

    Bonjour

    depuis quelques temps je n'arrive plus à afficher la page d'installation des plugin à partir du web sur l'adresse url

    https://www.monsite.net/administrato...=com_installer

    J'ai deux autres site ou ça fonctionne bien
    mes sites sont chez ovh sur un mutualisé

    Site ou ça ne marche pas
    PHP exécuté sur Linux webm090.clusterxxx.xxx.hosting.ovh.net 4.14.11xxxxx #1 SMP Wed May 15 10:40:34 CEST 2019 x86_64
    Type de la base de données mysql
    Version de la base de données 5.6.43-log
    Interclassement de la base de données latin1_swedish_ci
    Collation de la connexion à la base de données utf8mb4_general_ci
    Version de PHP 7.2.19
    Serveur web Apache
    Serveur web pour interface PHP fpm-fcgi
    Version de Joomla Joomla! 3.9.13 Stable [ Amani ] 5-November-2019 15:00 GMT
    Version de la plateforme Joomla! Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
    Navigateur Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

    site ou ça marche
    PHP exécuté sur Linux webm076.cluxxxxx.ovh.net 4.1xxx-ovxxxxxxxs-classid #1 SMP Wed May 15 10:40:34 CEST 2019 x86_64
    Type de la base de données mysql
    Version de la base de données 5.6.43-log
    Interclassement de la base de données latin1_swedish_ci
    Collation de la connexion à la base de données utf8mb4_general_ci
    Version de PHP 7.2.19
    Serveur web Apache
    Serveur web pour interface PHP cgi-fcgi
    Version de Joomla Joomla! 3.9.13 Stable [ Amani ] 5-November-2019 15:00 GMT
    Version de la plateforme Joomla! Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
    Navigateur Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0
    Si quelqu'un à une psite
    merci d'avance
    Dernière édition par lesoutier à 07/11/2019, 19h15

  • #2
    Bonjour,

    Je ne comprends pas votre demande.

    Pour installer une extension, on passe par le menu de l'admin. Ok, cela génère un ?option=com_installer, mais, on n'est pas supposé le savoir....

    Si vous avez un problème suite à la dernière mise à jour de Joomla (vous êtes en 3.9.13, ), vous pouvez essayer de vérifier si votre base de données est bien à jour (extensions/gérer/base de données).

    Autre possibilité, refaire la mise à jour : Composants/Mis à jour de Joomla, cliquez sur "Rechercher les mises à jour", il doit vous proposer un bouton "Réinstaller les fichiers du noyau de Joomla".

    Pascal
    If anything can go wrong, it will...
    If I can help, I will ..https://conseilgouz.com

    Commentaire


    • #3
      Merci
      effectivement j'ai
      La table 'ydsh1_ucm_content' a un type ou attributs incorrects pour la colonne 'core_title' avec le type varchar(400) (du fichier 3.7.0-2017-01-08.sql).
      et ceci
      • Version du schéma de la base de données (dans #__schemas): 3.9.10-2019-07-09
      • Version de la mise à jour (dans #__extensions): 3.9.13.
      • Pilote de la base de données: mysqli
      • 171 modifications de base de données vérifiés.
      • 211 valeurs de modifications de la base de données ne changent pas la structure des tables et ont été ignorées.

      J'ai fait une réinstallation du noyau mais ça ne change rien



      Commentaire


      • #4
        En haut de la page de vérification de la base de données, il y a un bouton pour corriger la base. Est-ce que ça a été fait ?
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

        Commentaire


        • #5
          oups ! je n'avais pas vu le bouton
          c'est fait , je n'ai plus d'erreur mais ça ne marche toujours pas
          • Version du schéma de la base de données (dans #__schemas): 3.9.10-2019-07-09
          • Version de la mise à jour (dans #__extensions): 3.9.13.
          • Pilote de la base de données: mysqli
          • 172 modifications de base de données vérifiés.
          • 211 valeurs de modifications de la base de données ne changent pas la structure des tables et ont été ignorées.


          Mais ça ne marche toujours pas
          Dernière édition par oliv316 à 07/11/2019, 14h42

          Commentaire


          • #6
            je progresse... j'ai remis le dossier webinstaller par défaut dans le dossier plugins et j'ai ça mainteant

            Commentaire


            • #7
              Actuellement, vous avez WebInstaller qui ne fonctionne pas. Est-ce que les autres types d'installation 'Transférer un paquet', 'à partir d'un répertoire', d'une URL fonctionnent ?
              If anything can go wrong, it will...
              If I can help, I will ..https://conseilgouz.com

              Commentaire


              • #8
                Pour info, le package webinstaller est constitué de plusieurs répertoires. Vous pouvez le télécharger à l'adresse https://github.com/joomla-extensions...rom-web-client

                Pascal
                If anything can go wrong, it will...
                If I can help, I will ..https://conseilgouz.com

                Commentaire


                • #9
                  merci pour l'info j'ai resolu le problème
                  le dossier /media/plg_installer_webinstaller était vide je ne sais pour quelle raison
                  j'y ai recopié les dossier css et js et cela fonctionne

                  Commentaire

                  Annonce

                  Réduire
                  Aucune annonce pour le moment.

                  Partenaire de l'association

                  Réduire

                  Hébergeur Web PlanetHoster
                  Travaille ...
                  X