[résolu] connexion redirection "vous n'êtes pas autorisé à accéder à cette ressource"

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [résolu] connexion redirection "vous n'êtes pas autorisé à accéder à cette ressource"

    bonjour,

    J'ai un menu"Connexion" de type Utilisateur:Connexion accessible en Guest.
    Il affiche bien le formulaire d'autenfication.
    L'authentification fonctionne, le user est connecté.
    Par contre j'ai un message d'erreur "vous n'êtes pas autorisé à accéder à cette ressource", au-dessus de l'affichage de la page d'accueil (peu importe la page d'origine lors de la sollicitation du menu "Connexion").
    J'ai bien paramétré une redirection dans la configuration du menu, onglet paramètres, vers un menu accessible en public.

    En réactivant le module par défaut "Login Form" et en paramétrant la même redirection après connexion, je n'ai pas le message d'erreur et la bonne redirection.

    merci d'avance pour vos bonnes idées ?

    cordialement,
    sharlee33.
    Dernière édition par sharlee33 à 22/06/2018, 18h23

  • #2
    hello !

    pas de nouvelle, n'est pas une bonne nouvelle ce coup ci

    un petit up pour dénicher des pistes.

    merci d'avance,
    sharlee33.

    Commentaire


    • #3
      Bonjour,

      En voici une: https://kb.joomla.fr/messages/articl...ette-ressource
      Un message d’erreur sur votre site Joomla, consultez la base de connaissance https://kb.joomla.fr
      ---
      UP, un plugin "couteau suisse" à découvrir sur https//up.lomart.fr
      bgMax
      , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ... sur http://lomart.fr/extensions

      Commentaire


      • #4
        Merci lomart pour le lien, mais malheureusement cela ne me parait pas aussi simple

        Solution : Il est nécessaire de se connecter/s’authentifier sur le site avec un compte utilisateur ayant un niveau d’accès suffisant pour effectuer l'opération souhaitée.
        1. Soit vous n'êtes pas connecté avec un compte/mot de passe.
        2. Soit votre compte ne vous permet pas d'accéder à cette page ou d'effectuer l'action demandée.

        Si je re-active le module de login par défaut "Login Form", la connexion avec le même utilisateur ne génère aucun message d'erreur, et aboutit bien sur la page demandée (param "redirection après connexion").
        -->
        L'utilisateur existe bien, et n'a pas de problème de droit (d'ailleurs la page paramétrée en redirection est de niveau "public")

        Si j'utilise un item menu de type Connexion (index.php?option=com_users&view=login),
        - le formulaire d'authent s'affiche correctement
        - la validation du formulaire (user/pwd), génère ce message d'erreur et affiche la page d'accueil
        - le user est pourtant bien identifié et peut accéder aux pages du sites, protégées ou pas

        Qu'est-ce qui viendrait s'intercaler entre l'envoi du formulaire et la réalisation de l'authent ?


        sharlee33.


        Commentaire


        • #5
          Tout bête mais essaie avec le template Protostar.
          J'ai déjà eu le cas qu'un template n'implémentait pas correctement les redirections (dans ses overrides du Joomla natif donc).
          Et d'autres choses (genre l'option "Do not display" des menus etc).

          Bref, depuis, qd j'ai une fonctionnalité du noyau qui ne fonctionne pas normalement, je reteste toujours avec Protostar... et bien souvent là ça marche, prouvant alors que c'est le template en cause.
          Présentations : slides.woluweb.be, ...
          Custom Fields / Automatiser la restauration de ses sites / Lightning Talks / Toutes les nouveautés au fil des sous-versions de Joomla! 3.x / Devenir un testeur Joomla / Akeeba Backup & Amazon S3 / Acymailing & ElasticEmail / ...
          Coordonnées complètes : www.woluweb.be

          Commentaire


          • #6
            Bonjour,
            avec un lien et un compte "test" vers le site, on comprendrait peut etre mieux le souci
            “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr
            Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérer à l'AFUJ https://www.joomla.fr/association/adherer

            Commentaire


            • #7
              bonjour,

              Envoyé par manu93fr Voir le message
              Bonjour,
              avec un lien et un compte "test" vers le site, on comprendrait peut etre mieux le souci
              voici le site de test : https://test.ecole-musique-galgon.fr/
              et le user : sharlee/123456

              merci d'avance si vous voyez qqch

              sharlee33.

              Commentaire


              • #8
                Bonjour,

                Vous pouvez vérifier les paramètres du lien de menu de connexion.

                Conseil : effacer au lieu d'éditer ce lien sinon vous aurez une drôle de surprise



                Le module de connexion a aussi sa propre redirection,
                donc on suppose que vous défini la redirection dans le lien et c'est resté par défaut dans les paramètres du module.
                Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

                Commentaire


                • #9
                  bonjour daneel,

                  a) redirections avec valeurs
                  Le menu item "connexion" a en redirection un lien vers un autre menu item.
                  Le module "login form" a en redirection un lien vers une page.
                  -->
                  message d'erreur pour le menu "connexion"
                  pas de pb pour module "login form"

                  b) nouveau test : suppression des redirections, pour avoir "default"
                  Le menu item "connexion" a en redirection default
                  Le module "login form" a en redirection default
                  -->
                  message d'erreur pour le menu "connexion"
                  pas de pb pour module "login form"

                  Le site de test communiqué précédemment est resté actuellement sur cette conf b)

                  Vous pensez à autre chose ?

                  merci d'avance
                  sharlee33.

                  Commentaire


                  • #10
                    Envoyé par sharlee33 Voir le message

                    Vous pensez à autre chose ?
                    En l'absence de redirection, un problème de droit sur les acl (soit sur l'utilisateur, niveau, groupe, lien...) ou une erreur du template.

                    Sur les tests, le cache a bien été vidé ? Il faut vérifier chaque point.


                    Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

                    Commentaire


                    • #11
                      ok sur un rapide coup d'oeil, c'etait le lien de menu de connexion défini sur "guest" au lieu de public.

                      le message d'erreur "vous n'êtes pas autorisé à accéder à cette ressource" n'est plus affiché sur le site de test.

                      Problème réglé

                      Yann
                      Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

                      Commentaire


                      • #12
                        En passant le menu item "connexion" sur public, celui-ci est alors toujours affiché, même une fois l'utilisateur authentifié
                        C'est pour cela que je l'avais positionné sur guest, pour qu'il soit affiché uniquement si pas d'utilisateur connecté.

                        Commentaire


                        • #13
                          Je comprends.

                          Sur le dernier site que j'ai réalisé avec un lien qui était remplacé par un autre à la connexion.

                          J'ai utilisé bt login : http://bowthemes.com/joomla-extensio...in-module.html et intégré le module de connexion
                          Et j'ai créé un alias vers le lien de menu original, ce qui evite ce genre de conflit.

                          Cela m'a permis de créer un panneau front pour les utilisateurs avec un affichage global de leur activité et complétement personnalisé.
                          (agenda, messagerie, fichiers à télécharger, etc...)

                          Yann

                          Edit : c'est ok sur ton site avec l'alias de menu. L'alias vers le lien de connexion s'affiche en haut à droite.
                          Etant en "guest", il ne s'affiche plus à la connexion


                          Pour la redirection, il faudra voir avec le vrai lien de menu
                          Dernière édition par daneel à 22/06/2018, 16h11
                          Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

                          Commentaire


                          • #14
                            Merci daneel

                            Je ne connaissais pas cette notion d'alias de menu.
                            Je vais creuser.

                            sharlee33.

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X