migrer un site http vers https sous joomla 3

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • migrer un site http vers https sous joomla 3

    Bonjour,
    Je souhaite migrer mon site actuellement en http pour le passer en htps. Le site est hébergé chez OVH.
    J'ai suivi le tutoriel de web-eau net, après avoir demandé et obtenu un certificat ssl chez OVH.
    J'ai donc modifié et complété les deux fichiers "configuration.php" et htaccess.txt comme décrit dans le tutoriel, puis j'ai forcé le https dans le panneau de configuration de joomla.
    Mon problème est qu'après avoir fait cela, lorsque je vais sur mon site (en tant qu'administrateur comme en tant que simple visiteur) ce dernier s'affiche comme "non sécurisé" (https://www.l-echo-de-la-foret-de-li...ator/index.php, https en rouge et barré)
    Je ne vois pas où est mon erreur.
    Merci pour votre aide
    Dernière édition par jchermant à 25/03/2019, 13h28

  • jchermant
    a répondu
    Voilà, mon problème est résolu, il fallait juste que je fasse la manip de déclarer le certificat de sécurité pour le sous domaine que j'utilise. OVH m'a aidé, merci à OVH et à RobertG pour ces aides.

    Laisser un commentaire:


  • RobertG
    a répondu
    Comme je l'ai dit précédemment, il faut désactiver le fichier .htaccess s'il existe (à lire le message, il ne semble exister qu'un "htaccess.txt" que le serveur ignore) et t'assurer que dans la configuration du site, tu n'as pas forcé https pour le site et l'administration.
    Ensuite, ta valeur pour "$live_site" doit être vide :
    "public $live_site = '';"
    Ainsi, tu vas pouvoir tester (après avoir vidé le cache de ton navigateur et les cookies du site) les deux adresses en http et https : les deux doivent fonctionner sans erreur si le certificat est correct et s'il n'y a pas encore quelque part une redirection de http vers https.

    Laisser un commentaire:


  • jchermant
    a répondu
    Rebonjour,
    Voici ce que me répond l'assistance OVH :"
    Suite aux vérifications d'usage, je n'ai pas pu retracer le problème décrit. Le site est fonctionnel et accessible. Le certificat SSL est correctement installé et configuré." Et pourtant, dans la barre d'adresse, il est toujours signalé que le site est "non sécurisé". Et dans le fichier "configuration.php", à la racine du site il y a cette phrase : "public $live_site = 'https://www.l-echo-de-la-foret-de-liffre.fr';" Et dans le fichier"access.txt", à la racine du site il y a ces ajouts : "RewriteEngine On ## Begin - Rewrite rules to block out some common exploits. # If you experience problems on your site then comment out the operations listed # below by adding a # to the beginning of the line. # This attempts to block the most common type of exploit `attempts` on Joomla! # # Block any script trying to base64_encode data within the URL. RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR] # Block any script that includes a <script> tag in URL. RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR] # Block any script trying to set a PHP GLOBALS variable via URL. RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR] # Block any script trying to modify a _REQUEST variable via URL. RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2}) # Return 403 Forbidden header and show the content of the root home page RewriteRule .* index.php [F] RewriteCond %{HTTPS} OFF RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} # ## End - Rewrite rules to block out some common exploits." Qu'en pensez-vous ?

    Laisser un commentaire:


  • jchermant
    a répondu
    Bonjour RobertG,
    J'ai fait ce que tu m'as indiqué et le problème reste. J'en déduis donc qu'il y a un problème de certificat. Je contacte OVH pour voir le problème avec eux. Je clôturerai ce post dès que j'aurai une réponse d'OVH.
    Merci encore, Jean Claude

    Laisser un commentaire:


  • jchermant
    a répondu
    Merci RobertG, je vais essayer tout cela et je répondrai ensuite. Bonne soirée
    Jean Claude Hermant

    Laisser un commentaire:


  • RobertG
    a répondu
    Neutralise ces lignes dans le .htaccess ou renomme le .htaccess puis teste ton site en http et en https : il ne faut pas que ça bascule automatiquement vers https.
    Si en ouvrant l'adresse en https, tu as de nouveau le message d'alerte, c'est qu'il y a un problème de certificat.
    Si on passe l'alerte (sous Firefox comme sur Chrome les pages du site et de l'administration sont bloquées et n'affichent qu'une alerte de site douteux), il n'y a pas de "http://" dans le code-source, le blocage ne vient pas de là. Il y a quand même sur la page d'accueil deux images intégrées qui sont codées et qu'il vaudrait mieux remplacer par des images placées sur le serveur.

    Quand on regarde bien sous Chrome par exemple, il y a une mention précisant que le certificat n'est pas valide : à voir donc avec OVH.

    Laisser un commentaire:


  • jchermant
    a répondu
    Bonjour RobertG,
    Dans le panneau de configuration d'OVH, le certificat est activé, il y a écrit "oui" pour l'activation du certificat. Maintenant je ne sais pas comment vérifier autrement qu'il est bien présent.
    Pour ce qui est du fonctionnement du site en http, oui il fonctionnait bien depuis plusieurs années. Lorsque j'ai ajouté le code, le site fonctionne encore bien avec l'information en rouge dans la barre d'adresse "non sécurisé".

    Laisser un commentaire:


  • RobertG
    a répondu
    Tu ne parles pas du certificat lui-même : as-tu vérifié dans ton Manager qu'il est bien présent ?
    As-tu testé ton site en http et https sans ce code dans ton .htaccess (et sans forçage dans la configuration du site, si tu l'as aussi activé)

    Laisser un commentaire:


  • jchermant
    a répondu
    Bonjour ZerooCool,
    j'ai ajouté ces lignes :
    RewriteCond %{HTTPS} OFF
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
    que j'ai prises dans le tuto de Web eau net

    Laisser un commentaire:


  • ZerooCool
    a répondu
    Mon tuto est pour VPS, donc, voir avec le support OVH pour être sur que le certif fonctionne.
    Sinon, tu as modifié comment ton fichier .htaccess pour la redirection https ?

    Laisser un commentaire:


  • GraphiqueDesign
    a répondu
    +1 avec Eddy !
    Le certificat est installé par défaut chez OVH, juste en tapant ton URL avec https, tu devrais déjà avoir un petit résultat approximatif. Peut être as tu fait une mauvaise manipulation, tente peut être de le régénérer via la console.

    Laisser un commentaire:


  • Eddy.vh
    a répondu
    Bonjour.

    Je ne comprends pas bien la.demande d'un certificat à OVH puisque ce certificat est installé automatiquement sur tous les plans mutualisés.

    La demande est donc inutile...
    J'avais un vieux 240plan (pro) chez eux où le certificat (Let's encrypt si je ne m'abuse) était installé et accessible. Il suffisait de passer le site en https et l'affaire était dans le sac.

    Laisser un commentaire:


  • jchermant
    a répondu
    Bonjour ZerooCool,
    Le site est sur un serveur mutualisé. J'ai demandé un ssl auprès de OVH (ssl gratuit) que j'ai obtenu. Et cela ne marche pas...
    J'ai posé la question à l'assistance de OVH, j'attends leur réponse.
    Merci pour ton aide, je suis preneur de ton tutoriel si tu le veux bien. Cordialement
    Jean Claude Hermant

    Laisser un commentaire:


  • ZerooCool
    a répondu
    Serveur Dédié, VPS ou mutualisé ?
    Si serveur mutualisé, demande au support OVH.
    Si serveur dédié ou VPS, je peux te passer un tutoriel fonctionnel pour générer ton certificat.

    Laisser un commentaire:

Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X