Joomladay francophone 2018 à Paris 18 et 19 mai

WAMP server ne démarre plus

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] WAMP server ne démarre plus

    Bonjour et AUUUUU SECOUUUUUURSSSS !!

    Voilà 4 mois que je développe mon site en local et ... boom, ce matin, wamp serveur ne démarre plus, l’icône reste orange. Je consulte les forums et :

    1. je teste le port 80 : il me dit qu'il n'est pas utilisé
    2. je tente de changer tout de même de port : aucun résultat
    3. j'ai bidouillé le httpd.conf pour remettre le port 80 par défaut : rien y fait sauf que maintenant l'icone wamp ne se met plus en orange, mais reste totalement rouge !!!

    NB : En réalité à l'étape 3, j'ai copié le contenu de httpd.conf (qui apparaissait en ligne au kilomètre) et je l'ai déposé dans NotePad++. Puis de NotePad, j'ai à nouveau copié et remis dans httpd.conf (cette fois le contenu apparaissant en tableau) !!!



    J'ai regardé la procédure de réinstallation ... c'est juste inaccessible pour un profane comme moi ... j'en appelle au secours car je n'ai pas envie de perdre bêtement 4 mois de travail !!!

    voici ce que les derniers Error Log me donne :

    [Fri Dec 18 06:23:21.146582 2015] [core:notice] [pid 2060:tid 384] AH00094: Command line: 'c:\\wamp\\bin\\apache\\apache2.4.9\\bin\\httpd.ex e -d C:/wamp/bin/apache/apache2.4.9'
    [Fri Dec 18 06:23:21.146582 2015] [mpm_winnt:notice] [pid 2060:tid 384] AH00418: Parent: Created child process 3260
    [Fri Dec 18 06:23:21.598983 2015] [mpm_winnt:notice] [pid 3260:tid 308] AH00354: Child: Starting 64 worker threads.
    [Fri Dec 18 06:25:15.729778 2015] [mpm_winnt:notice] [pid 2060:tid 384] AH00422: Parent: Received shutdown signal -- Shutting down the server.
    [Fri Dec 18 06:25:17.730892 2015] [mpm_winnt:notice] [pid 3260:tid 308] AH00364: Child: All worker threads have exited.
    [Fri Dec 18 06:25:17.746893 2015] [mpm_winnt:notice] [pid 2060:tid 384] AH00430: Parent: Child process 3260 exited successfully.
    [Fri Dec 18 06:25:20.062026 2015] [mpm_winnt:notice] [pid 3292:tid 384] AH00455: Apache/2.4.9 (Win32) PHP/5.5.12 configured -- resuming normal operations
    [Fri Dec 18 06:25:20.062026 2015] [mpm_winnt:notice] [pid 3292:tid 384] AH00456: Apache Lounge VC11 Server built: Mar 16 2014 12:13:13
    [Fri Dec 18 06:25:20.062026 2015] [core:notice] [pid 3292:tid 384] AH00094: Command line: 'c:\\wamp\\bin\\apache\\apache2.4.9\\bin\\httpd.ex e -d C:/wamp/bin/apache/apache2.4.9'
    [Fri Dec 18 06:25:20.063026 2015] [mpm_winnt:notice] [pid 3292:tid 384] AH00418: Parent: Created child process 348
    [Fri Dec 18 06:25:20.547053 2015] [mpm_winnt:notice] [pid 348:tid 308] AH00354: Child: Starting 64 worker threads.
    [Fri Dec 18 06:25:56.127121 2015] [mpm_winnt:notice] [pid 3292:tid 384] AH00422: Parent: Received shutdown signal -- Shutting down the server.
    [Fri Dec 18 06:25:58.155125 2015] [mpm_winnt:notice] [pid 348:tid 308] AH00364: Child: All worker threads have exited.
    [Fri Dec 18 06:25:58.170725 2015] [mpm_winnt:notice] [pid 3292:tid 384] AH00430: Parent: Child process 348 exited successfully.


    Et les derniers Apache access Log :

    ::1 - - [18/Dec/2015:06:07:00 +0100] "GET /mon_site_test_1/administrator/ HTTP/1.1" 500 93
    ::1 - - [18/Dec/2015:06:07:27 +0100] "GET /mon_site_test_1/administrator/ HTTP/1.1" 500 93
    ::1 - - [18/Dec/2015:06:07:32 +0100] "GET /mon_site_test_1/ HTTP/1.1" 500 93
    ::1 - - [18/Dec/2015:06:07:41 +0100] "GET /mon_site_test_1/ HTTP/1.1" 500 93
    127.0.0.1 - - [18/Dec/2015:06:09:01 +0100] "GET / HTTP/1.1" 200 5140

    Merci d'avance au bon samaritain qui voudra bien et pourra m'aider parce que là ... je flippe grave !!!!!!

    + +

    lolo
    Dernière édition par lolosurleweb à 18/12/2015, 06h44

  • #2
    Re : WAMP server ne démarre plus

    Bonjour,

    Bon première chose : se calmer et réfléchir tranquillement avant de faire de grosses bêtises.

    1) indispensable et urgent, rechercher où se trouvent (physiquement) ton site local et ta base de données mysql locale. Ton site local est un ensemble de fichiers probablement situé dans un répertoire de même nom que ton site et située sous l'arborescence d'installation de ta pile AMP (peut pas t'en dire plus, j'utilise easyPHP pas wampserver). Une fois l'emplacement repéré, mettre à l'abri (copie de fichiers) toute la structure de répertoire démarrant à partir de ce nom de site
    (pour simplifier mes explications peut être pas très claire, si tu lançais ton site avec quelque chose comme http://localhost/monsitedemo ou http://localhost/monsitedemo/administrator il te faut rechercher et sauvegarder le répertoire monsitedemo\ et tout ce qu'il y a en dessous)
    2) il te faut également faire la même chose avec l'emplacement de ta base de données mySQL. Elle aussi est sauvegardée sous forme de fichiers dans un répertoire monsitedemo\ situé ailleurs dans l'arborescence wampserver et comportera a minima un fichier db.opt plus autant de fichiers .frm, .MYI et .MYD que tu as de tables dans cette base

    Avec easyPHP, mon installation de test lancée via http:\\localhost\dec2015 est trouvée dans : X:\EasyPHP-DevServer\data\localweb\dec2015 en ce qui concerne le site (fichiers et extensions, plugins, images etc... et dans X:\EasyPHP-DevServer\binaries\mysql\data\dec2015 pour les tables mySQL

    Sauvegarder les deux répertoires autorise une forme de restauration manuelle pas orthodoxe mais efficace.

    3) Il te faut comprendre pourquoi le serveur ne démarre pas. Je ne sais pas si tu travailles sur PC ou sur Mac, mais dans les deux cas, ton installation wampserver dispose de fichiers logs. Les logs HTTP bien sûr, mais aussi les logs Apache qui détaillent kle lancement et l'exécution du site. Il te faut les trouver et les consulter pour déterminer ce qui pose problème.
    Pour easyPHP (désolé de mes références !), ceci s'obtient en effectuant un clic droit sur l'icône du serveur (même si le lancement a échoué) et ouvrant le sous-menu clic-droit > fichiers log > erreurs apache

    [EDIT] oooppss désolé, je n'avais pas lu jusqu'au bout, tu as bien cherché les logs apache..... pas très explicites au demeurant sur la cause du shutdown. As tu rebooté complètement ton PC (ou Mac) ?

    Tiens nous au courant et bon courage
    Dernière édition par PieceOfCake à 18/12/2015, 08h12
    Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

    Commentaire


    • #3
      Re : WAMP server ne démarre plus

      Salut PieceOfCake,

      et merci de ta réponse et du temps consacré. C'est vrai que ce matin, j'étais sévèrement en panique. Mon problème n'est pas résolu mais ça va mieux

      Pour répondre à tes questions, je suis sûr PC - win 7. J'ai tenté de rebooter au moins 3 fois sans succès et j'ai même éteint via MSCONFIG tous les programmes/services qui se lancent au démarrage, pour libérer le port 80 à priori encombré . . . sans succès.

      Du coup je me dit qu'une réinstallation de WAMP s'impose ? ? ? Car je ne suis pas sûr d'être capable de trouver l'origine du problème. En plus, je me demande si mes bidouilles dans les httpd.conf sont bonnes, le cas échéant, je ne serai probablement pas capable de les corriger (sauf si je trouve à faire un copier/coller du code d'origine).

      La "bonne" (j'espère) nouvelle, c'est que la veille, j'ai fais une sauvegarde Akeeba (en local). J'ai donc qq part sur mon PC, une sauvegarde fraiche et complète de mon site. Alors je me suis posé la question suivante :

      (1) Serait-il possible de désinstaller - réinstaller un WAMP tout neuf, puis (2) de créer un nouveau site vierge joomla, qui porterait le même nom que celui que je veux récupérer et (3) y installer Akeeba et faire un "rappel" de sauvegarde de mon précédent site ?

      Qu'en penses tu ?

      Merci d'avance,

      + +

      Lolo.

      Commentaire


      • #4
        Re : WAMP server ne démarre plus

        (1) Serait-il possible de désinstaller - réinstaller un WAMP tout neuf, puis (2) de créer un nouveau site vierge joomla, qui porterait le même nom que celui que je veux récupérer et (3) y installer Akeeba et faire un "rappel" de sauvegarde de mon précédent site ?


        Ca c'est la solution parfaite

        1) réinstaller Wamp Server (ou tout autre AMP de ton choix), il n'y a aucune dépendance entre la pile AMP et la sauvegarde Akeeba.

        2) Recréer le répertoire dans lequel tu souhaites exécuter ton site (relire dans ma réponse la relation entre nom de répertorie et site local avec une pile AMP

        3) à la racine de ce répertoire copier le fichier .jpa ainsi que les deux fichiers Akeeba pour la restauration (fr-FR.kickstart.ini et kickstart.php) que tu trouveras sur le site Akeeba dans la partie products (https://www.akeebabackup.com/product...kickstart.html)

        et il te restera juste à exécuter http://localhost/monsite/kickstart.php et à remplir tranquillement les différents formulaires et patienter (pas longtemps) pour tout retrouver en état

        Tiens nous informés

        PS : Si tu n'es pas sûr de tes connaissances en matière de Akeeba relire d'abord : http://cinnk.com/joomla/3/tutoriels?view=entry&id=59
        Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

        Commentaire


        • #5
          Re : WAMP server ne démarre plus

          Ahhhhhhh Merci Merci Merci PieceOfCake Gratitude éternelle Mon site est de retour

          J'ai désinstallé/résinstallé WAMP (qui au passage à conservé toutes mes bases et je me suis servi de ta procédure + ces 2 tutos :

          http://www.web-eau.net/tutoriels-joomla?catid=0&id=205

          http://web.lliseil.fr/joomla/tutos/e...a-restauration

          Pour info (aux profanes), il n'y a pas besoin de résinstaller un site joomla neuf. Les trois fichiers fr-FR.kickstart.ini, kickstart.php et trucmuche.jpa suffisent à eux seuls !!

          Enfin et toujours .... AKEEBA = Extension n°1 ... sans ça et sans sauvegarde régulière, j'aurais été dans une m...de noire. Grâce aux sauvegardes, je viens de retrouver mon site intégral, sans perte, et WAMP fonctionne de nouveau

          Génial et merci encore PieceOfCake

          + +

          Lolo

          Commentaire

          Annonce

          Réduire
          1 sur 2 < >

          C'est [Réglé] et on n'en parle plus ?

          A quoi ça sert ?
          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
          Comment ajouter la mention [Réglé] à votre discussion ?
          1 - Aller sur votre discussion et éditer votre premier message :


          2 - Cliquer sur la liste déroulante Préfixe.

          3 - Choisir le préfixe [Réglé].


          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

          2 sur 2 < >

          Assistance au forum - Outil de publication d'infos de votre site

          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

          UTILISER À VOS PROPRES RISQUES :
          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

          Problèmes connus :
          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

          Installation :

          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

          Archive zip : https://github.com/AFUJ/FPA/zipball/master

          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
          et remplacer www. votresite .com par votre nom de domaine


          Exemples:
          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/
          Pour executer le script: http://www..com/fpa-fr.php

          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
          Télécharger le script fpa-fr.php dans: /public_html/cms/
          Pour executer le script: http://www..com/cms/fpa-fr.php

          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
          Voir plus
          Voir moins
          Travaille ...
          X