Liens web : pas dans nouvelle fenêtre ?

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Liens web : pas dans nouvelle fenêtre ?

    Bonjour à tous !

    Je viens de m'apercevoir, en reprenant mon site de couteaux https://les-couteaux.de-ergé.fr/ que dans les deux modules de liens web "Quelques coups de cœur" et "Voir aussi", bien que les paramètres du composant soient définis pour ouvrir les liens dans une nouvelle fenêtre, ces liens s'ouvrent dans la fenêtre actuelle.
    J'ai eu beau chercher, je n'ai pas trouvé de solution, sinon celle de refaire mes listes sous forme de module personnalisé...

    Avez-vous rencontré ce problème, est-il possible de corriger ça (il n'y a actuellement aucune surcharge dans le template) ?
    merci de vos conseils !
    Robert
    Dernière édition par RobertG à 10/08/2019, 17h03
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

  • #2
    Bonjour Robert,

    Je viens de regarder sur mon site et le comportement est effectivement bizarre.

    Dans mes liens web, j'ai mis "Cible du lien" à "paramètres généraux" et, dans mes paramètres généraux", j'ai "Ouvrir dans la fenêtre parent", or, cela m'ouvre un nouvel onglet.

    Pascal
    RobertG likes this.
    If anything can go wrong, it will...
    If I can help, I will ..https://conseilgouz.com

    Commentaire


    • #3
      Merci Pascal,

      Quelle version as-tu ? Je n'ai pas "paramètres généraux" dans les réglages du composant, en version 3.6.0 récupérée sur Github (j'étais jusqu'ici en 3.5.0 et je n'ai pas trouvé d'autre version).

      Précision : si l'affichage des liens est de type composant, pas de problème de fenêtre !
      Dernière édition par RobertG à 10/08/2019, 11h00
      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
      MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

      Commentaire


      • #4
        Je suis en version 3.6.0 et ,dans le composant, en haut à droite, j'ai le bouton "paramètres". On peu aussi y accéder par Système, Configuration,Liens web.

        Pascal
        If anything can go wrong, it will...
        If I can help, I will ..https://conseilgouz.com

        Commentaire


        • #5
          Soit ma 3.6.0 a foiré à l'installation, soit il y a un hic quelque part, je n'ai pas dans les paramètres généraux du composant de possibilité de choisir les paramètres par défaut du site, sauf pour le captcha.
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
          MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

          Commentaire


          • #6
            Je viens de vérifier dans la version disponible sous Github (https://github.com/joomla-extensions/weblinks) et, dans le fichier administrator/components/com_weblinks/config.xml, qui correspond à ce qui est affiché dans système/configuration/liens webs, sous le captcha, il y a pas mal de monde, dont "target" (cible du lien, en français).

            Bizarre, bizarre.
            If anything can go wrong, it will...
            If I can help, I will ..https://conseilgouz.com

            Commentaire


            • #7
              En fait, comme je l'ai dit, c'est seulement le module qui pose problème, pas le composant. Je n'ai pas étudié son code.

              Je viens de regarder : il y a bien la gestion des destinations dans le module, reste à comprendre pourquoi ça ne fonctionne pas.
              Dernière édition par RobertG à 10/08/2019, 13h08
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

              Commentaire


              • #8
                Le module ne fait pas grand chose, il appelle le composant....
                If anything can go wrong, it will...
                If I can help, I will ..https://conseilgouz.com

                Commentaire


                • #9
                  Oui, mais dans le module, il semble que ala configuration du composant n'est pas récupérée, et par défaut, au lieu que faute de choix le lien soit ouvert dans une nouvelle fenêtre, il l'est dans le site, alors que ces liens étant a priori externes, il serait plus logique que l'ouverture se fasse par défaut dans une nouvelle fenêtre...
                  Il me semble qu'avant que ce composant/module disparaisse du core, le comportement par défaut était vers une nouvelle fenêtre.
                  "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                  MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

                  Commentaire


                  • #10
                    J'ai un site avec le composant Liens Web. Je viens de vérifier, le paramètre par défaut est d'ouvrir dans une nouvelle fenêtre (onglet) mais dans le module, les liens s'ouvrent dans la même fenêtre.

                    Si j'édite un lien dans le composant et que je lui précise une ouverture dans une nouvelle fenêtre alors ça le fait…

                    Dans le pied de page, j'ai 4 blocs de liens (Scripts Blogs / Sites, Divers, General Sites, Scripting Forums).

                    J'ai corrigé les liens des 3 premiers, seule les lien de Scripting Forums sont inchangés pour que vous puissiez y jeter un œil en cas d'envie.

                    C'est bizarre en effet que les target="_blank" aient disparu.
                    En tous cas, pour ce site précis, j'ai hérité du composant de J! 2.5 en migrant vers J! 3.x et j'ai donc la version core.
                    Dernière édition par Eddy.vh à 10/08/2019, 16h43
                    RobertG likes this.
                    Cordialement.
                    __
                    Eddy !!!
                    Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

                    Commentaire


                    • #11
                      Merci Eddy !

                      En effet, dans les liens définis depuis le composant, tous étaient paramétrés pour utiliser les paramètres globaux, qui eux sont définis pour l'ouverture dans une nouvelle fenêtre. Si je les modifie un à un pour forcer l'ouverture dans une nouvelle fenêtre, ça fonctionne, le module suit bien les instructions.
                      J'ai comparé avec un autre site où j'avais déjà paramétré chaque lien pour une ouverture dans une nouvelle fenêtre, les deux étant des sites 2.5 migrés avec conservation du composant.
                      Je ne comprends d’ailleurs pas pourquoi ce composant a disparu. Au départ, si je ne me trompe, après suppression du core il était proposé en extension, mais je ne l'ai pas retrouvé sur le JED (mal cherché ?).
                      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                      MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

                      Commentaire


                      • #12
                        Un petit tour sur https://extensions.joomla.org/extension/weblinks/

                        Pascal
                        If anything can go wrong, it will...
                        If I can help, I will ..https://conseilgouz.com

                        Commentaire


                        • #13
                          Merci Pascal ! J'avais vu le titre, mais pas fait le lien !
                          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                          MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins

                          Partenaire de l'association

                          Réduire

                          Hébergeur Web PlanetHoster
                          Travaille ...
                          X