Changement GoogleMap API

Réduire
Ceci est un sujet important.
X
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • fabrice4821
    a répondu
    Re : Changement GoogleMap API

    Bonjour,

    Cela ressemble fortement à un problème de clé Google.
    As tu regardé les messages d'erreur dans la console de débogage de ton navigateur ?
    As tu un lien ?

    Laisser un commentaire:


  • JBNCRAV
    a répondu
    Re : Changement GoogleMap API

    Envoyé par daneel Voir le message
    Bonjour,

    le 22 Juin 2016, Google nous a informé du changement dans l'API de google MAP.

    http://googlegeodevelopers.blogspot....to-google.html


    Après 11 ans d'utilisation, 3 millions d'applications et des milliards de requêtes sur les sites web, l'API de GoogleMAP subit quelques changement avec une mise à jour.

    Concrètement, il faudra saisir obligatoirement une clé API pour que les requêtes et affichage de carte GoogleMap fonctionne. Vous devez vérifier que votre extension Joomla soit à jour et que la clé soit bien défini dans les paramètres de l'extension.

    Vous pouvez obtenir une clé depuis :
    https://developers.google.com/maps/d...pt/get-api-key

    Les limites quotidiennes sont redéfinies mais elles sont toujours assez larges pour utiliser gratuitement pour la plupart des sites... Pour plus d'infos :
    https://developers.google.com/maps/p...an-2016-update
    https://developers.google.com/maps/pricing-and-plans/

    En résumé, si l'extension utilisant GoogleMAP ne propose pas de saisir de clé API, il y a peu de chance qu'elle fonctionne. Je vous invite également à vérifier également la date de mise à jour de l'extension soit la plus récente possible.

    N'hésitez pas à commenter ce fil de discussion de vos tests d'extensions utilisant GoogleMAP.
    Bonjour à tous,

    j'utilise Allevents sur joomla 3.6.4. Pas d'affichage de google maps. En fouillant dans les forums, je m'aperçois qu'effectivement il faut renseigner le numéro d'API de google maps. Après avoir effectué la démarche et obtenu le sésame, le fonctionnement n'est pas au top. Apparition de la carte et 2 à 3 secondes après plus rien. J'utilise Firefox et mes drivers de carte graphique sont a jour. Quelqu'un aurait il une idée pour résoudre ce pb. Merci d'avance JBNCRAV

    Laisser un commentaire:


  • PhilJ
    a répondu
    Re : Changement GoogleMap API

    Envoyé par dolnar Voir le message
    [...] Trop top, j'ai pas eu besoin d'une extension. Mais je sais pas si cela est judicieux de le faire ainsi.
    En effet, c'est tout aussi judicieux qu'une extension — sauf cas particuliers où une extension permet plus de possibilités.

    Laisser un commentaire:


  • lesoutier
    a répondu
    Re : Changement GoogleMap API

    Mais je sais pas si cela est judicieux de le faire ainsi.
    C'est une des solutions possibles, et elle semble te convenir, c'est l'essentiel.


    Si c'est réglé merci de l'indiquer :
    http://forum.joomla.fr/announcement.php?f=230

    Laisser un commentaire:


  • dolnar
    a répondu
    Re : Changement GoogleMap API

    J'ai finalement réussi à mettre ma google map sur mon site web. Ce que j'ai fait :
    1 - Je me suis connecté à l'interface d'administration de Joomla, puis Extensions -> Plug-ins -> Editeur-TinyMCE
    2 - Dans le champ "éléments prohibés", j'ai supprimé le mot iframe puis j'ai enregistré.
    3 - J'ai créé un module personnalisé dans lequel j'ai copié le code iframe de google map embeded API avec ma clé API puis j'ai positionné le module et j'ai enregistré ensuite.

    Et voilà, ma carte c'est littéralement affiché. Puis il a fallu que je me rendre dans ce module pour définir la taille de la Google Map.
    Trop top, j'ai pas eu besoin d'une extension. Mais je sais pas si cela est judicieux de le faire ainsi.
    Dernière édition par dolnar à 25/10/2016, 13h32

    Laisser un commentaire:


  • fabrice4821
    a répondu
    Re : Changement GoogleMap API

    Bonjour,

    Pour information et ceux qui cherche un petit tuto pour créer une clé google, vous pouvez aller sur :
    http://gmapfp.org/fr/news/41-tuto-co...le-pour-gmapfp

    Ce tuto est fait pour GMapFP, mais le principe est le même pour toutes les extension fonctionnant avec Google Map.

    Laisser un commentaire:


  • dolnar
    a répondu
    Re : Changement GoogleMap API

    Actuellement rien ne s'affiche en front-end, en back-end le module est activé et j'ai entré l'api key sans la partie "key=" mais j'ai toujours le même soucis.

    Laisser un commentaire:


  • PhilJ
    a répondu
    Re : Changement GoogleMap API

    Bonjour,


    Envoyé par dolnar Voir le message
    Sur le site de Google Map API il demande de l'ajouter. [...]
    Le site de l'API Google Map donne un exemple d'intégration d'une carte à l'aide d'un iframe. Dans ce cas, effectivement, il faut qu'il y ait key= dans la chaîne appelant l'affichage de la carte. Mais ici ce n'est pas requis car l'intégration se fait à l'aide d'une extension.


    J'ai téléchargé le module SP Simple Map de Joomshaper mais cela ne fonctionne pas
    Remarquez que deux types de dysfonctionnements peuvent survenir : (1) la carte ne s'affiche pas en frontend / sur le site ; (2) l'autocomplétion ne fonctionne pas depuis l'administration. Votre problème est bien en frontend ?

    Laisser un commentaire:


  • dolnar
    a répondu
    Re : Changement GoogleMap API

    Sur le site de Google Map API il demande de l'ajouter. Mais j'ai aussi fait cela. Moi j'ai choisi "Maps Embed API" pour le web. https://developers.google.com/maps/d...ed/start?hl=fr
    Est-ce qu'il faut un choix d'application Google Map API plus spécifique?
    Dernière édition par dolnar à 21/10/2016, 16h29

    Laisser un commentaire:


  • pmleconte
    a répondu
    Re : Changement GoogleMap API

    J'ai un doute: votre clé commence par key=... Avez-vous essayé de supprimer ça, pour commencer par Alza....?

    Pascal

    Laisser un commentaire:


  • dolnar
    a répondu
    Re : Changement GoogleMap API

    Envoyé par daneel Voir le message
    Bonjour,

    le 22 Juin 2016, Google nous a informé du changement dans l'API de google MAP.

    http://googlegeodevelopers.blogspot....to-google.html


    Après 11 ans d'utilisation, 3 millions d'applications et des milliards de requêtes sur les sites web, l'API de GoogleMAP subit quelques changement avec une mise à jour.

    Concrètement, il faudra saisir obligatoirement une clé API pour que les requêtes et affichage de carte GoogleMap fonctionne. Vous devez vérifier que votre extension Joomla soit à jour et que la clé soit bien défini dans les paramètres de l'extension.

    Vous pouvez obtenir une clé depuis :
    https://developers.google.com/maps/d...pt/get-api-key

    Les limites quotidiennes sont redéfinies mais elles sont toujours assez larges pour utiliser gratuitement pour la plupart des sites... Pour plus d'infos :
    https://developers.google.com/maps/p...an-2016-update
    https://developers.google.com/maps/pricing-and-plans/

    En résumé, si l'extension utilisant GoogleMAP ne propose pas de saisir de clé API, il y a peu de chance qu'elle fonctionne. Je vous invite également à vérifier également la date de mise à jour de l'extension soit la plus récente possible.

    N'hésitez pas à commenter ce fil de discussion de vos tests d'extensions utilisant GoogleMAP.
    Quelles sont les extensions pour l'affichage d'une Google Map qui fonctionnent avec la nouvelle mise à jour de Google? J'ai téléchargé le module SP Simple Map de Joomshaper mais cela ne fonctionne pas et pourtant il demande bien l'API KEY.

    Cliquez sur l'image pour l'afficher en taille normale

Nom : google_map_discussion.jpg 
Affichages : 1 
Taille : 23,0 Ko 
ID : 1805844
    Dernière édition par dolnar à 21/10/2016, 16h17

    Laisser un commentaire:


  • fynhooft
    a répondu
    Re : Changement GoogleMap API

    Envoyé par pmleconte Voir le message
    En complément, je viens d'essayer OSModul, c'est vrai qu'il est beau et règle le problème googlemap.
    Eventuellement, tu peux regarder ce post du forum auquel j'avais répondu sur osmodul. Il y a quelques trucs qui peuvent servir.

    Laisser un commentaire:


  • pmleconte
    a répondu
    Re : Changement GoogleMap API

    En complément, je viens d'essayer OSModul, c'est vrai qu'il est beau et règle le problème googlemap.

    Merci à vous 2.

    Pascal

    Laisser un commentaire:


  • pmleconte
    a répondu
    Re : Changement GoogleMap API

    Bonsoir fynhooft et PhilJ,

    Le problème est qu'à force de vouloir faire de l'interactif à tout prix, on en oublie les temps de réponse (j'habite dans la cambrousse, la 3G est encore loin, la fibre devrait arriver en 2020, la vitesse Internet maxi est à 1,5M), donc, je cherche du simple et efficace, en limitant les accès externes....

    Si l'utilisateur veut plus que ce que je lui propose, il clique (de toutes façons, pour interagir, il faut cliquer, non ?) et accède au site googlemap. Je sais, vous allez me reprocher qu'il sort de mon site, mais c'est un moindre mal.

    A force de rajouter des couches/plugins/composants sensés tout simplifier, on galère à chaque mise à jour (Joomla, php, sql, google api, .....).

    Mes 2 ou 3 lignes de codes restent compatibles (tant que googlemap existe)....et la surcharge réseau inexistante (mon jpg est petit)...

    Bonne soirée,

    Pascal

    Laisser un commentaire:


  • PhilJ
    a répondu
    Re : Changement GoogleMap API

    Bonjour fynhooft,



    Envoyé par fynhooft Voir le message
    Il y a encore une autre solution : tu peux utiliser openstreetmap.org . Regarde ta carte avec openstreetmap. Tu gardes ainsi l'interactivité et tu oublies Google
    Effectivement, et c'est même faisable facilement avec une extension telle que 'OSModul' (http://extensions.joomla.org/extension/osmodul)... mais cela ne résout pas vraiment le problème posé par les composants utilisant nativement des Google Maps (typiquement : les gestionnaires d'événements), du moins pour le moment.



    Bonne soirée,

    Laisser un commentaire:

Annonce

Réduire
1 sur 2 < >

C'est [Réglé] et on n'en parle plus ?

A quoi ça sert ?
La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
Comment ajouter la mention [Réglé] à votre discussion ?
1 - Aller sur votre discussion et éditer votre premier message :


2 - Cliquer sur la liste déroulante Préfixe.

3 - Choisir le préfixe [Réglé].


4 - Et voilà… votre discussion est désormais identifiée comme réglée.

2 sur 2 < >

Assistance au forum - Outil de publication d'infos de votre site

Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

UTILISER À VOS PROPRES RISQUES :
L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

Problèmes connus :
FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

Installation :

1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

Archive zip : https://github.com/AFUJ/FPA/zipball/master

2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
et remplacer www. votresite .com par votre nom de domaine


Exemples:
Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/
Pour executer le script: http://www..com/fpa-fr.php

Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
Télécharger le script fpa-fr.php dans: /public_html/cms/
Pour executer le script: http://www..com/cms/fpa-fr.php

En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
Voir plus
Voir moins

Partenaire de l'association

Réduire

Hébergeur Web PlanetHoster
Travaille ...
X