Joomladay francophone 2018 à Paris 18 et 19 mai

Problème avec JCE Editor depuis la dernière mise à jour

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Problème avec JCE Editor depuis la dernière mise à jour

    Bonsoir,
    Depuis que j'ai fais la mise à jour vers JCE Editor 2.6, les outils de l'éditeurs ont changé, je vous poste une capture d'écran et vous allez comprendre le soucis je pense :


    Il y a les noms des variables ont dirait avec advanced.le-nom-de-l'outil.

    Comment corriger ceci ?

    Merci.
    Dernière édition par LolYangccool à 01/12/2016, 17h28

  • #2
    Re : Problème avec JCE Editor depuis la dernière mise à jour

    Envoyé par LolYangccool Voir le message
    Bonsoir,
    Depuis que j'ai fais la mise à jour vers JCE Editor 2.6, les outils de l'éditeurs ont changé, je vous poste une capture d'écran et vous allez comprendre le soucis je pense :


    Il y a les noms des variables ont dirait avec advanced.le-nom-de-l'outil.

    Comment corriger ceci ?

    Merci.
    tu t attends a quoi normalement ?
    Mon site de documentation sur Joomla et le CCK K2 : http://documentation.informaticien51.fr
    Une notice pour le CCK K2 ( mise à jour le 01/06/2015) :
    http://documentation.informaticien51...couverte-de-k2

    Commentaire


    • #3
      Re : Problème avec JCE Editor depuis la dernière mise à jour

      Bonjour,

      Il ne s'agit pas de "noms de variables" mais du détail CSS de l'objet. Par exemple :
      advanced.h1 correspond à l'élément HTML <H1> sur lequel est appliqué la classe advanced, ce qui permet d'appliquer en une seule fois les deux (voire plus) effets sur la même sélection de texte au lieu de devoir cliquer sur le choix h1 puis de choisir la classe advanced

      Cordialement
      Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

      Commentaire


      • #4
        Re : Problème avec JCE Editor depuis la dernière mise à jour

        advanced.h1 correspond à l'élément HTML <H1> sur lequel est appliqué la classe advanced
        Salut PieceOfCake,
        Désole de te contredire, mais cette notation de sélecteur ne correspond à rien. J'ai fait une simulation pour vérifier
        https://jsfiddle.net/fuj3eqpj/
        D'ailleurs, si l'on affecte le style advanced.h1 a un paragraphe (p), JCE 2.6 n'affecte aucune classe, mais transforme la balise p en h1

        Avec la version 2.6, beaucoup de choses ont l'air d'avoir changé : http://forum.joomla.fr/showthread.ph...-coloris%C3%A9
        Avec Ghazal et Manu93fr nous guiderons les Grands Débutants au https://www.joomladay.fr/ le 19 mai à Paris
        ---
        UP, un plugin "couteau suisse" à découvrir sur https//up.lomart.fr
        bgMax
        , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ...
        plein de nouveaux modules et plugins sur http://lomart.fr/extensions

        Commentaire


        • #5
          Re : Problème avec JCE Editor depuis la dernière mise à jour

          Bonjour,
          Merci pour vos réponses.

          En fait, avant la mise à jour, il était noté Header 1 par exemple, à la place de advanced.h1.

          Merci à vous.

          Commentaire


          • #6
            Re : Problème avec JCE Editor depuis la dernière mise à jour

            En fait, avant la mise à jour, il était noté Header 1 par exemple, à la place de advanced.h1
            Oui, ça fait la même chose, mais le nom a changé
            Même pour les classes perso, on retrouve ce préfixe advanced qui ne sert à rien puisque non repris dans le code.
            Sans doute un bug qui sera corrigé
            Avec Ghazal et Manu93fr nous guiderons les Grands Débutants au https://www.joomladay.fr/ le 19 mai à Paris
            ---
            UP, un plugin "couteau suisse" à découvrir sur https//up.lomart.fr
            bgMax
            , AdminOrder, MetaData, Zoom, ArtPlug, Custom, Memo, Filter, ...
            plein de nouveaux modules et plugins sur http://lomart.fr/extensions

            Commentaire


            • #7
              Re : Problème avec JCE Editor depuis la dernière mise à jour

              D'accord, merci pour les réponses.
              Je vais donc attendre une mise à jour.

              Commentaire


              • #8
                Re : Problème avec JCE Editor depuis la dernière mise à jour

                Je n'ai pour l'instant regardé que sur une version Pro de JCE 2.6, et je retrouve bien les termes du CSS du template.
                Il faut que j'essaie la version standard sur un autre site...
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                Commentaire


                • #9
                  Re : Problème avec JCE Editor depuis la dernière mise à jour

                  Envoyé par lomart Voir le message
                  Salut PieceOfCake,
                  Désole de te contredire, mais cette notation de sélecteur ne correspond à rien. J'ai fait une simulation pour vérifier
                  En fait @lomart, je me basai sur la version 2.5 et l'on y voit d'ailleurs plutôt h1.advanced que advanced.h1

                  Je n'ai toujours pas touché à la 2.6, j'attends que le 'nuage' se redépose
                  Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

                  Commentaire


                  • #10
                    Re : Problème avec JCE Editor depuis la dernière mise à jour

                    J'ai rapidement testé la 2.6.0 standard sur un site, et je n'ai pas vu dans la liste de advanced.quelque chose, mais les CSS des templates utilisés.
                    Bizarre cette histoire !
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                    Commentaire


                    • #11
                      Re : Problème avec JCE Editor depuis la dernière mise à jour

                      Envoyé par RobertG Voir le message
                      J'ai rapidement testé la 2.6.0 standard sur un site, et je n'ai pas vu dans la liste de advanced.quelque chose, mais les CSS des templates utilisés.
                      Bizarre cette histoire !
                      Je pense qu'il s'agit d'une déclinaison de ce qui existe déjà en 2.5 (d'où ma réponse précédente). J'ai un fichier custom.css dans lequel j'ai défini des classes supplémentaires (news et notes pour faire simple) qui se déclinent sur les titres et sous-titres (h1, h2, h3 etc...) selon la partie du site dans lequel j'écris un article.

                      appliquer h2.news sur du texte me donne bien (en 2.5) un rendu différent de h2.notes (et est bien celui attendu) sans avoir à appliquer d'abord header2 puis la classe .news ou .notes

                      Pour les voir dans la liste des styles il faut bien entendu déclarer le fichier custom.css au niveau du paramètrage de JCE
                      Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

                      Commentaire


                      • #12
                        Re : Problème avec JCE Editor depuis la dernière mise à jour

                        Envoyé par RobertG Voir le message
                        J'ai rapidement testé la 2.6.0 standard sur un site, et je n'ai pas vu dans la liste de advanced.quelque chose, mais les CSS des templates utilisés. [...]
                        Idem. Par exemple mettre un paragraphe en <H3> se fait en choisissant 'Titre 3 - title 3'. Nulle trace de advanced.h3.

                        => Le souci semble spécifique au site ou bien à la configuration de JCE, non à JCE lui-même.
                        Créateur de sites internet — Agence web indépendante http://www.e-33.fr | http://www.quali-site.fr (région de Bordeaux)

                        Commentaire


                        • #13
                          Re : Problème avec JCE Editor depuis la dernière mise à jour

                          bonjour à tous,
                          J'ai craqué pour JCE pro 2.6. J'ai rencontré le même problème sur les boutons (pire encore sur la partie tableau)
                          j'ai téléchargé le pack de langue français de JCE ce qui a résolu le pb.
                          Pour moi il s'agit donc d'un bug de localisation.
                          Cordialement.

                          Commentaire


                          • #14
                            Re : Problème avec JCE Editor depuis la dernière mise à jour

                            Bonjour,
                            Merci pour la réponse mais... comment installe t'on une lmanbgue sur la version 2.6 ?
                            Dans la configuration de JCE je vois que certains ont une rubrique add-ons qui permets entre autre l'installation de langue, mais chez moi cette rubrique est absente.


                            Merci.

                            Commentaire


                            • #15
                              Re : Problème avec JCE Editor depuis la dernière mise à jour

                              Pour résoudre mon problème, j'ai cherché : JCE language package avec Google.
                              sur la page Download Languages de JCE, j'ai télécahrgé le ZIP de la langue Française et j'ai installé ce Zip avec l'installateur standard de Joomla sans me poser plus de question, et ça a suffit
                              En espérant avoir été clair.
                              Cordialement,
                              William

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X