Fichiers téléchargés corrompus.

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Fichiers téléchargés corrompus.

    Bonjour à tous,

    Je viens vers vous car j'ai un souci depuis plusieurs jours qui me fait grisonner les cheveux.

    J'ai migré notre site Internet Joomla qui était auparavant sur un VPS OVH sur un tout nouveau serveur. Au passage j'ai également changé de serveur web, passant de NGINX à Apache2 car je le maîtrise mieux. (Enfin on voit le résultat ).

    J'utilise le composant RSFiles pour mettre à disposition des visiteurs un espace de téléchargement de fichiers.

    Tout fonctionnait très bien avant mais maintenant les fichiers téléchargés se retrouvent corrompus. Impossible de les ouvrir avec Excel par exemple ou d'afficher une image JPEG (genre un logo).

    Message d'Excel : Impossible d'ouvrir le fichier "XXXXX.xlsx" car son format ou son extension n'est pas valide. Vérifiez que ce fichier n'est pas endommagé...

    Alors que si je vais le chercher directement en SSH par exemple, le fichier est tout à fait correct. Quelque soit la méthode les deux fichiers font exactement la même taille.

    Mon site est en HTTPS (Let's Encrypt), j'ai pensé à la compression deflate/gzip et pourtant même en désactivant tout ça, rien à faire.

    Voici mes infos :
    • Apache/2.4.25
    • PHP Version 7.0.33-0+deb9u7
    • 5.5.5-10.1.44-MariaDB-0+deb9u1
    • Joomla! 3.5.1 Stable [ Unicorn ] 05-April-2016 22:45 GMT
    Mis à part ça mon site fonctionne très bien.

    Si une âme charitable aurait une idée lumineuse pour me venir en aide, ce serait vraiment génial.

    Merci infiniment.

  • #2
    Bonjour,

    Je vais ajouté quelques résultats infructueux de mes opérations. J'ai essayé tellement de choses que je ne sais plus trop où j'en suis.

    Tout d'abords si je compare les deux fichiers, celui téléchargé directement depuis le site à perdu des informations dans l'onglet "détails" du panneau propriétés de Windows. Super étrange !
    L'auteur, le dernier enregistrement par, nom du programme, entreprise, etc. ni sont plus.

    J'ai essayé de désactiver "HTTPS" en passant par "HTTP". Je suis repassé sur NGINX, je suis repassé sur PHP5.6.

    Je ne comprends définitivement pas ce qu'il se passe !

    Commentaire


    • #3
      Bonjour.

      N'as-tu pas une sauvegarde de ces fichiers ? Il faudra peut-être remplacer les originaux par une copie saine.
      J'ai eu il y a pas mal de temps également des fichiers qui ont été corrompu, vas savoir par quoi ? La seule manière de retrouver des fichiers fonctionnels était de replacer une copie de chacun d'eux via FTP. Je n'ai jamais pu m'expliquer ce qui s'était passé.
      Cordialement.
      __
      Eddy !!!
      Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

      Commentaire


      • #4
        Bonjour

        Merci pour ta réponse. Si si j'ai tout. Mais je les remets, ou même un tout nouveau créé à l'instant, j'ai le même problème. Je ne comprends rien.
        Ce qui est vraiment bizarre c'est ça :

        Cliquez sur l'image pour l'afficher en taille normale

Nom : Annotation 2020-05-15 135913.jpg 
Affichages : 16 
Taille : 62,9 Ko 
ID : 2017465

        Pourquoi est-ce que je perds les infos ?! Mystère.

        Je viens de refaire l'essai. J'ouvre mon fichier Excel sur mon bureau sans souci. Je l'envoie en FTP sur le serveur. Depuis mon site je le télécharge et je ne peux pas.
        Alors je le retélécharge en FTP sur mon bureau depuis le serveur, et je l'ouvre !!!

        J'ai essayé avec mon téléphone, ma collègue qui est 500kms de moi, pareil. Je ne comprends pas pourquoi je perds "Nom du programme".

        En tout cas merci pour ton aide.

        Commentaire


        • #5
          Bonjour à tous,

          Je reviens vers vous car je me repenche sur le souci. J'avais fait une petite pause.

          Aujourd'hui je viens de refaire un test avec un fichier texte tout bête. J'obtiens des résultats que je n'ai jamais vus auparavant.

          Voici le fichier que j'envoie / upload sur mon site :
          Cliquez sur l'image pour l'afficher en taille normale

Nom : Envoi.jpg 
Affichages : 10 
Taille : 8,2 Ko 
ID : 2017863

          Et voici ce que je télécharge avec mon navigateur :
          Cliquez sur l'image pour l'afficher en taille normale

Nom : Dl.jpg 
Affichages : 10 
Taille : 8,0 Ko 
ID : 2017864

          Ça m'a ajouté une ligne au début et retiré la dernière lettre de "Pierre"...

          Je précise quand le consultant sur mon serveur avec nano, vi ou autre, ce fichier est tout à fait correct.

          Je suis complètement perdu, je n'ai jamais rencontré ce genre de problème.

          Toute aide sera la bienvenue.

          Merci.

          Commentaire


          • #6
            Oh mon dieu !!! J'ai trouvé. Ça fonctionne, c'est un Bug de mon CMS !

            Grâce à ce post : https://forum.joomla.org/viewtopic.php?t=229110

            Ceci dit comme j'avais la même configuration sur les deux serveurs, l'ancien et le nouveau, je suis tout de même vachement surpris !!!

            Merci à tous pour votre aide.

            Commentaire

            Annonce

            Réduire
            1 sur 2 < >

            C'est [Réglé] et on n'en parle plus ?

            A quoi ça sert ?
            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
            Comment ajouter la mention [Réglé] à votre discussion ?
            1 - Aller sur votre discussion et éditer votre premier message :


            2 - Cliquer sur la liste déroulante Préfixe.

            3 - Choisir le préfixe [Réglé].


            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

            2 sur 2 < >

            Assistance au forum - Outil de publication d'infos de votre site

            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

            UTILISER À VOS PROPRES RISQUES :
            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

            Problèmes connus :
            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

            Installation :

            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

            Archive zip : https://github.com/AFUJ/FPA/zipball/master

            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
            et remplacer www. votresite .com par votre nom de domaine


            Exemples:
            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/
            Pour executer le script: http://www..com/fpa-fr.php

            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
            Télécharger le script fpa-fr.php dans: /public_html/cms/
            Pour executer le script: http://www..com/cms/fpa-fr.php

            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
            Voir plus
            Voir moins

            Partenaire de l'association

            Réduire

            Hébergeur Web PlanetHoster
            Travaille ...
            X