JYAML : Mise à jour plugin et library

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] JYAML : Mise à jour plugin et library

    Bonjour à tous,
    Heureux de vous retrouver, cela faisait un bout de temps que je ne m'étais pas connecter sur le forum

    Il y a une petite quinzaine de jours j'ai fait un important travail de mise à jour de mon site associatif : https://ancc.asso.fr/. Nous utilisons le template JYAML que certain(e)s connaissent peut-être ? Je me suis rendu-compte que la mise à jour de ce template s'effectuait à partir de l'administration du template lui-même et non pas du système globale de Joomla.

    Je procède donc à la mise à jour via le bouton dédié car la dernière version datait d'octobre 2016 - La nouvelle version (remonte tout de même à mai 2017) s'installe ... Mais lorsque je retourne sur le site, surprise le message "Error" s'affiche sur une page blanche ???

    J'accède toujours à l'administration et je constate que ni le plugin "JYAML Framework - System Plugin" ni la librairie "JYAML Framework Library" ne se sont mis à jour !? Après pas mal de recherches, de récupérations, et d'investigations en tout genre je ne parviens pas à régler le problème - Pourtant il semble bien que l'installation du package proposé sur le site du concepteur "https://www.jyaml.de/en/downloads" installe l'ensemble ?

    Code:
    En résumé :
    - Le template version 4.5.16 Stable
    - Le plugin version 4.5.14 Stable
    - La bibliothèque version 4.5.14 Stable
    Mais impossible d'upgrader le plugin et la bibliothèque ?
    Dernière édition par sebiseb à 10/06/2018, 12h56
    Joomla 3.8.8. - Template JYAML - Kunena 5.1.0

  • #2
    Bonjour,
    Si comme ta signature l'indique ton site est toujours en version 2.5 de Joomla il n'est pas évident que la mise à jour du framework s'applique à ton site. Elle est en effet décrite comme version pour Joomla 3.7 et plus. Pas sur donc qu'elle soit utile/utilisable avec J 2.5.
    La meilleure solution dans ton cas serait de restorer la sauvegarde que tu n'as pas manqué (je l'espère) de faire avant cette mise à jour.

    Commentaire


    • #3
      Bonjour,
      non le site est apparemment en version 3 ... mais laquelle ?
      Je constate un blocage (403) sur les fichiers ou sous repertoires de administrator ... tu as surement une protection active sur ton serveur
      “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

      Commentaire


      • #4
        Non, non je suis bien sous Joomla 3.8.8.

        Quelle genre de protection ? Je suis chez Celeonet, et je ne peux pas modifier toutes les variables genre "url-rewrite". Je peux cependant modifier le "chmod" des fichiers.

        Mais je pense que la piste la plus sérieuse reste celle d'upgrader "plugin" et "librairies" dans la même version que le template ??? Hors, c'est vraiment ça qui est bizarre - car sur le site du concepteur il y a un package global et si l'installe se passe bien, les deux extensions ne se mettent pas à jour ???
        Joomla 3.8.8. - Template JYAML - Kunena 5.1.0

        Commentaire


        • #5
          un exemple du blocage 403
          https://ancc.asso.fr/administrator/manifests

          sinon, quelle version de php ?
          système -> info système

          Tu peux aussi faire une vérif de la base de donnée pour voir
          extensions -> Gerer -> base de donnée

          En fait, dans la console du navigateur, tu as une erreur 500 ... bizarre que ça affiche juste "error" pour dire que c'est une erreur 500 .... mais bon
          Donc direction tes logs serveur pour déterminer qui est responsable de ta page "error"
          Dernière édition par manu93fr à 10/06/2018, 17h45
          “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

          Commentaire


          • #6
            PHP : 5.6.18

            Bdd : La structure des tables de la base de données est à jour.
            • Version du schéma de la base de données (dans #__schemas): 3.8.8-2018-05-18
            • Version de la mise à jour (dans #__extensions): 3.8.8.
            • Pilote de la base de données:
            • 151 modifications de base de données vérifiés avec succès.
            • 188 valeurs de modifications de la base de données ne changent pas la structure des tables et ont été ignorées.

            PS : On change comment son pied de page dans ce forum ?
            Joomla 3.8.8. - Template JYAML - Kunena 5.1.0

            Commentaire


            • #7
              PS : On change comment son pied de page dans ce forum ?
              tu cherches "signature" dans ton profil

              PHP : 5.6.18

              Bdd : La structure des tables de la base de données est à jour.
              • Version du schéma de la base de données (dans #__schemas): 3.8.8-2018-05-18
              • Version de la mise à jour (dans #__extensions): 3.8.8.
              • Pilote de la base de données:
              • 151 modifications de base de données vérifiés avec succès.
              • 188 valeurs de modifications de la base de données ne changent pas la structure des tables et ont été ignorées.
              on est bon pour la version de php et la base de donnée

              Change de template par defaut juste pour tester que la page blanche "error" disparaisse
              Mets Protostar 2s et teste
              “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

              Commentaire


              • #8
                Oui, oui j'avais essayé ça aussi et ça passe ! C'est vraiment le template qui "bug". Par ailleurs, les erreurs en mode "débogage" sont les suivantes ; https://ancc.asso.fr/administrator/

                PS : J'ai fini par trouvé pour la signature en me rendant simplement dans la FAQ
                Dernière édition par sebiseb à 10/06/2018, 18h08 Raison: signature
                Joomla 3.8.8. - Template JYAML - Kunena 5.1.0

                Commentaire


                • #9
                  Envoyé par sebiseb Voir le message
                  Oui, oui j'avais essayé ça aussi et ça passe ! C'est vraiment le template qui "bug".
                  Je dirai oui .. et non
                  Oui, c'est le template qui fait cette erreur 500
                  non car je viens d'installer le template (package) sur un site de test et pas d'erreur a l'horizon

                  Donc le meilleur moyen d'avoir une piste, c'est d'aller dans tes fichiers de log serveur pour voir ce qu'il se passe
                  ou tu peux aussi tenter de réinstaller le template en téléchargeant le package complet .. puis :
                  Extensions -> Gerer -> Installer
                  Dernière édition par manu93fr à 10/06/2018, 19h26
                  “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

                  Commentaire


                  • #10
                    Si tu veux en profiter pour faire une mise à jour vers PHP 7, tu peux tenter ta mise à jour avec le templare par défaut de Joomla!
                    Tu passes en PHP 7 sur ton mutualisé ( Généralement, tu peux choisir le dossier racine pour appliquer un changement de version de PHP. )
                    Ensuite, une fois PHP 7 en place, tu regardes à faire les mises à jour de Joomla et de ce qui est proposé en mise à jour.
                    Seulement alors, tu réinstalles ton template que tu souhaites, pour le tester.

                    Pourquoi faire ainsi ? J'ai lu que lors d'un changement de version de PHP, il faut réinstaller le template, de préférence.
                    Cela peut t'éviter de travailler en double, pour ne pas recommencer cette tâche par la suite, et, ça pourrait permettre de tourner sur la dernière version de PHP 7.

                    Pour ton problème de template, voir les logs, ça peut aider oui.

                    Commentaire


                    • #11
                      Bonjour,


                      Tu peux restaurer une sauvegarde ?

                      Par ftp, tu peux essayer de renommer la librairie (jyaml dans libraries), le plugin (jyaml dans plugin/systeme) et le template jyaml (après avoir assigné protostar par défaut dans l'administration de joomla). Ainsi tu effectuera comme une nouvelle installation du template sans toutefois toucher à la base et les versions seront à jour (...enfin théoriquement de la dernière version ).

                      Comme dans l'image suivante :



                      Ensuite tu pourra supprimer les repertoires que tu aura renommé en vérifiant qu'il ne manque rien à ceux qui sont installés (image ou css).

                      Parfois, les concepteurs font évoluer leur code en effaçant des éléments obsolètes mais oublient de le faire dans les versions ultérieures donc
                      si on "saute" de version, des fichiers seront restés dans l'une des extensions, librairies et cela perturbe l'installation, l'affichage.

                      D'autres frameworks ont eu ce problème notamment sur des paramètres de surcharge... d'où la nécessité de tester et suivre régulièrement les mises à jour.

                      Je te déconseille de passer à php 5.6 à php 7 avant d'essayer la mise à jour de template pour ne pas mélanger ou bruler les étapes (jyaml est compatible php7 depuis la 4.5.12). Effectivement on doit passer sur php 7 tout comme le https et l'adaptation à la réglementation européenne ( DGRP ) mais on résout un problème à la fois.

                      Pour info, j'ai connu jyaml (que j'ai évoqué au joomladay en 2009 et en 2012) mais il est pratiquement devenu obsolète depuis depuis 2013, date de la dernière release de yaml https://github.com/yamlcss/yaml/releases , Reinhard Hiebl tente de maintenir des correctifs (dernière annonce du 7 octobre 2017) pour la version joomla du framework mais cela devient compliqué.



                      Yann
                      Dernière édition par daneel à 11/06/2018, 03h39
                      Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

                      Commentaire


                      • #12
                        Bonjour,
                        Si tu veux en profiter pour faire une mise à jour vers PHP 7
                        php 5.6 est assez stable pour que le site fonctionne correctement
                        S'il bascule le site en php7 et que des extensions ne passent pas avec cette version, tu auras rajouté un problème sur un problème
                        Pour info, mon teste sur l'installation du template s'est faite sur un php 5.5 ... et aucun souci

                        Pourquoi faire ainsi ? J'ai lu que lors d'un changement de version de PHP, il faut réinstaller le template, de préférence.
                        Ah bon ! Et pourquoi ? Le code du template restera le même (sauf mise a jour du template)

                        La soluce de Daneel est bonne aussi .. tu isoles ainsi les librairies, code de JYAML
                        “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr

                        Commentaire


                        • #13
                          Bonjour, et Merci à tous pour vos conseils et vos réponses. Désolé, n'étant pas mon activité principale, je n'ai pas eu beaucoup de temps pour revenir vous dire l'avancé de la remise à jour.

                          Nous sommes en mutualisé chez Celeonet. Nous avons fait faire une estimation pour passer en offre cloud, mais c'est assez onéreux pour notre budget - je vais revoir tout de même si nous ne pouvons pas faire un effort afin de mieux maîtriser la structure d'hébergement (version PHP / MySQL).

                          J'ai finalement réussi à remettre template, plugin et bibliothèque dans la dernière version 4.5.16 Stable. Malheureusement l'erreur subsiste.


                          Cependant, voici le message un peu étonnant que j'ai dans l'upgrade du template.

                          Joomla 3.8.8. - Template JYAML - Kunena 5.1.0

                          Commentaire


                          • #14
                            Hello,
                            Juste pour info c'était dû à un conflit avec les extensions suivantes :
                            • Le plugin système - DS Constant
                            • Le composant Kunena
                            Je suis personnlement surpris par ce template qui me paraît bien particulier, je ne vais en tout cas pas l'adopter pour mon usage
                            Communauté Suisse-Romande : www.joomlaromand.ch
                            Kits Joomla!, extensions FR et tutoriels : www.joomlatutos.com
                            Support de l'éditeur JCE FR : Fichiers à télécharger, aide & Forum www.sarki.ch/jce

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins
                            Travaille ...
                            X