Problème de template pour utilisateurs connectés

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Problème de template pour utilisateurs connectés

    Bonjour
    Je ne sais pas depuis combien de temps existe le problème sur mon site, mais je viens de m'apercevoir que si tout fonctionne bien pour un visiteur extérieur, le problème intervient quand un utilisateur se connecte. A partir de la connexion d'un utilisateur, les menus ne prennent plus en compte le style de template qui leur est assigné ! (en fait, je n'arrive pas à savoir quel template est alors pris en compte...) Cela pose le problème de la publication des modules dans de nombreuses pages puisque l’emplacement défini pour les modules ne doit plus correspondre à rien. Comme d'habitude ça doit être simple mais j'ai tourné dans tous les sens et ne trouve pas!
    Toute aide sera la bienvenue
    En espérant avoir posté au bon endroit...
    D'avance merci

  • #2
    Hello !

    Curieux ces 2 balises en rouge dans ton site ?

    <header0undefined> <div class="inner clearfix"> <divbannerlogo> <div class="inner clearfix"> <img src="/templates/shakjoomla3/images/personal2.png" alt="" /> </div> </div> <div class="clr"></div> </div> </header>
    I'am happy for you !
    Dernière réalisation : http://www.pierrickservais.com/

    Commentaire


    • #3
      Merci Papounet.
      Je vois pas bien d'où vient ton analyse, probablement d'un explorateur web. Mais comme tu as du analyser en mode non connecté, je ne vois pas comment ça peut me faire avancer puisque tout fonctionne bien dans ce mode. Je n'ai peut-être pas compris la réponse : si tu peux m'en dire plus... Je continue à chercher de mon côté plus tard dans la journée.
      Merci

      Commentaire


      • #4
        je ne vois pas comment ça peut me faire avancer puisque tout fonctionne bien dans ce mode.
        Oui, et en plus cela ne concerne pas le menu.
        Désolé, mais des balises non fermées ou non ouvertes sont toujours sources de soucis.
        I'am happy for you !
        Dernière réalisation : http://www.pierrickservais.com/

        Commentaire


        • #5
          Merci de la réponse.
          On arrive à un niveau qui me dépasse : comment on ferme ces balises?

          Commentaire


          • #6
            je ne trouve pas ton template.
            As tu un lien ?
            I'am happy for you !
            Dernière réalisation : http://www.pierrickservais.com/

            Commentaire


            • #7
              J'utilise plusieurs templates (créés avec Template Creator CK) donc je ne sais pas lequel tu souhaites examiner.... pour un lien je vais regarder comment tu peux y accéder.
              Le site fonctionne puisque j'ai mis provisoirement tous les éléments en lecture publique ( il n'y a pas grand chose de confidentiel). Je pense après contact avec le concepteur de Template Creator CK qu'il s'agit plus d'un problème de configuration générale voici sa réponse : "ton souci semble plutôt être lié à l'assignation et la config dans ton site, je ne pense pas que template creator ni maximenu ne soient en cause ici".
              Je continue à explorer cette voie.
              Merci de ton aide



              Commentaire


              • #8
                Bon!
                Comme (trop) souvent, j'ai réglé mon problème en le contournant : c'est à dire en retravaillant mon template de base pour qu'il devienne unique : toutes les pages l'utilisent maintenant. J'ai pu remettre en place la partie réservée aux connectés.
                Mais comme j'aime bien comprendre, je laisse ce post ouvert encore un certain temps.
                Merci à Papounet de sa collaboration!

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X