Joomla 3.8, OVH, Requetes et blacklistage

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Joomla 3.8, OVH, Requetes et blacklistage

    Bonjour à tous,

    Derrière ce titre spéciale, se cache une situation spéciale... J’espère que que vous pourrez m'aider à en sortir.

    Situation
    Site J2.5.26
    Sous répertoire avec un J3.8.5 en développement

    Sur le J3.8.5
    JCE
    Sliders
    En surfant sur le net j'ai truové des messages sur "Template Creator CK" qui m'ont séduit, je l'ai donc installé pour développer mon propre template.
    Installation ce matin de BreezingForms

    Le problème !
    Mon IP est blacklistée par OVH car celle-ci fait trop de requête ! Aujourd'hui il y en a eu 1800 en 1 heure !

    Chronologie
    Mardi 6 : tentative de migration avortée avec décision de repartir de 0. Installation de "template creator CK" et travail sur ce composant... Premier blocage (on ne savait pas encore qu'il s'agissait de blacklistage de la part d'OVH). Je retrouve l'accès environ en 1 heure. Cela se produit régulièrement. Appel à OVH qui me dit pas de problème sans me parler de blacklistage.

    Mercredi 7 : problème identique mais toute la journée. Je mets en doute "template creator CK" mais je tombe sur un poste de forum d'une personne qui a un problème identique et qui l'a résolu en supprimant le .htaccess du site dans le sous répertoire (ici le J3.8.5). Je supprime le .htaccess

    Jeudi 8 : Un peu de travail sur le site sans rencontrer de problème.

    Dimanche 11 : Toute la journée sur le site sans aucun problème

    Lundi 12 : Installation de BreezingForms et paramètrages avec beaucoup de "valider", "sauvegarder" etc... PAF nouveau blacklistage de OVH !!!

    Questions
    - Est-ce normal que lorsqu'on travail sur des composants et qu'on sauvegarde cela génère autant de requête ?
    - Avez-vous déjà rencontré ce problème ?
    - Les composants ne semblent pas à l'origine du problème, voyez-vous une piste ?
    - Est-ce la cohabitation d'un J2 et J3 sur le même hébergement qui peut poser problème ?

    Je suis vraiment coincé et dubitatif sur ce problème. Je viens de passer 2 heures avec OVH et ils me répètent en boucle : trop de requête !

    Par avance merci pour votre précieuse aide.


  • #2
    Bonjour

    Quelle chronologie... (respect pour cette mise en contexte) toutefois qui fait autant de requêtes ?

    Quelles sont les URLs qui sont accédées car cette info est cruciale. Si tu as 1000 accès sur p.ex. wp-admin ben c'est donc la faute à un apprenti pirate.
    Christophe (cavo789)
    Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
    Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
    Mes logiciels OpenSource : https://www.avonture.be

    Commentaire


    • #3
      Bonjour Cavo789,

      Les requetes ne touchent pas toujours la même URL et surtout... viennent de mon IP quand je travail sur le site !!!

      Commentaire


      • #4
        Apparemment tu n'es pas seul https://forum.joomla.fr/node/1975399
        Ça semble concerner OVH (une fois de plus ?)
        Connaissez-vous la loi de Murphy ? Appliquée à Joomla elle pourrait s'énoncer ainsi :
        C'est toujours lorsqu'on n'a pas pris le temps de faire une sauvegarde que les problèmes surgissent et s'enchainent.
        Moralité : faites des sauvegardes, elles vous paraitront peut-être superflues mais elles ne sont jamais inutiles.

        Commentaire


        • #5
          Bonsoir,

          Sans me faire plaisir, ne pas être seul à rencontrer ce problème me rassure car à en croire OVH je suis seul et unique responsable...

          Commentaire


          • #6
            Fichtre ! Ils le font exprès ou ...

            Plus sérieusement : c'est quand même dingue que leur gestion soit celle-là càd que cela semble être "de leur faute" (=ce sont leurs serveurs qui sont soumis à un feu de requêtes) mais leur système informatique rejette la faute sur le client qui, forcément, sans beaucoup plus d'informations, ne sait pas trop où regarder et quoi faire.

            Ils devraient avoir une alerte "globale" afin de savoir que c'est l'infrastructure qui est soumise à un feu et pas un site précis.
            Christophe (cavo789)
            Développeur d'aeSecure; protection, optimisation et nettoyage (après hack) de sites web Apache https://www.aesecure.com/fr
            Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
            Mes logiciels OpenSource : https://www.avonture.be

            Commentaire


            • #7
              Envoyé par lesoutier Voir le message
              Apparemment tu n'es pas seul https://forum.joomla.fr/node/1975399
              Ça semble concerner OVH (une fois de plus ?)
              Hello,

              C'est moi qui ai créé le post cité ci-dessus ! Autant continuer ici et essayer de trouver une solution ensemble
              En ce qui me concerne, c'est lorsque j'utilise K2 que le problème survient. Je peux être connecté sur mon Admin toute la journée sans soucis à la seule condition que je ne vais pas dans le composant K2.

              Si j'ai le malheur d'y aller, mon IP est bloqué pendant 1h environ. J'ai fait le test sur un site vierge en installant K2 et le même soucis c'est produit. je doute que ce soit un problème lié à K2 du coup d'autant que vous me dites que le problème se pose aussi chez vous avec d'autres composants.

              Si quelqu'un à une solution un jour mais personnellement, je compte de plus en plus quitter OVH...
              Dernière édition par Sentenzakh à 13/02/2018, 11h16

              Commentaire


              • #8
                A tout hasard, avez-vous vérifié que votre site n'est pas infecté par un malware (qui serait lié au fonctionnement de K2) ?
                Tous les services pour les sites Joomla! : sécurité, nettoyage de sites piratés, hébergement, SEO, applications Fabrik, migration, compatibilité mobiles, accessibilité, ...
                Administrateur certifié Joomla! 3
                https://www.betterweb.fr/services

                Commentaire


                • #9
                  Envoyé par jfque Voir le message
                  A tout hasard, avez-vous vérifié que votre site n'est pas infecté par un malware (qui serait lié au fonctionnement de K2) ?
                  Sauf erreur, j'ai procédé à toutes les vérifications et aucune infection à détecter jusqu'à présent...
                  Peut-être existe-t-il un moyen plus pousser de faire ce genre de vérification ?

                  Commentaire


                  • #10
                    Vous pouvez faire un scan des fichiers avec un outil comme Admin Tools Pro et vérifier une éventuelle mise en liste noire sur le site https://www.virustotal.com/fr/
                    Tous les services pour les sites Joomla! : sécurité, nettoyage de sites piratés, hébergement, SEO, applications Fabrik, migration, compatibilité mobiles, accessibilité, ...
                    Administrateur certifié Joomla! 3
                    https://www.betterweb.fr/services

                    Commentaire


                    • #11
                      Envoyé par jfque Voir le message
                      Vous pouvez faire un scan des fichiers avec un outil comme Admin Tools Pro et vérifier une éventuelle mise en liste noire sur le site https://www.virustotal.com/fr/
                      Merci pour le lien mais tout est normal apparemment à ce niveau...

                      Commentaire


                      • #12
                        Bonjour à tous,

                        De mon coté je n'ai pas fait de scan mais le site est "neuf". Cela serait étonnant qu'il y ait un maleware.

                        Le problème arrive de manière qui semble aléatoire. J'ai eu le problème avec "template créator CK", un autre jour j'y ai passé du temps sans rencontrer de problème ! Puis j'ai eu la même histoire avec "BreezingForms" mais pas de manière immédiate.

                        Pour moi le problème vient de OVH car quand je regarde les logs il y a bien des requêtes mais elles concernent toutes les composants sur lesquelles on travaille. Joomla fait son boulot et parfois, au hasard des modifications envoi trop d'infos et OVH bloque. Cette hypothèse tient la route ou pas du tout selon vous ?

                        Commentaire


                        • #13
                          Bonjour,
                          Pour moi le problème vient de OVH car quand je regarde les logs il y a bien des requêtes mais elles concernent toutes les composants sur lesquelles on travaille. Joomla fait son boulot et parfois, au hasard des modifications envoi trop d'infos et OVH bloque. Cette hypothèse tient la route ou pas du tout selon vous ?
                          L'hébergeur n'est pas sensé bloqué le site a chaque fois qu'il voit du traffic ou des modifs ... c'est pas vraiment son role ... mais avec Ovh, il faut prendre des pincettes

                          Sinon, une url a nous donner ? des fois que ....
                          “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr
                          Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérer à l'AFUJ https://www.joomla.fr/association/adherer

                          Commentaire


                          • #14
                            Bonjour,

                            Je ne peux malheureusement pas diffuser les URL pour le moment pour une question de confidentialité demandé par le client.

                            Je test sur un autre site avec la même configuration et je rencontre le même problème ! Et OVH la même réponse "votre IP fait trop de requête pour un mutualisé"...

                            Mon client ne souhaite pas changer d’hébergeur pour le moment je vais devoir passer par un serveur local mais le problème reste entier...

                            Avez-vous avancé ou eu du nouveau de votre coté ?



                            Commentaire


                            • #15
                              yammi vu le nombre de clients qui sont sur Ovh, ça se saurait s'il bloquait systématiquement les sites dès que l'on travaille dessus .. non ?
                              Donc je reste persuadé que le soucis vous concerne vous ... pourquoi, je ne sais pas ... mais il y a forcement un truc qui cloche sur l'hébergement en question .

                              Passer l'url sur sucuri.com par exemple, histoire de voir si le site n'est pas infecté
                              “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance https://kb.joomla.fr
                              Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérer à l'AFUJ https://www.joomla.fr/association/adherer

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X