Erreur INET_E_REDIRECT_FAILED sur certains navigateurs

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Erreur INET_E_REDIRECT_FAILED sur certains navigateurs

    Bonjour,

    J'ai mis en place un site sous Joomla pour un client.
    Le temps du développement de son nouveau site, j'ai installé la plateforme Joomla dans le dossier www/site2/ sur l'hébergement OVH.
    Une fois le nouveau site terminé et validé par mon client, j'ai ajouté un .htaccess sur la racine www pour rediriger directement sur l'index du site2. Tout marchait bien, jusqu'à ce que mon client me signale que sur Internet Explorer, il avait un message "INET_E_REDIRECT_FAILED" en essayant d'afficher son site.
    J'ai vérifié et en effet, page inaccessible depuis IE ou depuis Edge...mais tout passait bien sur Chrome et sur Firefox.
    Pensant qu'il s'agissait de la redirection du .htaccess, j'ai supprimé l'ancien site, et j'ai déplacé le site2 à la racine (en utilisant Akeeba) et tout s'est bien passé : le site fonctionne très bien.
    Pourtant, j'ai toujours la même erreur sur IE et sur Edge !! Alors qu'il n'y a plus de redirection ni même de fichier .htaccess.
    J'ai bien vidé le cache et tout ce qu'il faut, mais le problème persiste.

    Avez-vous une idée ?
    Merci pour votre aide.

  • #2
    Et si tu faisais pointer directement le nom de domaine sur ce dossier "site2", ou encore si tu renommais tes dossiers et corrigeais les chemins des dossiers logs et tmp dans le fichier de configuration ?
    Pourquoi faire une redirection avec un .htaccess ? Sauf erreur, si tu utilises une redirection, il faut ensyite forcer l'adresse dans $live_site
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Merci pour cette réponse. Mais il n'y a plus de redirections à présent : mon nouveau site a bien remplacé l'ancien, directement à la racine www/
      Il n'y a plus de redirections, plus de fichier .htaccess et plus d'ancien site...tout me semble normal, et pourtant, ce message s'affiche...

      Commentaire


      • #4
        Un effet de cache ? par défaut OVH en active un.
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #5
          Ah...je ne savais pas qu'OVH activait un cache ? Il faut que je les contacte pour le vider ? ou bien je peux le faire depuis la console d'admin ?

          Commentaire


          • #6
            Je ne m'en suis jamais préoccupé, dans la mesure où je laisse toujours en mode développement dans le .ovhconfig, pour éviter ce cache.
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

            Commentaire


            • #7
              Bonjour,
              J'ai bien mis environment=developement dans le fichier .ovhconfig, mais ça n'a rien changé...

              J'ai noté une petite anomalie que je n'avais jamais vue : le domaine du site a été réservé par mon client il y a déjà 2 ou 3 ans.
              Et dans ce nom de domaine, il y a des accents...est-ce que le problème peut venir de là ?
              Concrètement, j'ai 2 navigateurs sur 4 qui affichent un message disant qu'il y a trop de redirections, alors que moi, je n'ai plus aucune redirection sur mon site.
              Mais peut-être que la redirection se fait toute seule à cause de cette URL qui comporte des accents ?

              Je ne sais vraiment plus quoi faire

              Commentaire


              • #8
                Attention, c'est à écrire en anglais, donc "development".
                Il n'y a à mon avis pas de raison pour que des caractères accentués aient un impact, car le nom est automatiquement converti, sans redirection,
                Si tu ne veux pas mettre l'adresse ici, transmets-la moi par message privé, je regarderai..
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

                Commentaire


                • #9
                  Je n'ai pas de soucis à partager le lien en question : http://www.soazigboissier-psychothérapie.com/
                  Tu peux faire le test : sous Chrome, le site s'affiche normalement...mais la même URL sur un navigateur Microsoft ne fonctionne pas et donne toujours cette erreur...
                  Merci pour ton aide !

                  Commentaire


                  • #10
                    Heuu.....c'est à n'y rien comprendre ! Je n'ai rien touché, et le site s'affiche maintenant sans problèmes dans IE et dans Edge...
                    J'étais pourtant repassé sur environment=production dans mon fichier ovhconfig...
                    Je ne comprends pas ce qui se passe...c'est inquiétant quand même !

                    Commentaire


                    • #11
                      Bonjour,
                      Je reviens ici parce que c'était visiblement une fausse joie...
                      Le site ne passe à nouveau plus sur IE et Edge, toujours avec cette même erreur.
                      J'ai contacté OVH qui me dit sans plus de précisions qu'il s'agit d'un problème de développement du site et que ça n'a rien à voir avec eux.
                      J'ai repassé la ligne du fichier .OVHCONFG à environment=development mais ça ne change rien visiblement...
                      J'ai vraiment besoin d'aide, je tourne en rond

                      Commentaire


                      • #12
                        bonjour,
                        pour moi, il s'agirait plus d un probleme microsoft que joomla....
                        Si c est bien de cette erreur que l'on parles.
                        https://ugetfix.com/ask/how-to-fix-i...on-windows-10/

                        Ce serait des mises a jour microsoft qui brise edge
                        Mon site en cours de construction avec de nouvelles catégories de documents...
                        https://informaticien51.fr

                        Commentaire


                        • #13
                          Merci pour cette réponse lefabdu51.
                          Mais ça n'est pas exactement la même erreur. Le message d'erreur complet que j'ai dans IE est le suivant :

                          Nous ne pouvons pas accéder à cette page

                          •Vérifier que l’adresse web http://www.soazigboissier-psychothérapie.com est correcte
                          •Rechercher ce site sur Bing
                          •Actualiser la page


                          Informations
                          Le nombre de redirections était trop important.
                          Code d’erreur : INET_E_REDIRECT_FAILED

                          Je suis en train de chercher du côté de l'accent...en effet, l'URL de mon client contient un caractère accentué : soazigboissier-psychothérapie.com
                          QUand je suis sous Chrome et que je navigue sur le site, si je copie l'URL et que je la colle dans un fichier texte, je me rends compte qu'en réalité l'adresse est : http://www.xn--soazigboissier-psychothrapie-xrc.com
                          J'ai donc l'impression que ce caractère accentué pourrait générer une réécriture d'URL ou une redirection systématique...qui n'est pas supportée par les navigateurs Microsoft : est-ce possible ?
                          Je fais des recherches là dessus...

                          Commentaire


                          • #14
                            Bonsoir,
                            sur edge, pas de souci pour moi ...
                            ... par contre, le site souffre d'optimisation ...
                            Cliquez sur l'image pour l'afficher en taille normale

Nom : gtmetrix.png 
Affichages : 1 
Taille : 121,6 Ko 
ID : 1982351
                            Le JoomlaDay 2019 aura lieu le 8 et 9 mars à Paris ... On vous attend tous pour rencontrer la communauté, faire plus ample connaissance, assister aux conférences .... et surtout passer un BON moment ensemble
                            “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance
                            https://kb.joomla.fr
                            Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérer à l'AFUJ https://www.joomla.fr/association/adherer

                            Commentaire


                            • #15
                              Bonjour Manu93fr,
                              Merci d'avoir testé. Pour ma part, sur IE comme sur EDGE, j'ai le même message d'erreur (screenshot ci-joint).
                              Le site est basé sur une plateforme Joomla...quelles optimisations je peux faire ?? (sans avoir à péter tout le code bien sur...)



                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X