ERREUR 500 après migration à partir de 2.5.28

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • #46
    Peux-tu me contacter en MP pour me donner un accès à ton serveur (FTP et base) et si possible à tes sauvegardes ? J'essaierai de comprendre ce qui se passe.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #47
      C'est très gentil de me proposer cela, merci beaucoup Robert !
      Je suis en train de replacer une ancienne sauvegarde sur le serveur via le FTP (cela va être long car il y a beaucoup de vidéos et je veux replacer l'intégralité sans rien oublier) et vais ensuite supprimer la base actuelle pour placer la sauvegarde (même date que l'ancienne sauvegarde bien sûr).
      Si cela ne marche pas, je reviens vers toi et si tu as encore le temps de jeter un oeil je suis preneur :-)

      Commentaire


      • #48
        Pour résumer :
        1. la base utilisée était une base hors pack, d'où le non-fonctionnement avec la base du pack qui contenait une version 1.5 des données ;
        2. une erreur de mot de passe s'en est suivi ;
        3. après nouvelle restauration des fichiers et récupération de cette base hors pack et sa réinjection (sauf contenu des tables de statistiques, trop lourdes) dans la base du pack, la connexion a pu s'établir ;
        4. l'accès à l'administration est fonctionnelle mais présente des erreurs de structure de la base de données qui semble ne pas correspondre à la version des fichiers (2.5.19), et l'accès au site provoque une erreur 500 Unknown column 'a.title_alias' en page d'accueil.
        Le problème de fonctionnement du site n'étant pas réglé, mon conseil, déjà donné en MP, est de créer un nouveau site en version 3.8.7 et d'y importer, avec JMigrator ou SP Transfer, les données utiles.
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

        Commentaire


        • #49
          Bonjour !
          Pour celui qui a le même problème que moi, je confirme que le mieux et le plus rapide est bien de tout supprimer et de repartir sur de bonnes bases.
          Donc nouvelle installation du site en Joomla 3 puis installation de tout manuellement car la migration via JMigrator ne fonctionne pas (impossible d'installer le programme : de toute manière les fichiers étaient pollués avec des problèmes d'accents notamment...).
          Nouvelle installation chez un autre hébergeur (car la base hors pack était introuvable... bref... même le service client OVH n'a pas été d'une grande aide... surtout eux d'ailleurs...;-)
          @+ et encore merci !
          Laurent

          Commentaire


          • #50
            Comme je l'ai dit, j'ai pu récupérer les données de la base hors-pack et les injecter dans la base du pack. Donc dire que la base hors-pack était introuvable n'est pas correct.
            Comme je l'ai dit aussi, un autre problème grave subsistait, probablement lié aux tentatives de mise à jour précédentes qui ont dû partiellement modifier la structure de la base et la rendre incompatible avec la version 2.5.19

            Et que JMigrator ne soit pas installable sur un site vierge, c'est la première fois que je le lis. As-tu interrogé à ce sujet son auteur (canadien francophone) ?

            PS : si je parais pinailleur, c'est parce que souvent c'est à cause de situations mal décrites qu'on se fourvoie, alors qu'une description précise permet souvent de cibler instantanément la correction
            Dernière édition par RobertG à 24/05/2018, 17h47
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

            Commentaire


            • #51
              C'est sur l'ancien site que je n'ai pas installé JMigrator, pas sur le nouveau. J'ai vite compris que le plus simple était de repartir sur une page vierge en réinstallant seulement les nombreuses vidéos (il faut juste copier les bonnes tables de la base et le fichier sous FTP pour ceux que cela intéresse).

              Que ce soit la base hors-pack ou la base du pack qui était installée il y avait toujours un problème quelque part. Créer un nouveau site sur un truc pas d'aplomb n'a pas été mon option. Quitte à faire table rase, autant commencer sur un terrain propre, surtout lorsque l'on ne sait pas où est vraiment cachée l'erreur...

              Voilà voilà. Le nouveau site fonctionne et c'est le principale :-)

              Bon courage à vous tous pour vos migrations !

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins
              Travaille ...
              X