Téléchargement langue impossible

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Téléchargement langue impossible

    Salut à tous.

    Sur Joomla 3.1.5 en local sur WAMPSERVER, je voudrais installer des langues supplémentaires sur mon site mais quand je vais dans la gestion des langues et que je cliques sur "Installation de langues", voici ce que ça me retourne :

    Code:
    Il n'y a aucune langue disponible à installer pour le moment. Veuillez cliquer sur le bouton 'Rechercher des langues' pour obtenir une mise à jour depuis le serveur de langues Joomla. Une connexion internet est nécessaire à cet effet.
    Or j'ai une connection internet. Je pense que ça vient de WAMP mais je n'ai pas trouvé d'infos sur un tel problème sur Google.
    Est-ce que ça viendrai pas d'un module apache ou php qui ne serait pas activé?

    Je sais qu'on peut les installer par l'installateur d'extensions mais je voudrais vraiment les installer par la gestion des langues car je suis en train de faire un tuto vidéo.

    Merci d'avance
    Dernière édition par lucvillalba à 18/10/2013, 16h22
    Création de sites web, Référencement, Intégration, Webdesign... Un Webmaster freelance pour vos campagnes de communication sur le web... www.lucvillalba.fr
    Des tutos et astuces sur mon blog www.lestutosdelucho.fr

  • #2
    Re : Téléchargement langue impossible

    Bonjour,

    Voir si l'extension PHP Curl est active.
    Pas de demande de support par MP.
    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

    Commentaire


    • #3
      Re : Téléchargement langue impossible

      Salut Jisse03 et merci pour la réponse.

      J'avais déjà essayé et ça ne fonctionne pas...
      Création de sites web, Référencement, Intégration, Webdesign... Un Webmaster freelance pour vos campagnes de communication sur le web... www.lucvillalba.fr
      Des tutos et astuces sur mon blog www.lestutosdelucho.fr

      Commentaire


      • #4
        Re : Téléchargement langue impossible

        Un petit up...

        Ca ne fonctionne pas, que ce soit sur mon serveur local sous WAMP 2.2E ou sur mon serveur distant (o2switch)
        A noter que cURL est activé sur mon serveur distant. Sur mon serveur local, rien ne change quand je l'active ou le désactive...
        Création de sites web, Référencement, Intégration, Webdesign... Un Webmaster freelance pour vos campagnes de communication sur le web... www.lucvillalba.fr
        Des tutos et astuces sur mon blog www.lestutosdelucho.fr

        Commentaire


        • #5
          Re : Téléchargement langue impossible

          Et que racontent les logs serveur (error.log apache) dans les 2 cas ?
          Pas de demande de support par MP.
          S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

          Commentaire


          • #6
            Re : Téléchargement langue impossible

            Alors dans Wampserver :

            Code:
            [Mon Oct 21 10:45:12 2013] [warn] pid file C:/wamp/bin/apache/apache2.2.22/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
            PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.3.13/ext/php_curl.dll' - L\x92application n\x92a pas pu d\xe9marrer car sa configuration c\xf4te-\xe0-c\xf4te est incorrecte. Pour plus d\x92informations, consultez le journal d\x92\xe9v\xe9nements d\x92applications ou utilisez l\x92outil de ligne de commande sxstrace.exe.\r\n in Unknown on line 0
            [Mon Oct 21 10:45:12 2013] [notice] Apache/2.2.22 (Win64) PHP/5.3.13 configured -- resuming normal operations
            [Mon Oct 21 10:45:12 2013] [notice] Server built: May 13 2012 19:41:17
            [Mon Oct 21 10:45:12 2013] [notice] Parent: Created child process 4452
            PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.3.13/ext/php_curl.dll' - L\x92application n\x92a pas pu d\xe9marrer car sa configuration c\xf4te-\xe0-c\xf4te est incorrecte. Pour plus d\x92informations, consultez le journal d\x92\xe9v\xe9nements d\x92applications ou utilisez l\x92outil de ligne de commande sxstrace.exe.\r\n in Unknown on line 0
            [Mon Oct 21 10:45:13 2013] [notice] Child 4452: Child process is running
            [Mon Oct 21 10:45:13 2013] [notice] Child 4452: Acquired the start mutex.
            [Mon Oct 21 10:45:13 2013] [notice] Child 4452: Starting 64 worker threads.
            [Mon Oct 21 10:45:13 2013] [notice] Child 4452: Starting thread to listen on port 80.
            [Mon Oct 21 10:45:13 2013] [notice] Child 4452: Starting thread to listen on port 80.
            Je suis en train de voir avec o2switch pour les logs apache car je n'ai pas de dossier log sur mon hébergement...
            Création de sites web, Référencement, Intégration, Webdesign... Un Webmaster freelance pour vos campagnes de communication sur le web... www.lucvillalba.fr
            Des tutos et astuces sur mon blog www.lestutosdelucho.fr

            Commentaire


            • #7
              Re : Téléchargement langue impossible

              Pour info, ça marche sur o2switch avec un Joomla 2.5.14...
              Création de sites web, Référencement, Intégration, Webdesign... Un Webmaster freelance pour vos campagnes de communication sur le web... www.lucvillalba.fr
              Des tutos et astuces sur mon blog www.lestutosdelucho.fr

              Commentaire


              • #8
                Re : Téléchargement langue impossible

                Envoyé par lucvillalba Voir le message
                Alors dans Wampserver :
                Là, la chose est claire, l'extension Curl ne peut être démarrée car mal configurée.
                Voir sa doc http://php.net/manual/fr/book.curl.php
                Pas de demande de support par MP.
                S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                Commentaire


                • #9
                  Re : Téléchargement langue impossible

                  Apparemment ça ne vient pas de là, j'ai fixé l'erreur mais ça ne fonctionne toujours pas...

                  Le nouveau log apache :

                  Code:
                  [Mon Oct 21 11:37:16 2013] [notice] Parent: Received shutdown signal -- Shutting down the server.
                  [Mon Oct 21 11:37:16 2013] [notice] Child 5620: Exit event signaled. Child process is ending.
                  [Mon Oct 21 11:37:17 2013] [notice] Child 5620: Released the start mutex
                  [Mon Oct 21 11:37:18 2013] [notice] Child 5620: All worker threads have exited.
                  [Mon Oct 21 11:37:18 2013] [notice] Child 5620: Child process is exiting
                  [Mon Oct 21 11:37:18 2013] [notice] Parent: Child process exited successfully.
                  [Mon Oct 21 11:37:25 2013] [notice] Apache/2.2.22 (Win64) PHP/5.3.13 configured -- resuming normal operations
                  [Mon Oct 21 11:37:25 2013] [notice] Server built: May 13 2012 19:41:17
                  [Mon Oct 21 11:37:25 2013] [notice] Parent: Created child process 2296
                  [Mon Oct 21 11:37:25 2013] [notice] Child 2296: Child process is running
                  [Mon Oct 21 11:37:25 2013] [notice] Child 2296: Acquired the start mutex.
                  [Mon Oct 21 11:37:25 2013] [notice] Child 2296: Starting 64 worker threads.
                  [Mon Oct 21 11:37:25 2013] [notice] Child 2296: Starting thread to listen on port 80.
                  [Mon Oct 21 11:37:25 2013] [notice] Child 2296: Starting thread to listen on port 80.
                  Création de sites web, Référencement, Intégration, Webdesign... Un Webmaster freelance pour vos campagnes de communication sur le web... www.lucvillalba.fr
                  Des tutos et astuces sur mon blog www.lestutosdelucho.fr

                  Commentaire


                  • #10
                    Re : Téléchargement langue impossible

                    Je ne peux pas te dire grand chose de plus que ce que les logs racontent
                    Pas de demande de support par MP.
                    S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                    Commentaire


                    • #11
                      Re : Téléchargement langue impossible

                      CURL est ok chez o2switch, je viens d'avoir la confirmation.

                      Je vais faire des essais et voir d'où ça peut venir, je reviendrai vous dire ce qu'il en est...

                      En tous cas, merci Jisse03!
                      Création de sites web, Référencement, Intégration, Webdesign... Un Webmaster freelance pour vos campagnes de communication sur le web... www.lucvillalba.fr
                      Des tutos et astuces sur mon blog www.lestutosdelucho.fr

                      Commentaire


                      • #12
                        Re : Téléchargement langue impossible

                        Alors je viens de refaire des tests...

                        J'ai essayé avec J3.1.5, J3.0.1 et J2.5.14
                        Sur différents serveurs : 1&1, o2switch, Wamp, EasyPhp.

                        Cela ne fonctionne sur aucun... C'est à n'y rien comprendre...
                        Création de sites web, Référencement, Intégration, Webdesign... Un Webmaster freelance pour vos campagnes de communication sur le web... www.lucvillalba.fr
                        Des tutos et astuces sur mon blog www.lestutosdelucho.fr

                        Commentaire


                        • #13
                          Re : Téléchargement langue impossible

                          Vu que ça fonctionne sur ces mêmes hébergeurs pour pas mal de monde, il doit y avoir un loup dans ta configuration (ou un .htaccess trop restrictif)
                          Pas de demande de support par MP.
                          S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadok)

                          Commentaire


                          • #14
                            Re : Téléchargement langue impossible

                            C'est là que je ne comprends pas, sur une installation vierge, htacces non renommé, SEF non modifié, ça ne fonctionne pas. Mes hébergeurs sont dans des configs par defaut hormis le safe mode pour wamp easyphp et o2switch...

                            Ce n'est pas grave, j'ai fait sans mais c'est vrai que ça m'interpelle...
                            Création de sites web, Référencement, Intégration, Webdesign... Un Webmaster freelance pour vos campagnes de communication sur le web... www.lucvillalba.fr
                            Des tutos et astuces sur mon blog www.lestutosdelucho.fr

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins

                            Partenaire de l'association

                            Réduire

                            Hébergeur Web PlanetHoster
                            Travaille ...
                            X