Pleins d'erreurs joomla + nginx

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Pleins d'erreurs joomla + nginx

    Bonjour,

    Je suis en train de tester de passer des sites sous nginx et je ne sais pas si c'est lié mais j'ai pas mal d'erreurs.

    Pour info :

    - chaque site possède un home directory dédié du style /home/mon_site/www
    - le www dans le home directory est un lien symbolique vers un disque addidtionnel qui héberge physiquement les fichiers
    - donc le lien symbolique www pointe par exemple vers /mnt/mon_disque/data/mon_site (le point de montage du disque)

    1) Déjà sur la home page j'ai ce message : THE FILE CACHE STORAGE IS NOT SUPPORTED ON THIS PLATFORM
    Alors que dans le fichier configuration.php le cache est désactivé, voir ci-dessous :

    Cliquez sur l'image pour l'afficher en taille normale  Nom : cache1.jpg* Affichages : 1* Taille : 32,4 Ko* ID : 1988841

    2) Dans le fichier configuration.php, dans l'onglet système, le champ Gestion du cache est vide et je ne peux rien sélectionner.
    Alors que dans le fichier en dur j'ai bien ceci, voir ci-dessous :

    Code:
     public $cache_handler = 'file';
    Cliquez sur l'image pour l'afficher en taille normale  Nom : cache2.jpg* Affichages : 1* Taille : 33,7 Ko* ID : 1988842

    3) Au niveau système, mes dossiers sont en bien 755 voir ci-dessous....

    Cliquez sur l'image pour l'afficher en taille normaleNom : droits-linux.jpg*Affichages : 1*Taille : 108,2 Ko*ID : 1988844

    pourtant quand je vais dans système -> informations système -> onglet Permissions des dossiers, cela m'affiche tous les répertoires en lecture seule sauf tmp et logs...alors qu'ils sont tous bien en 755 au niveau linux. voir ci-dessous :



    Cliquez sur l'image pour l'afficher en taille normale  Nom : dossiers.jpg* Affichages : 1* Taille : 132,7 Ko* ID : 1988843

    4) même avec le composant Admin Tools je n'arrive pas à corriger les permissions

    5) Quand j'essaye de sauvegarder le fichier configuration.php ou que j'essaye de mettre à jour une extension, il me sort ces 2 messages respectifs :


    Une erreur s'est produite
    0 Impossible d'enregistrer le fichier de configuration


    Alerte

    JFolder::create: Impossible de créer le répertoirePath:






    Si vous avez des idées je suis preneur car la j'ai jamais eu ça sérieux :-/

    Merci d'avance
    Dernière édition par Tortue Genial 69 à 19/10/2018, 07h40
    Membre des 5 mousquetaires de l'apéro !!!

  • #2
    Voici la conf nginx pour info :

    A noter que la ligne root dans le bloc server pointe vers le lien symbolique

    Cliquez sur l'image pour l'afficher en taille normale

Nom : nginx.jpg 
Affichages : 1 
Taille : 123,3 Ko 
ID : 1988846

    Dernière édition par Tortue Genial 69 à 05/10/2018, 23h05
    Membre des 5 mousquetaires de l'apéro !!!

    Commentaire


    • #3
      J'ai trouvé une piste.

      quand je passe tous les répertoire en 777 tout refonctionne sauf dans le fichier configuration.php, dans l'onglet système, le champ Gestion du cache affiche juste FICHIER alors qu'il devrait y avoir en plus MIS EN MEMOIRE CACHE (expérimental).

      Donc tous les soucis viennent visiblement des permissions, mais je capte pas pourquoi car sur mon serveur actuel (sous apache) tout fonctionne nickel avec les dossiers en 755.
      Membre des 5 mousquetaires de l'apéro !!!

      Commentaire


      • #4
        Salut

        As-tu vérifié le owner du dossier et le nom de l'utilisateur ngix ? Je suis très loin d'être compétent ici mais si c'est OK en 777 et pas en 755 c'est obligatoirement un problème au niveau de l'utilisateur qui ne serait pas dans le même groupe que le propriétaire du dossier (enfin sauf erreur de ma part)
        Christophe (cavo789)
        Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
        Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
        Mes logiciels OpenSource : https://www.avonture.be
        Les 8 et 9 mars prochain ? J'peux pas, j'ai JoomlaDay 2019 #jd19fr (plus d'infos)

        Commentaire


        • #5
          Hello,

          en fait j'ai essayé de mettre le dossier du site en 755 et 775 avec user nginx et groupe nginx et idem.

          dossier en 755
          Cliquez sur l'image pour l'afficher en taille normale  Nom : 755.jpg* Affichages : 1* Taille : 30,7 Ko* ID : 1988859

          dossier en 775
          Cliquez sur l'image pour l'afficher en taille normale  Nom : 775.jpg* Affichages : 1* Taille : 31,3 Ko* ID : 1988860


          fichiers et sous dossiers en 755
          Cliquez sur l'image pour l'afficher en taille normale  Nom : dir.jpg* Affichages : 1* Taille : 113,1 Ko* ID : 1988861

          dans le fichier /etc/group j'ai bien la ligne du groupe nginx qui existe :

          nginx:x:121:

          dans le fichier /etc/passwd j'ai bien le user nginx qui existe et qui est bien affecté au groupe nginx, mais par contre la fin de la ligne n'est pas formatée pareil:

          nginx:x:114:121:nginx user,,,:/nonexistent:/bin/false

          Si je compare avec le user www-data, je n'ai pas le même formatage :


          www-data:x:33:33:www-data:/var/www:/usr/sbin/nologin

          C'est normal ça ?
          Membre des 5 mousquetaires de l'apéro !!!

          Commentaire


          • #6
            bon je viens de faire un autre test.

            j'ai remplacé les droits de tous les dossiers par le user et le groupe www-data au lieu de nginx et tout fonctionne impeccable.

            donc je sais pas ce qui coince avec le user/groupe nginx...dans le fichier passwd ?
            Membre des 5 mousquetaires de l'apéro !!!

            Commentaire


            • #7
              Il y a une discussion en cours sur le même type de problème. Selon la configuration du serveur (Apache ou Nginx), le propriétaire (et son groupe) sont différents selon que les fichiers sont transférés par ftp ou écrits par Joomla!
              J'ai été confronté à ce type de problème lorsque je me suis essayé à la gestion d'un VPS, et la solution était la manière de faire tourner PHP sur le serveur (mais je ne me souviens pas du paramétrage à l'époque).
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

              Commentaire


              • #8
                Envoyé par RobertG Voir le message
                Il y a une discussion en cours sur le même type de problème. Selon la configuration du serveur (Apache ou Nginx), le propriétaire (et son groupe) sont différents selon que les fichiers sont transférés par ftp ou écrits par Joomla!
                J'ai été confronté à ce type de problème lorsque je me suis essayé à la gestion d'un VPS, et la solution était la manière de faire tourner PHP sur le serveur (mais je ne me souviens pas du paramétrage à l'époque).
                +1
                j'ai eu un souci de ce genre une fois ... c'est celui qui avait la main sur le serveur qui a changé les droits du groupe www-data pour que ça passe ... (de mémoire)
                Le JoomlaDay 2019 aura lieu le 8 et 9 mars à Paris ... On vous attend tous pour rencontrer la communauté, faire plus ample connaissance, assister aux conférences .... et surtout passer un BON moment ensemble
                “Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter le nouveau service (en Beta) de la base de connaissance
                https://kb.joomla.fr
                Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez chaque jour ? Alors adhérer à l'AFUJ https://www.joomla.fr/association/adherer

                Commentaire


                • #9
                  en fait c'est moi qui gère le serveur car je suis sur du dédié.

                  j'ai bien identifié que cela vient d'un soucis de permissions, mais je capte pas pourquoi avec le user/groupe www-data tout fonctionne impec, alors qu'avec le user/group nginx j'ai toutes ces erreurs.

                  à part la ligne différente dans le fichier passwd je vois pas la

                  dans le fichier /etc/passwd j'ai bien le user nginx qui existe et qui est bien affecté au groupe nginx, mais par contre la fin de la ligne n'est pas formatée pareil:

                  nginx:x:114:121:nginx user,,,:/nonexistent:/bin/false

                  Si je compare avec le user www-data, je n'ai pas le même formatage :


                  www-data:x:33:33:www-data:/var/www:/usr/sbin/nologin
                  Dernière édition par Tortue Genial 69 à 07/10/2018, 09h22
                  Membre des 5 mousquetaires de l'apéro !!!

                  Commentaire


                  • #10
                    autre truc, quand j'essaye d'uploader une extension pour l'installer j'obtiens ça, alors que la mise à jour d'une extension déjà installer fonctionne :

                    403 Forbidden

                    nginx
                    Membre des 5 mousquetaires de l'apéro !!!

                    Commentaire


                    • #11
                      je viens de voir autre chose.
                      quand je vais dans un article, l'éditeur JCE ne s'affiche plus et dans la console de debug du navigateur j'ai ça :
                      et les boutons annuler, fermer etc ne fonctionnent plus...

                      Failed to load resource: net::ERR_SPDY_PROTOCOL_ERROR
                      index.php?option=com_content&view=article&layout=e dit&id=46:102 Uncaught ReferenceError: WFEditor is not defined
                      at Object.Joomla.submitbutton (index.php?option=com_content&view=article&layout= edit&id=46:102)
                      at HTMLButtonElement.onclick (index.php?option=com_content&view=article&layout= edit&id=46:430)


                      Solution pour JCE, pour ceux que ça intéresse :

                      In the Editor Global Configuration, set Compress Javascript and Compress CSS to No.

                      par contre je ne comprends pas pourquoi sur mon serveur actuel cela fonctionne et maintenant sous nginx je suis obligé de désactiver ces options de compression.

                      je viens de faire un tour un peu partout dans le back office et dès que je veux enregistrer un article, cliquer sur un bouton ferme ou autre, j'ai le message :

                      403 Forbidden
                      nginx

                      par contre les boutons FERMER, ENREGISTRER etc.... fonctionnent bien dans menu et modules.

                      mais dans les menu utilisateurs, certaines extensions, contenu etc... cela me sort l'erreur 403.

                      la j'avoue je comprends pas :-/
                      Dernière édition par Tortue Genial 69 à 07/10/2018, 09h57
                      Membre des 5 mousquetaires de l'apéro !!!

                      Commentaire


                      • #12
                        bon j'ai trouvé d'ou vient le soucis de cette erreur 402, il s'agit de conf du mod_security de nginx.
                        une fois les lignes rouges ci-dessous commentées, je n'ai plus aucun soucis...cela vous parle?

                        # From https://github.com/SpiderLabs/ModSecurity/blob/master/
                        # modsecurity.conf-recommended
                        #
                        # Edit to set SecRuleEngine On
                        Include "/etc/nginx/modsec/modsecurity.conf"

                        # OWASP CRS v3 rules
                        Include "/etc/nginx/owasp-modsecurity-crs-3.0.0/crs-setup.conf"
                        Include "/etc/nginx/owasp-modsecurity-crs-3.0.0/rules/*.conf"

                        Membre des 5 mousquetaires de l'apéro !!!

                        Commentaire


                        • #13
                          [Mode humour dominical]

                          Voilà, voilà, c'était donc ça, c'était ton "Kamehamehaaaa" ;-)

                          [/MHD]
                          Christophe (cavo789)
                          Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
                          Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
                          Mes logiciels OpenSource : https://www.avonture.be
                          Les 8 et 9 mars prochain ? J'peux pas, j'ai JoomlaDay 2019 #jd19fr (plus d'infos)

                          Commentaire


                          • #14
                            Envoyé par cavo789 Voir le message
                            [Mode humour dominical]

                            Voilà, voilà, c'était donc ça, c'était ton "Kamehamehaaaa" ;-)

                            [/MHD]
                            mon dieu ...
                            en effet
                            que de souvenirs au passage....
                            Membre des 5 mousquetaires de l'apéro !!!

                            Commentaire


                            • #15
                              # Edit to set SecRuleEngine On
                              Include "/etc/nginx/modsec/modsecurity.conf"

                              # OWASP CRS v3 rules
                              Include "/etc/nginx/owasp-modsecurity-crs-3.0.0/crs-setup.conf"
                              Include "/etc/nginx/owasp-modsecurity-crs-3.0.0/rules/*.conf"

                              bon tu a supprimer le module de ta config.
                              Ton fihcier crs-setup.conf est un fichier standard. Il y a des regles spécifiques à joomla...
                              https://github.com/SpiderLabs/owasp-...a_attacks.conf

                              Deja la tu devrais avoir du mieux.....
                              Ensuite il faut tester et noter toutes les regles qui posent probleme.
                              Soit tu les supprimes du scan, soit tu les modifies pour les adapter.
                              Ce ne sont que des expressions régulières.
                              Ca reste compréhensible.
                              Mon site en cours de construction avec de nouvelles catégories de documents...
                              https://informaticien51.fr

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X