Joomladay francophone 2019 à Paris, les 8 et 9 mars 2019

Joomla 3.9.2 et version de php

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Joomla 3.9.2 et version de php

    Bonjour la communauté,

    Pour l'un de mes clients, un prestataire tiers a procédé à une mise à jour vers Joomla 3.9.2 fin janvier
    Ils ont aussi upgradé la version php sur leur serveur à 7.2.14 > je ne sais pas quand

    Le 06 février (après la mise à jour du CMS), je me connecte au site et j'utilise le composant que je suis chargée d'administrer, sans aucun problème
    Le 07 février, je me reconnecte à nouveau >> problème avec le composant que je dois administrer
    En l'occurrence Free Support Portal

    1/ type erreur
    Le composant tiers déclenche des erreurs partielles sur ses comportements
    L'erreur se traduit par une page type erreur 404 (cf screenshot)

    MAIS la page générée affiche cette chaîne : Erreur: 0 [] operator not supported for strings

    Le prestataire avance qu'il s'agit d'un problème de compatibilité de version php >> selon vous, est-ce exact ?
    Ou bien ce genre de message signale plutôt un problème de base de données?

    2/ version php

    Pour une réparation rapide, je leur demande de revenir à la version précédente de php implémentée sur leur serveur qui ne posait pas problème.
    La page de pré-requis de joo 3.9.2 recommande 7.1 et +, mais dit que le CMS peut fonctionner avec des versions antérieures
    Avez-vous des préconisations / conseils ???

    Merci pour vos retours
    Bonne journée à tous

    Cliquez sur l'image pour l'afficher en taille normale  Nom : Screen Shot 02-08-19 at 09.56 AM.PNG* Affichages : 40* Taille : 16,6 Ko* ID : 1995436
    Cliquez sur l'image pour l'afficher en taille normale  Nom : Screen Shot 02-08-19 at 10.13 AM.PNG* Affichages : 34* Taille : 2,7 Ko* ID : 1995437Cliquez sur l'image pour l'afficher en taille normale  Nom : Screen Shot 02-08-19 at 10.13 AM 001.PNG* Affichages : 34* Taille : 3,9 Ko* ID : 1995438

    PS:
    concernant les conseils backup / test sur version de préprod avant mise en prod, please, pas de remarque...
    Je pratique ce protocole sur mon propre travail
    Malheureusement je n'ai pas la main sur les pratiques de ce prestataire tiers, qui lui ne suit pas ce protocole apparemment.
    Et c'est ce prestataire qui chapeaute la maintenance du site et des serveurs.
    Je dois le subir: c'est dans les règles de mon client, qui doit lui-même subir les décisions d'une instance supérieure
    Dernière édition par crapouille63 à 11/02/2019, 23h08

  • #2
    Bonjour,

    As-tu testé cette extension sur un autre serveur sous PHP 7.2 ?

    Aïe, Freestyle m'a l'air de ne plus mettre à jour ses extensions. J'utilise Freestyle Translation Manager et j'ai trouvé la mention sur le forum à propos de je ne sais plus laquelle de leurs extensions qu'elle ne sera plus mise à jour (j'avais été intéressé par leur "Portal").
    https://extensions.joomla.org/extens...style-support/
    Dernière édition par RobertG à 08/02/2019, 10h24
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

    Commentaire


    • #3
      Envoyé par RobertG Voir le message
      Bonjour,

      As-tu testé cette extension sur un autre serveur sous PHP 7.2 ?
      Malheureusement je n'ai pas la main sur l'hébergement, géré par un autre prestataire
      Et je ne peux pas récupérer de backup pour faire des tests

      Je leur ai demandé de revenir à la version précédente puisqu'il n'y avait pas de problème avant leur màj
      Pas sûre qu'ils obtempèrent...


      Envoyé par RobertG Voir le message

      Aïe, Freestyle m'a l'air de ne plus mettre à jour ses extensions. J'utilise Freestyle Translation Manager et j'ai trouvé la mention sur le forum à propos de je ne sais plus laquelle de leurs extensions qu'elle ne sera plus mise à jour (j'avais été intéressé par leur "Portal").
      Ben j'espère qu'ils vont le maintenir
      Le truc est impressionnant de fonctionnalités.
      Pas évident à prendre en main, mais assez impressionnant
      En plus du gestionnaire de ticket, il y a une fonction KB (Base de connaissance), une fonction Commentaires sur les tickets

      Là où il est très fort, c'est les très nombreux outils avancés sur les tickets eux-mêmes (agents support multiples / utilisateurs multiples / fusion / réédition...et j'en passe)

      D'un autre côté, comme l'éditeur se sert de son outil pour son propre support et sa KB, ça devrait le motiver à le garder vivant...
      Il faudra bien qu'il mette son Joomla à jour ?


      Merci de ton retour Robert
      En désespoir, si on ne trouve pas de soluce avec le presta tiers, je proposerait de "monter" un joo 3 indépendant, avec l'outil en question.
      Le client avait envisagé d'avoir une solution ticket séparée de son site.

      Je vous tiens au courant si j'ai des news

      Tout retour de la communauté sur le "" [0] error operator.... "", ou autre piste / solution, sera bienvenu

      bonne soirée / journée

      Commentaire


      • #4
        Hello.

        C'est une tolérance de php qui a disparue avec php 7.1
        L'erreur est causée par quelque chose comme ceci :
        Code PHP:
        $foo '';
        $foo[] = "bar"
        Si la variable a été définie comme un string, elle ne peut être utilisé comme un array, sauf à la passer explicitement en array :

        Code PHP:
        $foo '';
        $foo = array();
        $foo[] = "bar"
        .

        Tu as donc une extenssion qui en l'état ne passe pas de php x vers php 7.1 ou +
        Dernière édition par roland_d_alsace à 10/02/2019, 22h08
        A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
        Rejoignez le Joomla Users Groupe Alsace...
        roland_d_alsace va-t-il devenir roland_du_grand_est ?

        Commentaire


        • #5
          Freestyle ne répond plus ! Il suffit de se balader sur leur forum.
          Donc à moins de savoir coder pour réécrire ce composant, ce qui doit être lourd et nécessite au moins un accès ftp ou la possibilité d'installer des extensions sur le site si tu as une copie du pack d'installation à modifier sur un site de test avant de refaire un pack, il n'y a plus qu'à dire à l'autre prestataire de trouver une autre solution que Freestyle Portal
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

          Commentaire


          • #6
            Bonjour


            Oui j'ai vu que le l'éditeur ne répond plus... :-(

            Moi pas savoir coder
            Donc $foo = '';
            $foo[] = "bar";

            c'est du chinois pour moi
            Merci quand même pour la piste

            Mais trouvé astuce quand même grâce à une autre "victime"
            Je la donne ici au cas où ça puisse servir

            Il s'agit de dépublier l'un des plugins du composant >> GUI Plugin Extra Admin

            Il reste quelques erreurs.
            Notamment en administration où on ne peut plus supprimer un utilisateur ajouté à la liste des "autorisés" (pour la gestion du ticket)
            Message retourné:


            Code HTML:
            Too few arguments to function FsssModelFuser::delete(), 0 passed in /home/pmifrance/public_html/administrator/components/com_fss/controllers/fuser.php on line 80 and exactly 1 expected
            Mais en front ça a l'air de fonctionner

            Je vais me mettre en quête d'une autre solution
            En priant pour que Freestyle revienne à la vie
            Ou soit repris par quelqu'un

            Franchement il est bien cet outil de ticket.

            Je passe le ticket en Réglé (bancal)

            Bonne journée

            Commentaire


            • #7
              Compte tenu de ce que j'ai eu l'occasion de lire sur leur forum et du fait que cette extension est commerciale, je doute que quelqu'un la reprenne, hélas, sauf si elle a été achetée par un développeur, les sources n'ayant pas été rendues publiques.
              J'ai le même problème avec leur extension de traduction qui fonctionne pour le moment, mais que je n'ai pas testée sous Joomla! 4 alpha.
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - +sites gérés chez 1and1 et OVH - Site pro : www.robertg-conseil.fr

              Commentaire

              Annonce

              Réduire
              1 sur 2 < >

              C'est [Réglé] et on n'en parle plus ?

              A quoi ça sert ?
              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
              Comment ajouter la mention [Réglé] à votre discussion ?
              1 - Aller sur votre discussion et éditer votre premier message :


              2 - Cliquer sur la liste déroulante Préfixe.

              3 - Choisir le préfixe [Réglé].


              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

              2 sur 2 < >

              Assistance au forum - Outil de publication d'infos de votre site

              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

              UTILISER À VOS PROPRES RISQUES :
              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

              Problèmes connus :
              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

              Installation :

              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

              Archive zip : https://github.com/AFUJ/FPA/zipball/master

              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
              et remplacer www. votresite .com par votre nom de domaine


              Exemples:
              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/
              Pour executer le script: http://www..com/fpa-fr.php

              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
              Télécharger le script fpa-fr.php dans: /public_html/cms/
              Pour executer le script: http://www..com/cms/fpa-fr.php

              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
              Voir plus
              Voir moins

              Partenaire de l'association

              Réduire

              Hébergeur Web PlanetHoster
              Travaille ...
              X