Joomla 3.9.3 ne fonctionne pas sur Version de PHP : 7.2.7

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • #16
    Envoyé par Cara Voir le message

    Je ne fais que lire le message annoncé dès l'entrée du panneau d'administration de JOOMLA, noté comme message d' "ERREUR : Nous avons détecté que le serveur utilise la version de PHP 7.0.33 qui est obsolète et ne reçoit plus les mises à jour de sécurité officielles par ses développeurs. Le projet Joomla recommande la mise à niveau de votre site en PHP 7.1 ou ultérieur qui recevront les mises à jour de sécurité au moins jusqu'au 1/12/19..." ... ça dit bien ce que ça veut dire !

    J'attends toujours la réponse de mon hébergeur...

    Bon samedi
    Oui lire c'est bien mais il faut aussi comprendre et interpréter.

    Comme dit à ce jour ce message n'a aucune importance.

    Je ne sais pas pourquoi ce message est classé en 'error' par le core team de Joomla, il devrait l'être en 'notice' ou 'warning' au grand maximum.

    A faire ainsi peur aux 'clients' avec des messages intrusifs sans réelle raison, on les fait plutôt fuir (ce message a déjà été évoqué +ieurs fois sur les forums).

    Aucun développeur aujourd'hui ne proposera des extensions qui ne fonctionnent qu'en php 7.2, sinon il risque d'en vendre très peu.

    Il en est de même pour les futures versions de Joomla

    Concernant l'emplacement des cessions c'est bien à paramétrer dans la configuration php par toi ou ton hébergeur selon le type d’hébergement que tu possèdes, mais cela peut être aussi un problème de droit d'accès sur ce dossier.
    Dernière édition par roland_d_alsace à 17/02/2019, 01h35
    Cara likes this.
    A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
    Rejoignez le Joomla Users Groupe Alsace...
    roland_d_alsace va-t-il devenir roland_du_grand_est ?

    Commentaire


    • #17
      Une recherche sur "Warning: session_start(): Failed to read session data: user joomla" donne quelques pistes, dont l'une est que mysqli n'est pas activé (réponse proche de ce que Woluweb avait trouvé), une autre concerne le préfixe des tables, incorrect.
      Cara likes this.
      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
      MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

      Commentaire


      • #18
        Envoyé par RobertG Voir le message
        Une recherche sur "Warning: session_start(): Failed to read session data: user joomla" donne quelques pistes, dont l'une est que mysqli n'est pas activé (réponse proche de ce que Woluweb avait trouvé), une autre concerne le préfixe des tables, incorrect.
        Si je comprend bien, il change juste la version de php, l'install de Joomla restant la même.

        Il n'y a donc aucun raison que ce soit le paramétrage de Joomla qui soit en cause.

        Ou alors j'ai raté une des explication de Cara.
        Cara likes this.
        A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
        Rejoignez le Joomla Users Groupe Alsace...
        roland_d_alsace va-t-il devenir roland_du_grand_est ?

        Commentaire


        • #19
          Envoyé par RobertG Voir le message
          J'ai proposé de vérifier sur la version 7.0 : n'as-tu aucune alerte avec en rapport d'erreur à "développement" ? Dans ton premier message, c'est l'errer qui apparaît en 7.2 que tu cites.
          L'alerte de version, on la laisse de côté pour le moment, comme l'a dit Roland, tu peux continuer à utiliser la 7.0 en attendant de comprendre la cause de ce qui se produit en 7.2
          Tu peux aussi activer le débogage en même temps pour voir si autre chose apparaît.

          J'ai trouvé cette discussion, qui concerne surtut PHP 7.3, mais peut-être y a-t-il la même manip à faire pour la 7.2
          https://forum.joomla.fr/forum/joomla...omla-et-php7-3
          A en croire une autre discussion (VPS) il semblerait aussi que soit un problème de paramétrage de serveur.
          Merci pour vos réponses, mais je n'ai pas accès à ce "logiciel" dans le cPanel pour pouvoir tester ce paramètre comme pour "woluweb" :


          Envoyé par woluweb Voir le message
          Voilà, solution trouvée (en tout cas pour PlanetHoster, où on peut activer/désactiver les extensions PHP de son choix) :

          Si ça donne un message "error" sur le site, sur l'écran de configuration de PHP7.3 activer l'extension : nd_mysqli


          [ @modos / SimonG / cavo789 : deuxième fois cette semaine que je veux uploader un screenshot .png, mais le forum me répond "L'importation de l'image a échoué car l'extension de ce fichier ne concorde pas avec son contenu.". Vous aussi ? ]

          ... donc j'attends toujours une réponse de mon hébergeur... Merci pour vos réponses. Pour l'instant je continue de travailler sur 7.0 avec Joomla.

          Bon dimanche à tous

          Commentaire


          • #20
            Envoyé par roland_d_alsace Voir le message

            Si je comprend bien, il change juste la version de php, l'install de Joomla restant la même.

            Il n'y a donc aucun raison que ce soit le paramétrage de Joomla qui soit en cause.

            Ou alors j'ai raté une des explication de Cara.
            Les réponses qu'on a concernent, notamment celle de woluweb et d'une autre discussion au moins, l'activation d'extensions PHP.
            Il suffirait donc qu'une extension nécessaire (nd_mysqli pour woluweb, qui n'est pas activée pour moi qui n'ai que mysqli sur un CPanel en 7.2, nd_mysqli étant désactivé) ne soit pas présente dans la version 7.2 de l'hébergeur alors qu'elle l'es dans la 7.0 pour qu'une erreur apparaisse.

            Question : quel est l'hébergeur ?
            Cara likes this.
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
            MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

            Commentaire


            • #21
              Réponse : Réseau Inter Système

              Commentaire


              • #22
                Envoyé par RobertG Voir le message

                Les réponses qu'on a concernent, notamment celle de woluweb et d'une autre discussion au moins, l'activation d'extensions PHP.
                Il suffirait donc qu'une extension nécessaire (nd_mysqli pour woluweb, qui n'est pas activée pour moi qui n'ai que mysqli sur un CPanel en 7.2, nd_mysqli étant désactivé) ne soit pas présente dans la version 7.2 de l'hébergeur alors qu'elle l'es dans la 7.0 pour qu'une erreur apparaisse.

                Question : quel est l'hébergeur ?
                Effectivement, c'est beaucoup plus probable que le problème provienne de ce côté là que du côté du CMS.
                A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                Rejoignez le Joomla Users Groupe Alsace...
                roland_d_alsace va-t-il devenir roland_du_grand_est ?

                Commentaire


                • #23
                  Envoyé par Cara Voir le message
                  Réponse : Réseau Inter Système
                  "Ce que vous obtenez avec nous:
                  Les meilleurs prix: nous sommes les meneurs!"

                  Pas évident de consulter leur site sur un smartphone, visiblement, le responsive n'est pas encore arrivé là bas !
                  "Si vous n’êtes pas impliqués émotionnellement dans ce que vous créez, laissez tomber."
                  https://www.graphiquedesign-bf.com/

                  Commentaire


                  • #24
                    Envoyé par RobertG Voir le message
                    ....
                    As-tu la possibilité de tester une copie du site sur un autre serveur en 7.2, en local par exemple ?
                    Bonsoir,
                    Chose faite, j'ai pu tester sur un serveur différent (pas en local)... et qui de plus a été changé la nuit dernière...
                    Bref depuis j'ai accès à la version PHP 7.1 sur ce nouveau serveur, et j'en ai profité pour testé les deux versions PHP 7.1 et 7.2, la première est ok, et ne donne plus ce message "d'erreur" à l'ouverture du panneau d'administration de Joomla, la seconde 7.2, elle donne toujours ce message comme sur le premier serveur..
                    Quoiqu'il en soit je vais donc commencer mon apprentissage sur la version php 7.1. Je pars sur de bonnes bases pour tester joomla... avec cette version j'ai jusqu'à la fin de l'année 2019 pour que mon hébergeur me réponde un jour concernant la version 7.2, ce dernier doit être passablement occupé durant ce changement de serveurs., j'imagine !

                    Merci pour toutes vos réponses, je pense pouvoir clore cette conversation.

                    Commentaire


                    • #25
                      Bon courage Reviens si tu as d'autres questions
                      Chabi01 - http://www.xlformation.com

                      Commentaire

                      Annonce

                      Réduire
                      1 sur 2 < >

                      C'est [Réglé] et on n'en parle plus ?

                      A quoi ça sert ?
                      La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                      Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                      Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                      Comment ajouter la mention [Réglé] à votre discussion ?
                      1 - Aller sur votre discussion et éditer votre premier message :


                      2 - Cliquer sur la liste déroulante Préfixe.

                      3 - Choisir le préfixe [Réglé].


                      4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                      2 sur 2 < >

                      Assistance au forum - Outil de publication d'infos de votre site

                      Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                      Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                      Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                      UTILISER À VOS PROPRES RISQUES :
                      L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                      Problèmes connus :
                      FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                      Installation :

                      1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                      Archive zip : https://github.com/AFUJ/FPA/zipball/master

                      2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                      3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                      4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                      5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                      6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                      et remplacer www. votresite .com par votre nom de domaine


                      Exemples:
                      Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/
                      Pour executer le script: http://www..com/fpa-fr.php

                      Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                      Télécharger le script fpa-fr.php dans: /public_html/cms/
                      Pour executer le script: http://www..com/cms/fpa-fr.php

                      En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                      Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                      Voir plus
                      Voir moins

                      Partenaire de l'association

                      Réduire

                      Hébergeur Web PlanetHoster
                      Travaille ...
                      X