Localhost -> https admin

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • #31
    Confiance ? Ça va pas nan ? [Rire]

    On parle bien d'une restauration locale ?
    Je te prépare un lien de téléchargement du jpa demain.

    Dernière édition par Eddy.vh à 01/03/2019, 21h47
    Cordialement.
    __
    Eddy !!!
    Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

    Commentaire


    • #32
      Après avoir lu un message sur Debian User French, j'ai pensé à toi et à ton problème, mais, après vérification, le message d'erreur que tu partages n'est pas cité dans le lien partagé ci-après, ça ne semble donc pas correspondre à ta problématique.

      A tout hasard, je partage tout de même.

      Ce ne serait pas par hasard, un problème de HSTS, et, de preload, le site étant forcé en HTTPS, avec le preload, tu tentes de l'utiliser en local, et, le navigateur te dis : hé coco, moi, je suis en preload hsts, donc, je te force le HTTPS, que tu le veuilles, ou non !

      Lire : https://www.thesslstore.com/blog/cle...hrome-firefox/

      Noter que, à ce moment la que ma proposition de créer un certificat local, pour le https, serait effectivement une solution au problème, plutot que de tenter de désactiver le hsts, autant créer un certificat local.
      Dernière édition par ZerooCool à 15/03/2019, 13h40

      Commentaire


      • #33
        Bonjour ZeroCool.

        Merci pour ton retour.

        J'ai bien pensé au hsts mais étant géré par le plugin :
        1. Je l'ai désactivé via la base de données alors que le site était installé en local.
        2. je l'ai désactivé online avant de faire un backup et le réinstaller en local.
        Rien n'y fait… Je suis un peu en standby avec ce problème et je viens de faire une restauration de mon site miroir (site de tests) à partir de l'original et il fonctionne.
        Je reprendrai ce cas dès que j'aurais un peu plus de temps…
        Cordialement.
        __
        Eddy !!!
        Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

        Commentaire


        • #34
          Bonjour,

          A tester car avec SimonG nous avons rencontré un problème similaire avec un site rapatrié en local pour tests.
          Après maintes recherches, pas de solution.

          Mais une chose a fait tilt ensuite : la sauvegarde du site embarquait un dossier ".well-known" (avec un sous-dossier "acme-challenge" vide) qui, à ma connaissance, correspond au certificat de sécurité. Sur mon PC, je l'ai renommé et j'ai testé (j'avais précédemment forcé l'acceptation de l'affichage sur Firefox et Chrome pour accéder à l'administration) : sur Firefox, Chrome, Opera et Safari, la bascule automatique vers https ne se fait plus, ce qui laisserait entendre que le serveur utiliserait automatiquement ce dossier pour passer en https, sans autre besoin de code pour le lui indiquer, d'où le plantage faute de certificat en local.

          A vérifier donc !
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
          MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

          Commentaire


          • #35
            RobertG.

            Je pense que j'ai supprimé ce répertoire, il s'agit en effet du certificat.
            Je vais cependant vérifier sait-on jamais… Merci pour l'astuce.
            Cordialement.
            __
            Eddy !!!
            Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

            Commentaire


            • #36
              Pas sûr de moi ! Je viens de récupérer une copie d'un site hébergé chez le même hébergeur, avec son dossier .well-known, et pas de forçage en https même en le laissant.
              Je ne sais pas si le forçage de l'affichage en acceptant que le certificat ne soit pas correct a joué un rôle, dans la mesure où ça a fonctionné sur plusieurs navigateurs...
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

              Commentaire


              • #37
                Comme je le pressentais, le dossier est supprimé depuis le début chez moi aussi. Ce n'est donc pas la source du problème…
                Merci quand-même pour l'essai.
                Cordialement.
                __
                Eddy !!!
                Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

                Commentaire


                • #38
                  Salut Eddy.vh ,
                  Je ne sais pas si tu as résolu ton souci de http en local. Voici deux solutions que je te propose.
                  Une astuce peu connue c'est que par défaut mod_login en frontend et backend force https actif. Donc par défaut pour se connecter à l'admin ou sur le site il faut avoir https activé. Mais on peut changer cette option dans l'admin. Si on a pas accès à l'admin. Il faut executer deux requetes SQL. les voici.
                  Code:
                  -- mod_login partie admin forcer http plutot que https par defaut
                  UPDATE bdd_joomla3915.prefix_modules AS m SET m.params = '{"usesecure":"0"}' WHERE m.module = 'mod_login' AND m.`client_id` = 1;
                  -- mod_login partie site forcer http plutot que https par defaut
                  UPDATE bdd_joomla3915.prefix_modules AS m SET m.params = '{"greeting":"1","name":"0","usesecure":"0"}' WHERE m.module = 'mod_login' AND m.`client_id` = 0;
                  les lignes précédées de -- sont des commentaires SQL. Tu peux les effacer si tu veux. Il faut bien sur remplacer le nom de ta base de donnée et le prefix par ceux qui correspondent à ton cas d'utilisation.

                  La seconde solution qui peut être complémentaire à la première c'est de mettre
                  Code PHP:
                  public $shared_session true
                  dans le fichier de configuration.php de joomla comme ça tu peux essayer de te connecter en frontend avec les identifiant superutilisateur et tu seras automatiquement connecté à l'admin. Je sais que c'est risqué et pas securisé mais c'est temporaire. Bien sûr tu desactive cette option dès que tu as à nouveau le contrôle de ta partie admin.

                  Bon courage pour la suite. A tantôt.
                  Cordialement
                  Alexandre
                  manu93fr aime ceci.

                  Commentaire


                  • #39
                    Bonjour alexandreelise

                    Pour la sécurité, c'est pas très grave, c'est en local…
                    Je vais tester tes astuces, sait-on jamais mais le https est bien désactivé en front comme en backend.

                    Je te remercie de ton attention et de ton coup de pouce.
                    Cordialement.
                    __
                    Eddy !!!
                    Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

                    Commentaire


                    • #40
                      Pas de souci Eddy.vh J'essai d'aider tant que je peux. Comme je peux. Bon courage. Moi aussi je cherche une solution à ce problème et pour l'instant ça s'annonce chaud!
                      Eddy.vh aime ceci.

                      Commentaire


                      • #41
                        J'ai déjà rencontré ce problème et si je me souviens bien, la raison était la présence de la mention du site d'origine dans la variable "live_site" du fichier configuration.php. Il faut que la variable soit vide pour que ça fonctionne correctement.
                        Tous les services pour les sites Joomla! : sécurité, nettoyage de sites piratés, hébergement, SEO, applications Fabrik, migration, compatibilité mobiles, accessibilité, ...
                        Administrateur certifié Joomla! 3
                        https://www.betterweb.fr

                        Commentaire


                        • #42
                          Bonjour jfque.

                          Je laisse cette variable toujours vide. C'est donc une bonne idée mais à écarter.
                          Merci toutefois pour ton passage.

                          Cette histoire est vraiment un mystère… Je regarderai à ça le weekend prochain.

                          Belle journée à tous.
                          Cordialement.
                          __
                          Eddy !!!
                          Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

                          Commentaire


                          • #43
                            Rien non plus dans le réglages des domaines de cookies (dans la configuration générale) ?
                            Tous les services pour les sites Joomla! : sécurité, nettoyage de sites piratés, hébergement, SEO, applications Fabrik, migration, compatibilité mobiles, accessibilité, ...
                            Administrateur certifié Joomla! 3
                            https://www.betterweb.fr

                            Commentaire


                            • #44
                              Hé non, pas le moins du monde.

                              Ce n'est plus si grave, j'ai la copie du site (hors-ligne) sur un sous-domaine afin de pouvoir tester mes backups, et faire quelques tests mais je vais tester les quelques nouvelles idées qui pourraient encore être source du problème.
                              Cordialement.
                              __
                              Eddy !!!
                              Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

                              Commentaire


                              • #45
                                Bonjour.

                                alexandreelise BINGO, tu as mis le doigt dessus, j'ai activé la connexion cryptée sur les modules de connexion et c'est ce qui redirige vers https.
                                La modification des options de connexion depuis la base de donnée à résolu le problème.
                                Cool, le grisonnement de mes cheveux va enfin cesser

                                Je te remercie infiniment de m'avoir mis sur cette voie !
                                Dernière édition par Eddy.vh à 06/03/2020, 16h17
                                manu93fr aime ceci.
                                Cordialement.
                                __
                                Eddy !!!
                                Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

                                Commentaire

                                Annonce

                                Réduire
                                1 sur 2 < >

                                C'est [Réglé] et on n'en parle plus ?

                                A quoi ça sert ?
                                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                                Comment ajouter la mention [Réglé] à votre discussion ?
                                1 - Aller sur votre discussion et éditer votre premier message :


                                2 - Cliquer sur la liste déroulante Préfixe.

                                3 - Choisir le préfixe [Réglé].


                                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                                2 sur 2 < >

                                Assistance au forum - Outil de publication d'infos de votre site

                                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                                UTILISER À VOS PROPRES RISQUES :
                                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                                Problèmes connus :
                                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                                Installation :

                                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                                et remplacer www. votresite .com par votre nom de domaine


                                Exemples:
                                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                                Télécharger le script fpa-fr.php dans: /public_html/
                                Pour executer le script: http://www..com/fpa-fr.php

                                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                                Télécharger le script fpa-fr.php dans: /public_html/cms/
                                Pour executer le script: http://www..com/cms/fpa-fr.php

                                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                                Voir plus
                                Voir moins

                                Partenaire de l'association

                                Réduire

                                Hébergeur Web PlanetHoster
                                Travaille ...
                                X