404 Catégorie Introuvable

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] 404 Catégorie Introuvable

    Hello

    Bon je découvre Joomla, et quand je dit "découvre" çà fait 3 jours que j'ai appris son existance et que j'ai porté mon choix vers ce CMS bien complet !
    C'est pas la première fois que j'utilise un CMS, mais là je suis bloqué ... alors je vient chercher de l'aide

    1- J'ai d'abord eu des soucis pour sauvegarder des config toutes bêtes dans la zone admin, mais çà venait de mon htaccess.txt, qu'il fallait renommer en .htaccess et activer "Réécriture au 'vol' des URL" dans la config du site, depuis à ce niveau là çà fonctionne.

    Mais, j'ai un soucis que je ne parvient pas à comprendre, je ne peut en aucun cas sauvegarder un article si dans celui ci je j'insert une image. Il me renvoie sur une erreur 404 Catégorie Introuvable.
    Alors que la catégorie existe bien. De toute façon l'article se sauvegarde correctement sans image :/

    Si quelqu'un peut m'aider çà serai sympa

    Thomas

  • #2
    Toutes les permissions des fichiers du repertoire sont en statut "modifiable", excepté configuration.php qui est en lecture seule.
    et si çà peut aider :

    Informations système
    Paramètres Valeur

    PHP exécuté sur Linux web40.lws-hosting.com 3.10.0-962.3.2.lve1.5.25.5.el7.x86_64 #1 SMP Mon Mar 4 09:57:47 EST 2019 x86_64
    Type de la base de données mysql
    Version de la base de données 5.5.5-10.0.37-MariaDB-cll-lve
    Interclassement de la base de données utf8_general_ci
    Collation de la connexion à la base de données utf8mb4_general_ci
    Version de PHP 5.6.40
    Serveur web Apache
    Serveur web pour interface PHP litespeed
    Version de Joomla Joomla! 3.9.5 Stable [ Amani ] 9-April-2019 15:00 GMT
    Version de la plateforme Joomla! Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
    Navigateur Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

    Commentaire


    • #3
      Voici mon réglége PHP, par mon hebergeur :

      Réglages utiles de PHP
      Paramètres Valeur

      Safe Mode (mode de sécurité PHP) Désactivé
      Open basedir (dossier limite d'arborescence) Aucun
      Display Errors (afficher les erreurs) Activé
      Short open tags (balises courtes d'ouverture) Activé
      File Uploads (transfert HTTP de fichiers) Activé
      Magic quotes (ajout antislash aux guillemets) Désactivé
      Register Globals (EGPCS variables globales) Désactivé
      Output Buffering (limitation du buffer de sortie) Désactivé
      Session Save Path (répertoire de sessions) /var/cpanel/php/sessions/ea-php56
      Session auto start (démarrer à chaque script) 0
      XML activé (lire et écrire les fichiers XML) Oui
      Zlib activé (lire et écrire les fichiers gzip) Oui
      Zip natif activé Oui
      Disabled Functions (fonctions désactivées) Aucun
      Mbstring actif (interprétation des chaînes) Oui
      Iconv activé (conversion des chaînes) Oui
      Nombre maximum de champs de saisie (Maximum Input Variables) 1000

      Commentaire


      • #4
        Bienvenue !

        Pour commencer, tu n'est pas obligé d'utiliser d'emblée la réécriture au vol. Par défaut, seul "SEO" est activé et tu peux le désactiver pour démarrer sur des adresses totalement non réécrites. Logiquement, ça ne devrait pas avoir d'impact côté administration, seules les pages du site ayant leurs adresses réécrites selon les paramétrages de la configuration.

        Utilises-tu l'éditeur par défaut ? Veux-tu dire que c'est lors de l'enregistrement dans l'administration ou depuis le site que l'erreur 404 apparaît ?
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

        Commentaire


        • #5
          Salut RobertG,

          Alors le truc c'est que oui le paramètre SEO sur la ré écriture au vol n'était pas activé, d'ailleurs je l'ai remise en OFF. C'est surtout depuis que j'ai remis le htacess.txt en .htacess je n'ai plus la page blanche avec comme quoi je ne pouvait pas accéder à index.php.
          Que j'utilise JCE ou TinyMCE, çà revient au même, voici l'historique de mes manip :


          1er scénario :
          - Contenu -> Ajouter un article
          - la catégorie est bonne
          - je saisie le titre et commence a rédiger que du texte.
          - Enregistrer

          Je reste bien dans la zone admin et tout se passe bien

          2eme scénario :
          - Contenu -> Ajouter un article
          - la catégorie est bonne
          - je saisie le titre et commence a rédiger que du texte ET je rajoute une image (ou même si j'embed une player c'est idem)
          - Enregistrer

          et là page d'erreur 404 catégorie introuvable DEPUIS la zone admin, car sur le site tout se passe bien (il est en ligne je fait juste des teste donc aucun risque : http://www.amstrad.fun)

          2019-04-16 11_08_34-.png
          2019-04-16 11_09_07-404 Catégorie introuvable.png
          L'Amstrad c'est vraiment fun ! Venez découvrir ce micro 8bits et sa ludothède de ouf !
          Dernière édition par Zisquier à 16/04/2019, 10h21

          Commentaire


          • #6
            Je me demandait si ce n'était pas les "" qu'il n'aimait pas, mais j'ai regardé les magic quote sont désactivé dans la config PHP, alors c'est assez mystérieux j'avoue ... si çà se trouve c'est tout con !

            Commentaire


            • #7
              Ce que je ne comprend pas dans tes copies d'écran, c'est qu'après enregistrement, ce soit sur la page d'accueil du site, et pas dans l'administration, que tu as cette erreur de catégorie. Tes catégories sont-elles bien publiées ?
              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

              Commentaire


              • #8
                Comme tu peut le vois, je ne crois pas me tromper, mais les catégories et notamment "Magazine Français" est notifié OK.
                Le comportement est différent quand je modifie un article vie le site et non l'admin : je procède de la même façon, j'ajoute une image et là il me supprime le code de l'image au moment de la validation : il ne veut pas de mes images lol

                Cliquez sur l'image pour l'afficher en taille normale

Nom : 2019-04-16 11_28_35-.png 
Affichages : 48 
Taille : 55,9 Ko 
ID : 1999322

                Commentaire


                • #9
                  Envoyé par RobertG Voir le message
                  Ce que je ne comprend pas dans tes copies d'écran, c'est qu'après enregistrement, ce soit sur la page d'accueil du site, et pas dans l'administration, que tu as cette erreur de catégorie. Tes catégories sont-elles bien publiées ?
                  Pretite chose à préciser même si c'est l'écran avec le template du site, dans la barre d'url je suis toujours en ../administrator/index.php

                  Cliquez sur l'image pour l'afficher en taille normale

Nom : 2019-04-16 11_34_48-404 Catégorie introuvable.png 
Affichages : 44 
Taille : 27,7 Ko 
ID : 1999324

                  Commentaire


                  • #10
                    Pour la suppression des images depuis l'enregistrement côté site, il pourrait s'agir d'un paramétrage de sécurité de l'éditeur de texte, mais c'est là encore assez bizarre.

                    Que se passe-t-il si tu définis un autre template pour le site, puis que tu enregistres un article avec une image ?
                    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                    Commentaire


                    • #11
                      Envoyé par RobertG Voir le message
                      Pour la suppression des images depuis l'enregistrement côté site, il pourrait s'agir d'un paramétrage de sécurité de l'éditeur de texte, mais c'est là encore assez bizarre.

                      Que se passe-t-il si tu définis un autre template pour le site, puis que tu enregistres un article avec une image ?
                      Et bien j'ai exactement le même problème, mêrme comportement dans les 2 scénarios :
                      Cliquez sur l'image pour l'afficher en taille normale

Nom : 2019-04-16 12_37_45-Erreur_ 404 Catégorie introuvable.png 
Affichages : 49 
Taille : 146,5 Ko 
ID : 1999334

                      Commentaire


                      • #12
                        Je vient de fouiller dans les réglages de mon hebergeur j'était pas défaut en PHP 5 et des bananes et je me suis mis en 7.2 ... mais çà n'a rien changé :/

                        Commentaire


                        • #13
                          Hello.

                          Dans cette discussion il y a de mon côté des trucs qui m'interpellent.

                          Tout au début il est dit :

                          Envoyé par Zisquier Voir le message
                          ...

                          1- J'ai d'abord eu des soucis pour sauvegarder des config toutes bêtes dans la zone admin, mais çà venait de mon htaccess.txt, qu'il fallait renommer en .htaccess et activer "Réécriture au 'vol' des URL" dans la config du site, depuis à ce niveau là çà fonctionne.
                          ...
                          Je ne comprend pas, en admin il n'y a pas de réécriture SEO, renommer ou pas le htaccess n'a aucune incidence sur l'enregistrement des paramètres de configuration.

                          Ensuite un peu plas bas tu dis
                          Envoyé par Zisquier Voir le message

                          Pretite chose à préciser même si c'est l'écran avec le template du site, dans la barre d'url je suis toujours en ../administrator/index.php...
                          Ca aussi je ne comprend pas.

                          Si tu es en backoffice, tu n'as aucune raison d'en sortir lors de l'enregistrement d'un article ?
                          Je comprend pas tu peux préciser ?

                          Peux-tu nous confirmer :
                          1. que le .htaccess il est bien à la racine du site et qu'il n’est pas en /administrator ?
                          2. que tu n'as pas porté de modification dans ce fichier .htaccess ?
                          Dernière édition par roland_d_alsace à 16/04/2019, 13h26
                          A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                          Rejoignez le Joomla Users Groupe Alsace...
                          roland_d_alsace va-t-il devenir roland_du_grand_est ?

                          Commentaire


                          • #14
                            Autre point qui m'interpelle, tes url, comment arrives-tu sur ces url (il manque le view=) ?

                            En admin tu devrais avoir :
                            /administrator/index.php?option=com_content&view=article&layout=e dit&id=13

                            Et en front un truc du genre :
                            ....?view=form&layout=edit&a_id=6840&catid=12&retu rn=aHR0cHM6Ly9za2l2b3NnZXMubmV0Lw==
                            A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                            Rejoignez le Joomla Users Groupe Alsace...
                            roland_d_alsace va-t-il devenir roland_du_grand_est ?

                            Commentaire


                            • #15
                              Salut Roland,

                              Pourtant le fait de passer d'un htacess.txt en .htacess çà m'a permis de pouvoir sauvegarder des config sinon j'avais la page impossible "d'accéder à administrator/index.php"
                              çà faisait çà que certaine configuration de plugin mais pas tous ...
                              Je te confirme je n'ai absoluement rien touché au fichier htacess, je l'ai juste renommé. Et oui il est bien à la racine du site, là où il se trouve dans le pack officiel de joomla, j'ai touché à rien.

                              Oui je trouve le comportement bizarre aussi, si je laisse la moindre image dans l'article je ne peux ni l'enregistrer ou quitter l'article tant que je n'ai pas enlevé l'image ...
                              Est ce qu'il peut y avoir un paramètre qui empêche çà sur le réglage PHP de mon hebergeur ? C'est bizarre que les images empêche la sauvegarde d'un article ...

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X