Class 'WFApplication' not found

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] Class 'WFApplication' not found

    Bonjour,

    Je viens de mettre à jour en cet instant deux extensions de Joomla !

    - Mise à jour language FR 3.9.5.1 => 3.9.5.2 le 16/04/2019
    - Mise à jour Regular Labs - Sourcerer 7.4.3 => 7.5.0FREE le 16/04/2019

    Résultat : je ne peux plus rentrer dans le panneau d'administration.
    Erreur Joomla -> Un erreur s'est produite : 0 Class 'WFApplication' not found

    Avez-vous connaissance de ce problème ? Merci

    Cordialement

    NB : J'ai rechercher dans la base kb joomla => pas de réponse.
    J'ai fais une mise à jour sur un autre site de "language FR 3.9.5.1 => 3.9.5.2". Tout c'est bien passé. C'est donc l'extension Régular Labs qui est à l'origine du plantage.
    Dernière édition par claudiusIII à 16/04/2019, 16h11

  • #2
    "WFA" me fait penser à Admin Tools (le firewall d'Admin Tools)

    Vu que vous n'avez plus accès à l'administration, tentez de simplement (temporairement) renommer le(s) dossier(s) d'Admin Tools :
    administrator/components/com_admintools
    /components/com_admintools

    Et retentez de vous connecter
    Cette année, le JoomlaDay FR aura lieu à Bruxelles (date à préciser suite au report "COVID-19", probablement après l'été. Évènement à ne pas rater. Plus d'infos sur https://www.joomladay.fr

    Un message d’erreur sur votre site Joomla ... ayez le reflexe de consulter lla base de connaissance : https://kb.joomla.fr

    Ce forum, vous l'aimez ? il vous a sauvé la vie ? Vous y apprenez régulièrement ? Alors adhérer à l'AFUJ : https://www.joomla.fr/association/adherer

    Présentations : slides.woluweb.be | Coordonnées complètes : www.woluweb.be

    Commentaire


    • #3
      Bonsoir Woluweb,

      Merci de votre réponse mais je n'ai pas de com_admintools sur aucun de mes sites. Je tiens à signaler que j'ai accès à certaines parties comme les extensions par exemple. C'est l'onglet "Système" qui produit cette erreur dès que l'on clique et cela se déclenche dans d'autres parties de l'Administrateur.
      Dernière édition par claudiusIII à 16/04/2019, 16h10

      Commentaire


      • #4
        Bonjour,

        Pour moi, il s'agit d'un problème avec JCE, une table wf_profile contenant les définitions des profils utilisateurs, il est probable que WFApplication en fasse aussi partie.
        Si l'accès à l'installation d'extensions est toujours possible, j'installerais ou réinstallerais la dernière version 2.7 de cette extension.
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

        Commentaire


        • #5
          Après quelques recherches WFApplication c'est lié à JCE

          /components/com_jce/editor/librairies/classes/extensions/application.php ligne 22 :
          Code PHP:
          class WFApplication extends JObject 
          Fait une mise à jour de JCE.

          A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
          Rejoignez le Joomla Users Groupe Alsace...
          roland_d_alsace va-t-il devenir roland_du_grand_est ?

          Commentaire


          • #6
            Ah !

            Robert à dégainé plus vite que moi
            A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
            Rejoignez le Joomla Users Groupe Alsace...
            roland_d_alsace va-t-il devenir roland_du_grand_est ?

            Commentaire


            • #7
              Bonsoir à tous,

              Merci pour vos réponses qui pointent unanimement sur JCE. Et effectivement et je ne suis pas le seul dans ce forum, j'ai un problème de mise à jour JCE Editor 2.6.38 => 2.7.7 sur mes 4 sites. La même erreur qui est la suivante:

              Joomla\Filesystem\File::delete: Failed deleting inaccessible file controller.php
              Installation d'un paquet : il y a eu une erreur en installant l'extension Mettre à jour

              Je suis donc bloqué sur la version 2.6.38. Certains m'ont dit que cela venait du serveur alors qu'il n'y avait jamais eu de problème depuis : debian 9.8 et php 7.2.15.

              Cordialement

              NB: J'ai vérifié sur deux de mes sites le chemin suivant : /components/com_jce/editor/librairies/classes/extensions/application.php et oh! surprise je n'ai pas le fichier application.php. Comment cela se fait-il ?
              Dernière édition par claudiusIII à 16/04/2019, 19h20

              Commentaire


              • #8
                Bonsoir.

                Télécharge la dernière version et installes par dessus l'actuelle. Ça devrait aller, j'ai procédé de cette manière.
                Dernière édition par Eddy.vh à 16/04/2019, 21h08
                Cordialement.
                __
                Eddy !!!
                Tutoriels BreezingForms en Français : https://www.breezingforms.eddy-vh.com/

                Commentaire


                • #9
                  Regarde si tu n'as pas 2 versions de JCE dans Extensions > Gerer > Gestion.

                  Puis recherche jce / type composant.

                  Si oui, désinstalle la plus ancienne.

                  Mais fait une sauvegarde des tes profils avant.
                  Dernière édition par roland_d_alsace à 16/04/2019, 20h11
                  A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                  Rejoignez le Joomla Users Groupe Alsace...
                  roland_d_alsace va-t-il devenir roland_du_grand_est ?

                  Commentaire


                  • #10
                    Bien ! J'ai tout d'abord vérifié ce que Roland_d_alsace me proposait. Je n'ai absolument pas de deuxième version. Je suis sur la version 2.6.38. J'ai donc fait différentes manips:

                    J'ai essayé de retrouver la version juste après la 2.6.38. C'est la 2.7.3. J'ai essayé de l'installer => même punition et même erreur. J'ai toujours ma fameuse erreur au niveau système.

                    J'ai donc réinstallé la 2.6.38 et là mon erreur sur l'onglet "Système" a disparu et j'ai pu rentrer dans le panneau d'administration donc le problème est réglé à ce niveau. J'ai pu mettre à jour Regular Labs - Sourcerer 7.4.3 => 7.5.0FREE sans souci. C'est donc bien un plantage dû à JCE editor.

                    Conclusion : Il y a vraiment un bug de mise à jour avec JCE editor. Je suis donc bloqué à la version 2.6.38. Aussitôt que l'on passe en version 2.7.x, impossible de faire cette mise à jour:

                    Joomla\Filesystem\File::delete: Failed deleting inaccessible file controller.php ou access.php
                    Installation d'un paquet : il y a eu une erreur en installant l'extension Mettre à jour

                    Qu'est-ce qui cloche dans la version 2.7.x au niveau développement ?

                    Commentaire


                    • #11
                      Pour info, la version 2.7 en est à la 2.7.10
                      Si tu n'as pas fait de paramétrages particuliers sur la 2.6, rien ne t'empêche de la désinstaller pour installer cette 2.7.10

                      En ce qui me concerne, j'ai installé cette 2.7.x sur plus d'un site ayant déjà la 2.6.x installée, et sans le moindre incident.
                      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                      MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                      Commentaire


                      • #12
                        Bonsoir RobertG,

                        J'ai donc suivi ton conseil, n'ayant pas de paramètres particuliers. J'ai désinstallé la version 2.6.38 non sans difficulté car j'avais des erreurs du à des suppressions impossibles dans la,gestion des extensions. Certaines ont été supprimées mais d'autres restaient. J'ai donc renommé dans /components, /administrator/components, com_jce en com_jce1. Dans plugins/editors, jce en jce1.
                        Par précaution j'ai installé la version 2.7.3 qui s'est mise en place avec succès mais quelques erreurs de chemins/répertoires puis j'ai installé la version 2.7.7 qui s'est installée avec succès et sans erreur. J'attends maintenant que joomla détecte la version 2.7.10.

                        J'ai viré ensuite les com_jce1 et jce1.

                        Voilà, voili une chose de réglée. Merci à tous pour votre aide et bonne nuit

                        Commentaire


                        • #13
                          Si le problème est réglé merci de l'indiquer.
                          Pour cela voir l'encadré ci-dessous.
                          Lorsque l'on se cogne la tête contre un pot et que cela sonne creux, ça n'est pas forcément le pot qui est vide.
                          Confucius

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins

                          Partenaire de l'association

                          Réduire

                          Hébergeur Web PlanetHoster
                          Travaille ...
                          X