Accès Admin impossible

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Accès Admin impossible

    Bonjour,

    Je viens de restauré un site sur un sous-domaine, la restauration avec Akeeba backup et kickstart c'est bien passé, le seule souci impossible d’accéder à l'administration du site avec le mot de passe fournie lors de l'installation du site.
    Aucun message d’erreur ne s'affiche.
    Version Joomla 3.9.8 / PHP 7.2 URL/ https://www.inox.joomlaalger.org/adm...ator/index.php
    c'est la première fois que je suis confronté a ce type de problème.

    Cordialement,
    @webdjam
    Dernière édition par webdjam à 03/07/2019, 14h32

  • #2
    Bonjour

    Va voir https://github.com/cavo789/joomla_log_admin. Il devrait t'être fort utile.

    Bonne journée
    Christophe (cavo789)
    Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
    Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
    Mes logiciels OpenSource : https://www.avonture.be

    Commentaire


    • #3
      Bonjour Christophe,

      Le Script ne marche pas, la je suis dans un cas de figure différents, pas de message d'erreur lorsque j'introduis mon mot de passe, je l'ai même modifier via myphpadmin.
      Merci pour le coup de main.

      Commentaire


      • #4
        Bonjour,

        Effectivement, vous ne passez pas par la validation de l'utilisateur car, quelque soit ce que l'on entre, on sort.....

        La dernière fois que j'ai vu cela, c'était lié au domaine de cookies qui était incorrect dans la configuration, mais, c'est peut-être autre chose.

        Avez-vous essayé de renommer votre fichier .htaccess, s'il existe ? utilisez-vous des extensions type admintools ?

        Pascal
        Dernière édition par pmleconte à 02/07/2019, 18h00
        If anything can go wrong, it will...
        If I can help, I will ..https://conseilgouz.com

        Commentaire


        • #5
          Bonjour,

          Dans un premier temps j'essaierais de modifier le fichier configuration.php afin de mettre la valeur de $debug à 1 et $error_reporting à "development" pour voir si une info permet de savoir ce qui bloque.
          Autre possibilité : écraser les fichiers avec une version vierge de Joomla! 3.9.8, sauf le dossier "installation " et éventuellement sans les templates au cas où ce serait un template par défaut modifié qui serait utilisé. Il n'est pas impossible que malgré Akeeba, certains fichiers aient été mal écrits sur le nouveau serveur.
          "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
          MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr hébergés chez PHPNET - sites perso chez PlanetHoster + sites gérés chez 1and1 et OVH

          Commentaire


          • #6
            Bonjour

            Le script https://github.com/cavo789/joomla_log_admin ne passe pas par les plugins d'authentication; si p.ex. le plugin est désactivé, log_admin s'en moque.

            Toutefois ... il faut au minimum un super admin actif et valide.

            Perso, je pencherai plutôt de ce côté-là : est-ce qu'il y a au moins un super admin et est-ce que ses droits sont bien corrects ?

            ==> je tenterai de créer un nouveau super admin; la doc officielle reprend un SQL statement à cette fin : https://docs.joomla.org/How_do_you_r...in_password%3F

            Bonne journée
            Christophe (cavo789)
            Logiciel gratuit de scan antivirus : https://github.com/cavo789/aesecure_quickscan (plus de 45.000 virus détectés, 700.000 fichiers sur liste blanche)
            Développeur de marknotes, logiciel de gestion de prises de notes avec interface web et de multiples convertisseur https://github.com/cavo789/marknotes
            Mes logiciels OpenSource : https://www.avonture.be

            Commentaire


            • #7
              Bonjour,

              Merci pour les astuces, oui le fichier htaccess existe, pas d'admin tools installer, je vais faire des test et je vous tiens au courant.

              Bonne journée

              Commentaire


              • #8
                Envoyé par RobertG Voir le message
                Bonjour,

                Dans un premier temps j'essaierais de modifier le fichier configuration.php afin de mettre la valeur de $debug à 1 et $error_reporting à "development" pour voir si une info permet de savoir ce qui bloque.
                Autre possibilité : écraser les fichiers avec une version vierge de Joomla! 3.9.8, sauf le dossier "installation " et éventuellement sans les templates au cas où ce serait un template par défaut modifié qui serait utilisé. Il n'est pas impossible que malgré Akeeba, certains fichiers aient été mal écrits sur le nouveau serveur.
                Bonjour Robert,

                Fichier configuration php modifier debug activé et rapport d’erreur en development , j'ai aussi écraser les fichiers avec une version vierge de Joomla! 3.9.8, le template installer n'a pas subi de grande modification a part le custom css. peut-être comme tu le mention une mauvaise écriture des fichiers sur le serveur, bon pour l'instant rien de nouveau, impossible d’accéder a l'admin, aucun message d’erreur ou de mot de passe erroné, mystère boule de gomme!!!

                Commentaire


                • #9
                  Bonjour,

                  As-tu regardé si tu as un domaine de cookies dans ta config (ligne cookie_domain + cookie_path) ? cela m'avait fait tourner en bourrique une journée. Il avait suffi de mettre à blanc.

                  Pascal
                  Dernière édition par pmleconte à 03/07/2019, 12h58
                  If anything can go wrong, it will...
                  If I can help, I will ..https://conseilgouz.com

                  Commentaire


                  • #10
                    Envoyé par pmleconte Voir le message
                    Bonjour,

                    As-tu regardé si tu as un domaine de cookies dans ta config (ligne cookie_domain + cookie_path) ? cela m'avait fait tourner en bourrique une journée. Il avait suffi de mettre à blanc.

                    Pascal
                    Bonjour Pascal,

                    Et oui c'est bien les deux ligne cookie domain et cookie path dans le fichier de configuration, encore une fois merci d'avoir éclairé ma lanterne.
                    Merci aux membres du forum qui ont participer a la discussion.

                    Djamel
                    Dernière édition par webdjam à 04/07/2019, 09h14

                    Commentaire

                    Annonce

                    Réduire
                    1 sur 2 < >

                    C'est [Réglé] et on n'en parle plus ?

                    A quoi ça sert ?
                    La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                    Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                    Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                    Comment ajouter la mention [Réglé] à votre discussion ?
                    1 - Aller sur votre discussion et éditer votre premier message :


                    2 - Cliquer sur la liste déroulante Préfixe.

                    3 - Choisir le préfixe [Réglé].


                    4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                    2 sur 2 < >

                    Assistance au forum - Outil de publication d'infos de votre site

                    Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                    Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                    Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                    UTILISER À VOS PROPRES RISQUES :
                    L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                    Problèmes connus :
                    FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                    Installation :

                    1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                    Archive zip : https://github.com/AFUJ/FPA/zipball/master

                    2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                    3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                    4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                    5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                    6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                    et remplacer www. votresite .com par votre nom de domaine


                    Exemples:
                    Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/
                    Pour executer le script: http://www..com/fpa-fr.php

                    Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                    Télécharger le script fpa-fr.php dans: /public_html/cms/
                    Pour executer le script: http://www..com/cms/fpa-fr.php

                    En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                    Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                    Voir plus
                    Voir moins

                    Partenaire de l'association

                    Réduire

                    Hébergeur Web PlanetHoster
                    Travaille ...
                    X