Page blanche à l'ouverture du site

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Page blanche à l'ouverture du site

    Bonjour,
    A l'ouverture mon site affiche une page blanche. Avec un lien j'arrive à l'ouvrir par exemple
    https://www.rhone-alpes-petanque.fr/...alaudiere-2019.
    Pour l'administration c'est pareil, je l'ouvre avec un lien. Une fois dans l'admin je peux y naviguer et travailler.
    J'ai l'impression que c'est mon index.php qui est bloqué. J'ai pas mal d 'inscriptions frauduleuses et ai des retours chez OVH. Est ce la cause ?
    Dernière édition par WROOM à 12/09/2019, 19h50
    https://www.michel-pilato.fr

  • #2
    Bonjour,

    Je vois que votre site est en php 5.6, est-ce à dire qu'au niveau Joomla, ce n'est pas bien à jour non plus ?

    Nous avons eu plusieurs discussions sur des sujets proches : https://forum.joomla.fr/forum/joomla...-blanche-error

    Pascal
    If anything can go wrong, it will...
    If I can help, I will ..https://conseilgouz.com

    Commentaire


    • #3
      Sur votre page d'accueil, vous avez une erreur 500, donc un composant/module qui ne fonctionne pas.

      Essayez de passer votre site en mode développement : https://kb.joomla.fr/procedures/debu...-developpement

      Cela devrait permettre de voir d'où vient l'erreur.

      Pascal
      If anything can go wrong, it will...
      If I can help, I will ..https://conseilgouz.com

      Commentaire


      • #4
        Ça donne l'impression qu'il y a un fichier index.html à la racine du site.
        Lorsque l'on se cogne la tête contre un pot et que cela sonne creux, ça n'est pas forcément le pot qui est vide.
        Confucius

        Commentaire


        • #5
          Bonjour,
          Je vois que votre site est en php 5.6, est-ce à dire qu'au niveau Joomla, ce n'est pas bien à jour non plus ?
          @pmleconte
          Je suis au courant que la version est obsolète.Je dois changer mon logiciel de protection pour la mise à niveau de php.
          Sur votre page d'accueil, vous avez une erreur 500, donc un composant/module qui ne fonctionne pas.
          La semaine passée ça marchait trés bien et je n'ai pas rajouté de composant ni de module.
          J'ai mis en mode développement. J'ai des erreurs sur le template et j'ai eu ce message
          0 - templates/purity_iii/less/bootstrap.less<br /> File `../../../templates/purity_iii/less.less` not found. in anonymous-file-0.less
          Avec le template beez et protostar la page d'accueil est revenue.
          Avec japurity iii j'ai cette erreur
          Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 2 bytes) in /home/michelpiv/petanque/libraries/joomla/database/driver/mysqli.php on line 905
          Donc je vais voir du coté de ce template
          lesoutier
          Il n'y a pas de fichier html
          Dernière édition par WROOM à 09/09/2019, 14h23
          https://www.michel-pilato.fr

          Commentaire


          • #6
            Bonjour Michel,

            Au niveau du template purity iii, il y a eu une mise à jour récente 27 juin 2019 : https://www.joomlart.com/joomla/templates/purity-iii

            Pascal
            If anything can go wrong, it will...
            If I can help, I will ..https://conseilgouz.com

            Commentaire


            • #7
              Bonjour,
              Je viens juste de vérifier, j'ai la bonne version japurityiii 1.2.5.
              Sur mon autre site https://michel-pilato.fr/ j'ai ce template aussi et pas de probléme.
              https://www.michel-pilato.fr

              Commentaire


              • #8
                Bonjour,

                Un module qui s'afficherait seulement sur Purity et pas sur beez3 ni protostar ?
                Un gros besoin de mémoire, à voir le message d'erreur de l'accueil.
                "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                Commentaire


                • #9
                  Bonjour,
                  J'ai mis Cache conservateur dans les paramétres du cache.
                  C'est encore lent mais ça s'ouvre.
                  https://www.michel-pilato.fr

                  Commentaire


                  • #10
                    Le problème avec purity iii est qu'il a lui aussi son système de cache https://www.joomlart.com/documentati...n#optimize-css

                    Il peut y avoir conflit entre le cache Joomla et le cache Purity.

                    Avez-vous activé aussi l'optimisation Purity ?

                    Pascal
                    If anything can go wrong, it will...
                    If I can help, I will ..https://conseilgouz.com

                    Commentaire


                    • #11
                      Ta page est très lourde, voilà ce que je vois dans l'inspecteur de Chrome :
                      406 requests
                      12.1 MB transferred
                      23.6 MB resources
                      Finish: 1.6 min
                      DOMContentLoaded: 3.18 s
                      Load: 18.36 s
                      "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                      MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                      Commentaire


                      • #12
                        En regardant vos pages, vous n'utilisez pas l'option de compression GZIP (dans Configuration, onglet Serveur, option Compression GZip) et je ne vois pas l'activation du cache conservateur.

                        Vous pouvez aussi utiliser JCH Optimize qui, en version gratuite, fait un beau travail de compression/optimisation : https://www.jch-optimize.net/

                        Pascal
                        If anything can go wrong, it will...
                        If I can help, I will ..https://conseilgouz.com

                        Commentaire


                        • #13
                          En complément, (n'hésitez pas à m'arrêter si vous trouvez que je suis trop bavard), vous avez pas mal d'erreurs sur le chargement de votre page d'accueil à cause d'un problème de "mixed content" : vous appelez des styles et js avec des adresses en dur au format http://www.... alors que votre site est en https.

                          Cela se voit en lançant la console de votre explorateur internet : ctrl maj i ou f12 avec Chrome

                          Pascal
                          If anything can go wrong, it will...
                          If I can help, I will ..https://conseilgouz.com

                          Commentaire


                          • #14
                            Bonjour,
                            @pmleconte
                            C'est le site http://www.rhone-alpes-petanque.fr/ qui est deffectueux. Celui ci n'est pas en https.
                            Aujourd'hui c'est la page blanche totale.J'ai activée l'optimisation dans japurity et installé et activé JCH Optimize.
                            Mais je ne sais pas comment le paramétrer.Après l'installation j'ai toujours une page blanche

                            [EDIT] Maintenant je n'est plus accès à l'administration.J'ai une page blanche avec "error"
                            Dernière édition par WROOM à 10/09/2019, 07h54
                            https://www.michel-pilato.fr

                            Commentaire


                            • #15
                              Bonjour,

                              Compte tenu de l'erreur et de l'hébergement chez OVH, vérifie les paramètres d'accès à la base de données. C'est un problème fréquent en ce moment...
                              Pour JCH Optimize, il faut souvent tâtonner. Profite de ce que le site de Fred Jouan (qui nous a quittés en avril dernier) est toujours en ligne pour voir ce qu'il conseillait : https://www.fred-net.fr/blog/joomla/...c-jch-optimize
                              "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
                              MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

                              Commentaire

                              Annonce

                              Réduire
                              Aucune annonce pour le moment.

                              Partenaire de l'association

                              Réduire

                              Hébergeur Web PlanetHoster
                              Travaille ...
                              X