Problème installation site sur un serveur local XAMPP

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Problème installation site sur un serveur local XAMPP

    Bonsoir,
    Je rencontre des difficultés épisodiques pour restaurer en local sur XAMPP (à la fois dernière version de Xampp en PHP8 et version précédente en PHP 7)
    Jusqu'à présent, je n'avais jamais eu aucun pb pour le faire, mais maintenant quelque soit le site que je veux restaurer, j'ai souvent le message "Unable to connect to the Database: Could not connect to MySQL." qui bloque l'installation, mais, ce qui me trouble, c'est que cela marche parfois.
    Y-a-t-il un réglage de time out ou autre à faire ?
    Les sites sont en dernière version Joomla (3.9.24) et les sauvegardes avec la dernière version Akeeba (7.5.1) ; il y a juste un détail quand je sauvegarde, j'ai un warning, mais qui ne semble pas porter à conséquence selon la doc (j'ai laissé la sortie de la sauvegarde sur adminsitrator/component/Com_Akeeba/Backup) "Akeeba Backup is ready to backup your site, but there are potential issues Default output directory in use

    D'avance merci de votre aide

  • #2
    Bonjour,

    Le message d'Akeeba ne signifie rien d'autre que le fait d'utiliser le dossier par défaut est prendre un risque. Il est particulièrement faible compte tenu des noms des sauvegardes.

    Celui à l'import semble vouloir dire que soit MySQL n'est pas démarré, soit qu'il y a un problème sur un des paramètres d'accès à la base.
    "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
    MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

    Commentaire


    • #3
      Merci de votre réponse.
      Quand je regarde XAMPP control MYSQL est bien démarré.
      Quels sont les paramètres d'accès à la base, à part Localhost et Root ? Jusqu'à présent, je nommais la base locale de façon simple du type BDxx ?

      Commentaire


      • #4
        Je n'ai pas l'habitude de Xampp, mais vérifie si root a ou non besoin d'un mot de passe, certains serveurs locaux en ayant un, d'autres pas.

        Et quand tu as l'erreur, essaie d'ouvrir phpMyAdmin pour voir ce qui se passe
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

        Commentaire


        • #5
          Jusqu'à présent, je n'avais jamais mis de mot de passe après root
          Quel phpMyAdmin ouvrir ? j'en ai seulement trouvé un dans le dossier XAMPP ?

          Commentaire


          • #6
            Tu n'as pas un accès direct vers phpMyAdmin depuis un menu de Xampp ?
            "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
            MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

            Commentaire


            • #7
              Si, avec localhost/dashboard mais je n'y vois rien de particulier
              Je viens de refaire une sauvegarde d'un site (dont j'avais fait hier une sauvegarde après mise à jour de joomla et qui ne fonctionnait pas)
              Pas de modif sur le site depuis hier et surprise, la restauration sur le serveur local fonctionne. C'est vraiment aléatoire ou alors c'est la sauveagarde qui se passe mal une fois sur deux.
              Je vais systématiser en local le test de chaque sauvegarde.

              Commentaire


              • #8
                bonjour,
                pour info, le fichier xamp\mysql\resetroot.bat permet de supprimer le mot de passe root de mysql.
                Après, a toi de le reconfigurer.
                Pour accéder à PHPMYADMIN: http://localhost/phpmyadmin
                Quels sont les droits utilisateur ?

                second point; si tu ne vois rien en entrant http://localhost, c est que ton site n'est pas à la racine du serveur.

                Dernier point, lors de ta restauration, tu laisse par défaut les champs admin et identifiants sql?
                Ou tu les modifies à chaque fois?
                .
                Dernière édition par lefabdu51 à 17/01/2021, 13h44
                Un site pour comparer des solutions : https://comparatifs-informaticien51.joomla.com
                un site personnel, sur Joomla, linux, windows et Powershell : https://informaticien51.joomla.com/

                Commentaire

                Annonce

                Réduire
                Aucune annonce pour le moment.

                Partenaire de l'association

                Réduire

                Hébergeur Web PlanetHoster
                Travaille ...
                X