[RÉGLÉ] Les liens ne fonctionnent pas après la migration de Joomla 1.5 à 3.2

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Les liens ne fonctionnent pas après la migration de Joomla 1.5 à 3.2

    Bonjour à tous!

    Je voulais mettre à jour mon Joomla 1.5 à la version 3.2. J'ai utilisé redmigrator et j'ai mis mon site web dans un sous-dossier.
    Puis j'ai déménagé le site web joomla 3.2 du sous-dossier à un autre hebergeur. Le transfert a réussi, mais malheureusement maintenant les liens internes ne fonctionnent pas.
    J'ai aussi transféré le nom de domaine (je suis toujours en attente pour le transfert définitif du domaine). Ainsi, afin d'utiliser joomla 3.2, j'utilise un URL temporaire.

    Est-ce que les liens internes ne fonctionnent pas à cause du URL temporaire?

    Ou ai-je fait quelque erreur dans le transfert du sous-dossier au nouveau hébergeur?

    S'il vous plaît quelqu'un pourrait m'aider?

    N.B. dans le backend tout fonctionne, mais dans le frontend non!

    Merci à tous!
    Dernière édition par NatVit à 23/04/2014, 09h04

  • #2
    Re : Les liens ne fonctionnent pas après la migration de Joomla 1.5 à 3.2

    Bonjour, et bienvenue sur le forum.

    Reprenons tranquillement;
    Ta migration de 1.5 à 3.2 s'est bien passée ? déjà un bon point si c'est le cas, tu as fait le plus dur.

    Migrer vers un autre hébergeur, ne demandera sans doute que des 'ajustements'. Je suppose que tu as profité de passer chez un nouvel hébergeur pour remonter ton site d'un cran et le placer à la racine du www ou quelque soit le nom chez cet hébergeur. (On peut connaître l'heureux élu ?)
    Quand tu dis les liens internes ne fonctionnent plus ça veut dire quoi exactement ? erreur 404 ? peux tu donner un exemple de l'url affiché et de ce que tu pensais obtenir à la place.
    Est-ce que les liens internes ne fonctionnent pas à cause du URL temporaire?
    Probablement pas, les url temporaires pour les migrations sont prévus pour ce genre de cas justement.
    Si tu as changé le niveau de profondeur, vérifie si, dans ton .htaccess tu aurais pas hasard une instruction rewritebase, elle est obligatoire chez certains hébergeurs en cas de sous répertoire d'installation et peut provoquer des ennuis si elle est resté telle que chez ton nouvel hébergeur, tu devrais étant installé à la racine de ton site avoir soit:
    Code:
    rewritebase /
    ou
    Code:
    #rewritebase/cequetuveuxc'estuncommentaire
    Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

    Commentaire


    • #3
      Re : Les liens ne fonctionnent pas après la migration de Joomla 1.5 à 3.2

      Merci pour ta reponse,

      Migrer vers un autre hébergeur, ne demandera sans doute que des 'ajustements'. Je suppose que tu as profité de passer chez un nouvel hébergeur pour remonter ton site d'un cran et le placer à la racine du www ou quelque soit le nom chez cet hébergeur. (On peut connaître l'heureux élu ?)
      l'hebergeur est Westnic (serveur en Allemagne chez Hetzner)


      Quand tu dis les liens internes ne fonctionnent plus ça veut dire quoi exactement ? erreur 404 ? peux tu donner un exemple de l'url affiché et de ce que tu pensais obtenir à la place.
      l'erreur est 404 (voir fichier joint)
      Quand je dis que les liens ne fonctionnent pas, je veux dire que il y a l'erreur 404 quand dans la configuration de joomla les trois paramètres SEO sont actifs. Si je désactive le paramètre SEO: "Réecriture d'URL (SEF)" les liens fonctionnent, mais ne sont pas optimisés pour les moteurs de recherche.

      Si tu as changé le niveau de profondeur, vérifie si, dans ton .htaccess tu aurais pas hasard une instruction rewritebase, elle est obligatoire chez certains hébergeurs en cas de sous répertoire d'installation et peut provoquer des ennuis si elle est resté telle que chez ton nouvel hébergeur, tu devrais étant installé à la racine de ton site avoir soit:
      Code:

      rewritebase /
      Dans la racine de mon site j'ai: rewritebase /

      Qu'est ce que je peut faire?

      Merci encore pour ta reponse.

      Commentaire


      • #4
        Re : Les liens ne fonctionnent pas après la migration de Joomla 1.5 à 3.2

        L'erreur 404 vient de la réécriture d'url qui n'est pas activée dans le .htaccess très certainement.
        Voir avec ton hébergeur comment l'activer si ce n'est pas par la manière standard
        Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

        Commentaire


        • #5
          Re : Les liens ne fonctionnent pas après la migration de Joomla 1.5 à 3.2

          Merci de ta reponse,

          J'ai déplacé le site web et la base des données sur un nom de domaine actif et les link fonctionnent (avec réécriture d'url SEF actif), donc probablement, quand j'active réécriture d'URL (SEF), les liens ne fonctionnent pas parce que j'utilise une URL temporaire.
          Merci encore.

          Commentaire


          • #6
            Re : Les liens ne fonctionnent pas après la migration de Joomla 1.5 à 3.2

            Dans ce cas, il ne te reste qu'à attendre que ton nom de domaine soit transféré définitivement chez ton nouvel hébergeur. Il faut juste te méfier que désactiver la réécriture d'URL provisoirement va modifier tes url, ça va marcher bien sûr, mais Google pendant ce temps va indexer des url provisoires qui une fois stockées vont générer des erreurs 404 potentiels depuis son cache lorsque tu auras réactivé le SEF.

            peut être intéressant d'interdire (provisoirement) l'accès de ton site aux robots

            Cordialement
            Il y a 10 sortes de gens. Ceux qui savent compter en binaire et ceux qui ne savent pas ...

            Commentaire


            • #7
              Re : Les liens ne fonctionnent pas après la migration de Joomla 1.5 à 3.2

              Merci encore pour tes reponses, je suivrai tes conseils. J'attends que le nom de domaine soit transféré. Après, si mon site fonctionnera, j'ajouterai "reglé" à ce topic.
              Cordialement

              Commentaire


              • #8
                Re : Les liens ne fonctionnent pas après la migration de Joomla 1.5 à 3.2

                Oui, les liens ne fonctionnaient pas parce que j'utilisais une URL temporaire. Maintenant tous les liens fonctionnent.
                Merci encore.

                Commentaire

                Annonce

                Réduire
                1 sur 2 < >

                C'est [Réglé] et on n'en parle plus ?

                A quoi ça sert ?
                La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                Comment ajouter la mention [Réglé] à votre discussion ?
                1 - Aller sur votre discussion et éditer votre premier message :


                2 - Cliquer sur la liste déroulante Préfixe.

                3 - Choisir le préfixe [Réglé].


                4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                2 sur 2 < >

                Assistance au forum - Outil de publication d'infos de votre site

                Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                UTILISER À VOS PROPRES RISQUES :
                L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                Problèmes connus :
                FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                Installation :

                1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                Archive zip : https://github.com/AFUJ/FPA/zipball/master

                2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                et remplacer www. votresite .com par votre nom de domaine


                Exemples:
                Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/
                Pour executer le script: http://www..com/fpa-fr.php

                Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                Télécharger le script fpa-fr.php dans: /public_html/cms/
                Pour executer le script: http://www..com/cms/fpa-fr.php

                En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                Voir plus
                Voir moins
                Travaille ...
                X