Joomladay francophone 2018 à Paris 18 et 19 mai

2.5.27 vers 3.3.6 : JHtml image not found.

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [Problème] 2.5.27 vers 3.3.6 : JHtml image not found.

    Slt

    Je viens de passer mon site de 2.5.27 vers 3.3.6, mais je viens de remarquer ce message d'erreur tout en bas du panneau d'administration :
    500 JHtml image not found.
    J'ai fait la mise a jour directement depuis l'admin et ca c'est deroule sans souci.

    Je sais pas si ca peut avoir un rapport, mais j'ai un autre probleme, avec Phocagallery. Au cas ou ca pourrait vous aider, je vous met le lien vers mon post.

    Merci d'avance pour votre aide.
    • Hebergeur :O2Switch
    • PHP 5.4.29
    • Serveur apache
    Mon site de photos du Pays Basque : nenex-argazkia.net

  • #2
    Re : 2.5.27 vers 3.3.6 : JHtml image not found.

    bonjour nenex,

    je rencontre le même problème que toi, sans avoir PhocaGallery.

    le forum anglais donne des pistes pour le résoudre, mais je ne comprends pas la marche à suivre...
    http://forum.joomla.org/viewtopic.php?f=706&t=822116
    An eye for an eye makes the whole world blind...

    Site pro sous Joomla 3 : www.anco.pro et mon site perso : Pixel Marketing

    Commentaire


    • #3
      Re : 2.5.27 vers 3.3.6 : JHtml image not found.

      N'y comprenant rien en anglais j'ai fait une traduc avec google, mais j'y comprend que dalle . J'ai completement refais mon site sur une installation propre de Joomla et j'ai pas eu ce message. Mais j'aimerais quant meme bien savoir d'ou vient de probleme. J'ai garde mon installation qui a ce probleme.
      Mon site de photos du Pays Basque : nenex-argazkia.net

      Commentaire


      • #4
        Re : 2.5.27 vers 3.3.6 : JHtml image not found.

        Hello,
        pour ma part, j'ai pas mal de détails indiqués dans l'admin. C'est survenu pas tout de suite après la MAJ, plutot juste après que j'aie activé le SEF, et c'est resté même après avoir désactivé. L'admin marche à part çà, mais certains comportements sont bizarres...

        Les messages sont :

        An error has occurred.

        500 JHtml image not found.

        Call stack
        # Function Location
        1 JApplicationCms->execute() /home/ancokkaz/www/test/administrator/index.php:42
        2 JApplicationAdministrator->doExecute() /home/ancokkaz/www/test/libraries/cms/application/cms.php:251
        3 JApplicationAdministrator->dispatch() /home/ancokkaz/www/test/libraries/cms/application/administrator.php:159
        4 JComponentHelper::renderComponent() /home/ancokkaz/www/test/libraries/cms/application/administrator.php:98
        5 JComponentHelper::executeComponent() /home/ancokkaz/www/test/libraries/cms/component/helper.php:332
        6 require_once() /home/ancokkaz/www/test/libraries/cms/component/helper.php:352
        7 JControllerLegacy->execute() /home/ancokkaz/www/test/administrator/components/com_cpanel/cpanel.php:15
        8 JControllerLegacy->display() /home/ancokkaz/www/test/libraries/legacy/controller/legacy.php:730
        9 CpanelViewCpanel->display() /home/ancokkaz/www/test/libraries/legacy/controller/legacy.php:693
        10 JViewLegacy->display() /home/ancokkaz/www/test/administrator/components/com_cpanel/views/cpanel/view.html.php:63
        11 JViewLegacy->loadTemplate() /home/ancokkaz/www/test/libraries/legacy/view/legacy.php:211
        12 include() /home/ancokkaz/www/test/libraries/legacy/view/legacy.php:663
        13 JModuleHelper::renderModule() /home/ancokkaz/www/test/administrator/components/com_cpanel/views/cpanel/tmpl/default.php:23
        14 include() /home/ancokkaz/www/test/libraries/cms/module/helper.php:190
        15 acesefIcon() /home/ancokkaz/www/test/administrator/modules/mod_acesef_quickicons/mod_acesef_quickicons.php:59
        16 JHtml::_() /home/ancokkaz/www/test/administrator/modules/mod_acesef_quickicons/mod_acesef_quickicons.php:21
        An eye for an eye makes the whole world blind...

        Site pro sous Joomla 3 : www.anco.pro et mon site perso : Pixel Marketing

        Commentaire


        • #5
          Re : 2.5.27 vers 3.3.6 : JHtml image not found.

          Bonjour à tous,
          petit up svp

          pour les joomlistes pro... de quel côté faut-il investiguer ?
          An eye for an eye makes the whole world blind...

          Site pro sous Joomla 3 : www.anco.pro et mon site perso : Pixel Marketing

          Commentaire


          • #6
            Re : 2.5.27 vers 3.3.6 : JHtml image not found.

            Envoyé par Adrien555 Voir le message
            Bonjour à tous,
            petit up svp

            pour les joomlistes pro... de quel côté faut-il investiguer ?
            Oui moi c'est pareil.

            Je prépare la migration de deux sites de J2.5 vers J3.
            Pour l'instant je teste en local la compatibilité de mes composants.
            En BackEnd, en bas de la page index (panneau d'administration) j'ai ce message qui s'affiche :

            Une erreur s'est produite
            500 JHtml image not found.

            Il y a un début de réponse ici (en anglais)

            http://forum.joomla.org/viewtopic.php?f=706&t=822116
            Code:
            $relative = '/admin/disabled.png';
            $alt = 'foobar';
            JHtml::image($relative, $alt, null, true, false);
            Il est demandé de passer le 4ème paramètre sur "true" mais il n'est nul part précisé dans quel fichier ?
            Dernière édition par glenan à 03/11/2014, 21h07

            Commentaire


            • #7
              Re : 2.5.27 vers 3.3.6 : JHtml image not found.

              bonjour glenan,
              au moins on est moins seuls... je suis tombé sur le même article sur le forum US, et honnetement, je ne sais pas quoi en faire...
              An eye for an eye makes the whole world blind...

              Site pro sous Joomla 3 : www.anco.pro et mon site perso : Pixel Marketing

              Commentaire


              • #8
                Re : 2.5.27 vers 3.3.6 : JHtml image not found.

                Je confirme le même problème sur un site en production.
                Je viens de passer l'upgrade de mon site en local à mon site en ligne.

                Commentaire


                • #9
                  Re : 2.5.27 vers 3.3.6 : JHtml image not found.

                  bonjour Glenan, as tu une liste d'erreurs comme mentionné au message #4 ?

                  c'est bien galère la MAJ vers J33...
                  An eye for an eye makes the whole world blind...

                  Site pro sous Joomla 3 : www.anco.pro et mon site perso : Pixel Marketing

                  Commentaire


                  • #10
                    Re : 2.5.27 vers 3.3.6 : JHtml image not found.

                    Envoyé par Adrien555 Voir le message
                    bonjour Glenan, as tu une liste d'erreurs comme mentionné au message #4 ?

                    c'est bien galère la MAJ vers J33...
                    Non je n'ai pas de liste d'erreur mais sans doute as tu validé le mode debug ?

                    En lisant ta liste d'erreurs, je commencerais par dévalider un module quickicons (voir la ligne qui en parle ci-dessous) car en ce qui me concerne j'avais un problème avec celui d'un composant et ça l'a fait disparaitre (je pense que dans mon cas, ce module n'était pas adapté pour J3 car il s'affichait de manière anarchique en backend)

                    Code:
                    16 JHtml::_() /home/ancokkaz/www/test/administrator/modules/mod_acesef_quickicons/mod_acesef_quickicons.php:21

                    Commentaire


                    • #11
                      Re : 2.5.27 vers 3.3.6 : JHtml image not found.

                      Ca alors ! Je n'y croyais pas trop, mais le fait de dépublier le module dont tu parles a tout résolu, je n'ai plus aucune erreur !

                      merci

                      tu as peut etre toi aussi un composant / module qui coince... je suis en mode debug, et également le 'reporting error' est sur maximum dans l'onglet server de la configuration. Tu auras plus d'infos en mettant sur développement ..
                      An eye for an eye makes the whole world blind...

                      Site pro sous Joomla 3 : www.anco.pro et mon site perso : Pixel Marketing

                      Commentaire


                      • #12
                        Re : 2.5.27 vers 3.3.6 : JHtml image not found.

                        Envoyé par Adrien555 Voir le message
                        c'est bien galère la MAJ vers J33...
                        T'inquiète ! ici c'est le topic JHtml mais j'ai aussi d'autres problèmes à résoudre :
                        - Les composants Phoca (download et Gallery) qui ne veulent pas s'installer sur les versions précédentes J2.5, obligé de désinstaller les deux composants précédents pour que ça se passe bien sauf que j'ai perdu mes listes de fichiers à télécharger ainsi que mes albums photos (tout à refaire à la main).
                        - ContactMap, la version prévue pour J3 ne fonctionne toujours pas.
                        - Dropbox, idem

                        Mais ce que je constate c'est que Joomla n'est pas en cause. Lui se met correctement à jour.
                        Ce sont certains composants qui ne le font pas correctement.
                        Dernière édition par glenan à 04/11/2014, 11h10

                        Commentaire


                        • #13
                          Re : 2.5.27 vers 3.3.6 : JHtml image not found.

                          Envoyé par Adrien555 Voir le message
                          Ca alors ! Je n'y croyais pas trop, mais le fait de dépublier le module dont tu parles a tout résolu, je n'ai plus aucune erreur !

                          merci

                          tu as peut être toi aussi un composant / module qui coince... je suis en mode debug, et également le 'reporting error' est sur maximum dans l'onglet server de la configuration. Tu auras plus d'infos en mettant sur développement ..
                          Tant mieux pour toi, je vais voir ce que je peux faire de ce coté là. Je suis déjà en debug sur mon site en local mais je n'avais pas bien examiné les lignes car moi j'en ai des tonnes !!!

                          Mais on n'est jamais si bien servi que par ... les autres ;-))

                          Commentaire


                          • #14
                            Re : 2.5.27 vers 3.3.6 : JHtml image not found.

                            A quel endroit tu récupères les lignes que tu as postées ici ?

                            Commentaire


                            • #15
                              Re : 2.5.27 vers 3.3.6 : JHtml image not found.

                              les erreurs s'affichaient directement dans l'accueil de l'administration, sous l'erreur JHtml image not found... si tu le vois pas, peut etre que tu n'as pas d'erreurs...
                              An eye for an eye makes the whole world blind...

                              Site pro sous Joomla 3 : www.anco.pro et mon site perso : Pixel Marketing

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X