pas d'accès au front-end - message d'erreur de redirection...

Réduire
Ce sujet est fermé.
X
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] pas d'accès au front-end - message d'erreur de redirection...

    Bonsoir à tous,
    Il y a quelques années, j'ai obtenu de l'aide ici alors je reviens !
    Il y a 2 jours, j'ai mis à jour la version 2.5.28 vers la version 3.4 de mon site.
    J'ai accès au back-end mais pas au front-end...

    Sur le back-end, tout s'affiche correctement sauf l'onglet configuration qui s'affiche d'une drôle de façon (tout en longueur avec des cadres) et qui , à la fin, donne cette info :
    "Paramètres de la base de données
    Type
    Fatal error: Class 'PDO' not found in /home/-nomdusite/public_html/joomla_2_5/libraries/joomla/database/driver/pdomysql.php on line 102"
    .
    J'ai trouvé cette info d'un correctif à appliquer mais je ne sais pas du tout où appliquer le correctif proposé...

    pour le front-end, j'ai ce message :
    "La page n'est pas redirigée correctement
    Firefox a détecté que le serveur redirige la demande pour cette adresse d'une manière qui n'aboutira pas.
    La cause de ce problème peut être la désactivation ou le refus des cookies."


    Je ne sais pas si les 2 problèmes sont liés, si le correctif proposé suffirait à résoudre le problème... et ce soir, je commence à ne plus avoir beaucoup de cheveux à force de chercher des solutions sur le net que je ne trouve pas...

    Je ne suis pas du tout une pro en informatique, je gère seulement depuis quelques années un petit site d'association qui tournait avec joomla et ai appris à m'en débrouiller sur le tas... Si vous avez une idée ou une aide à m'apporter, je vous en serai infiniment reconnaissante !
    Bon week-end !

  • #2
    Re : pas d'accès au front-end - message d'erreur de redirection...

    Envoyé par Nanne Voir le message
    J'ai trouvé cette info d'un correctif à appliquer mais je ne sais pas du tout où appliquer le correctif proposé...
    Bonjour,
    Le correctif est facile à mettre en oeuvre:
    Ouvre le fichier /libraries/joomla/database/driver/pdomysql.php dans un éditeur de texte
    Rends toi à la ligne 102
    Remplace cette instruction :
    Code PHP:
    return in_array('mysql'PDO::getAvailableDrivers()); 
    par:
    Code PHP:
    return class_exists('PDO') && in_array('mysql'PDO::getAvailableDrivers()); 
    Sinon, pour le front, active les cookies dans ton navigateur et regarde si ça fonctionne...
    Un peu de pub: http://www.aplomb.ch

    Commentaire


    • #3
      Re : pas d'accès au front-end - message d'erreur de redirection...

      Merci pour ta réponse Al1
      Notre gentil hébergeur a installé le correctif ! (Merci Michel !).
      Malheureusement, cela ne résout pas le problème du front-end qui n'est toujours pas visible... Quant aux cookies, ils sont bien activés sur mon navigateur...

      Commentaire


      • #4
        Re : pas d'accès au front-end - message d'erreur de redirection...

        Le site est-il multilingue ? S'il ne l'est pas est-ce que le plugin filtre de langue ne serait pas activé inutilement ?
        "Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes; il n'y a que des solutions" (André Gide).
        MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info - Site pro : www.robertg-conseil.fr et sites perso chez PlanetHoster + sites gérés chez PHPNET, 1and1 et OVH

        Commentaire


        • #5
          Re : pas d'accès au front-end - message d'erreur de redirection...

          Envoyé par RobertG Voir le message
          Le site est-il multilingue ? S'il ne l'est pas est-ce que le plugin filtre de langue ne serait pas activé inutilement ?
          Bonsoir Robert,
          Non, il ne l'est pas et le plugin n'est pas activé, j'avais vérifié après avoir déjà lu cette possibilité sur un forum...
          Merci tout de même !

          Commentaire


          • #6
            Re : pas d'accès au front-end - message d'erreur de redirection...

            Bonsoir à tous !
            Bon, ben c'est bien un plugin qui bloquait l'accès au front-end, je ne sais pas encore lequel puisque je suis en train de les réactiver un par un mais dès que j'aurai trouvé, je viendrai poster son nom ici, au cas où ça pourrait aider quelqu'un ?...

            Commentaire


            • #7
              Re : pas d'accès au front-end - message d'erreur de redirection...

              Envoyé par Nanne Voir le message
              Bon, ben c'est bien un plugin qui bloquait l'accès au front-end, je ne sais pas encore lequel puisque je suis en train de les réactiver un par un mais dès que j'aurai trouvé, je viendrai poster son nom ici, au cas où ça pourrait aider quelqu'un ?...
              Bonjour,
              voilà une bonne nouvelle, mais sache une chose, il te faut activer seulement les plugins dont tu as besoin. Activer un plugin inutilisé fait faire des opérations à ton serveur dans le vide...
              Si tu voulais savoir ce qui faisait planter le front end, il fallait activer les messages de débugage, il t'aurait dit quel fichier provoquait l'erreur fatale.
              A+
              Un peu de pub: http://www.aplomb.ch

              Commentaire


              • #8
                Re : pas d'accès au front-end - message d'erreur de redirection...

                Bonsoir,

                quitte à faire des boulettes, autant les faire en série....


                Quand j'ai désactivé tous les modules et plugins, j'en ai réactivé quelques uns mais je n'ai pas du tout pensé à l'authentification avant de me déconnecter...
                Du coup, quand j'ai voulu me reconnecter, j'ai eu le message suivant :
                JAuthentication: :__construct : impossible de charger les librairies d'authentification

                J'ai suivi ce tuto pour activer le plugin authentication_ joomla via phpMyAdmin mais cela n'est pas suffisant pour mon cas : je n'ai plus le message d'erreur lors de la connexion mais mes données (identifiant et mot de passe) sont effacées et la page se recharge inlassablement sur le formulaire vierge d'authentification de l'admin...

                Si quelqu'un a une idée.... ou connaissance d'un autre plugin à réactiver pour pouvoir rétablir l'accès...
                Merci !

                ps à Al1 : j'avais essayé le mode débugage mais je dois vraiment pas être douée parce que je n'avais rien vu...(ou en tout cas, pas compris si il y avait un message d'erreur...). Merci en tout cas pour ta réponse !

                Commentaire


                • #9
                  Re : pas d'accès au front-end - message d'erreur de redirection...

                  Hello.

                  Dans la table #_extensions cherche sur name : plg_authentication_joomla
                  Dans la colone "enabled" met 1 au lieu de 0

                  C'est ce que tu as du déjà faire je suppose.
                  Vérifie bien, sinon mets une copie d'écran de phpmyadmin ici.
                  Dernière édition par roland_d_alsace à 18/03/2015, 21h53
                  A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                  Rejoignez le Joomla Users Groupe Alsace...
                  roland_d_alsace va-t-il devenir roland_du_grand_est ?

                  Commentaire


                  • #10
                    Re : pas d'accès au front-end - message d'erreur de redirection...

                    Envoyé par roland_d_alsace Voir le message
                    Hello.

                    Dans la table #_extensions cherche sur name : plg_authentication_joomla
                    Dans la colone "enabled" met 1 au lieu de 0

                    Vérifie bien, sinon mets une copie d'écran de phpmyadmin ici.
                    Merci Roland pour ta réponse.
                    pour le plg_authentication_joomla, c'est bien ce qu'il y avait déjà, j'ai bien vérifié
                    Quant au plg_authentication_cookie, je viens de l'activer (ce qui donne 0 1 1 0)... mais ça change rien, je ne peux toujours pas me logguer...

                    Commentaire


                    • #11
                      Re : pas d'accès au front-end - message d'erreur de redirection...

                      Dans #_extensions, cherche sur name : plg_user_joomla et mets enabled à 1
                      A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                      Rejoignez le Joomla Users Groupe Alsace...
                      roland_d_alsace va-t-il devenir roland_du_grand_est ?

                      Commentaire


                      • #12
                        Re : pas d'accès au front-end - message d'erreur de redirection...

                        Envoyé par roland_d_alsace Voir le message
                        Dans #_extensions, cherche sur name : plg_user_joomla et mets enabled à 1
                        Je viens de le faire aussi mais malheureusement, le pb reste entier... à chaque fois que j'essaie de me connecter, la page se recharge et le formulaire réapparait vidé de l'identifiant et du mot de passe...

                        Commentaire


                        • #13
                          Re : pas d'accès au front-end - message d'erreur de redirection...

                          Merci Roland !! grâce à toi, je me suis dit qu'il fallait peut-être que je cherche dans tous les plugins joomla et j'ai trouvé celui-ci : plg_extension_joomla qui n'était pas ouvert ! et maintenant, ça fonctionne !!!

                          je peux maintenant acceder au backend ! youppi !

                          Par hasard, existerait-il une liste de tous les plugins natifs de joomla à laisser obligatoirement ouverts ? comme j'ai tout désactivé à cause d'un bug, y'en a que je ne sais pas trop à quoi ils servent...

                          En tout cas, merci encore !!!!

                          Commentaire


                          • #14
                            Re : pas d'accès au front-end - message d'erreur de redirection...

                            Hello.

                            Quand tu "rentres" dans un plugin, comme pour le configurer, il y a toujours une petite info succincte sur la fonctionnalité.

                            Je ne comprend pas trop pourquoi le plg_extension_joomla empêche l'identification.
                            Joomla doit en avoir besoin pour afficher le page d'accueil de l'admin vu qu'il y a un module qui contrôle les Mises à Jour.

                            ...il faut dire que quand tu fais le ménage toi, tu ne fais pas les choses à moitié !!

                            Pense à mettre le sujet en [réglé].
                            A tous les utilisateurs de Joomla du très Grand Est de la France et du Jura suisse
                            Rejoignez le Joomla Users Groupe Alsace...
                            roland_d_alsace va-t-il devenir roland_du_grand_est ?

                            Commentaire

                            Annonce

                            Réduire
                            1 sur 2 < >

                            C'est [Réglé] et on n'en parle plus ?

                            A quoi ça sert ?
                            La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                            Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                            Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                            Comment ajouter la mention [Réglé] à votre discussion ?
                            1 - Aller sur votre discussion et éditer votre premier message :


                            2 - Cliquer sur la liste déroulante Préfixe.

                            3 - Choisir le préfixe [Réglé].


                            4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                            2 sur 2 < >

                            Assistance au forum - Outil de publication d'infos de votre site

                            Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                            Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                            Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                            UTILISER À VOS PROPRES RISQUES :
                            L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                            Problèmes connus :
                            FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                            Installation :

                            1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                            Archive zip : https://github.com/AFUJ/FPA/zipball/master

                            2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                            3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                            4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                            5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                            6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                            et remplacer www. votresite .com par votre nom de domaine


                            Exemples:
                            Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/
                            Pour executer le script: http://www..com/fpa-fr.php

                            Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                            Télécharger le script fpa-fr.php dans: /public_html/cms/
                            Pour executer le script: http://www..com/cms/fpa-fr.php

                            En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                            Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                            Voir plus
                            Voir moins

                            Partenaire de l'association

                            Réduire

                            Hébergeur Web PlanetHoster
                            Travaille ...
                            X