Installation et message "Une erreur s'est produite".

Réduire
X
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • Installation et message "Une erreur s'est produite".

    Bonsoir,

    Je viens d'installer Joomla 3.5.1 sur mon NAS synology (DSM 6).
    L'installation s'est bien déroulée. Mais j'ai le droit à une petite zone "rose" en haut de a console d’administration avec le message:
    "
    Erreur
    Une erreur s'est produite
    "

    Je n'ai pas plus de précision.

    Tout semble fonctionner, mais je n'aime pas comprendre. Et ce message est persistant.

    Avez vous une idée svp ?

    Bonne soirée

  • #2
    Re : Installation et message "Une erreur s'est produite".

    Helloe Loloio,

    Persistant ... C'est à dire ?
    Solidaire avec les dinosaures

    Commentaire


    • #3
      Re : Installation et message "Une erreur s'est produite".

      Envoyé par messinmaisoui Voir le message
      Helloe Loloio,

      Persistant ... C'est à dire ?
      Bonsoir Messinmaisoui

      Merci de t'intéressé à mon problème.

      Quand je dis persistant, c'est que le message ne s’en va pas. Il reste toujours là.
      J'ai beau cliqué sur la petite croix en haut à gauche pour le faire disparaître. Il revient dès que je change de page dans la console d'admin de Joomla.

      J'avais un autre site que j'ai également mis à jour et j'ai la même chose.

      Je comprends pas.

      Une idée ?

      Commentaire


      • #4
        Re : Installation et message "Une erreur s'est produite".



        J'ai mis une capture d'écran pour visualiser.

        Commentaire


        • #5
          Re : Installation et message "Une erreur s'est produite".

          Pièce jointe inaccessible ... malheureusement.
          Solidaire avec les dinosaures

          Commentaire


          • #6
            Re : Installation et message "Une erreur s'est produite".

            j'ai la même chose : même erreur persistante, nas synology... je me demande si ca ne viens pas de DSM... Tu peux accéder à la gestion des modules ? Car c'est le seul dysfonctionnement que j'ai

            Commentaire


            • #7
              Re : Installation et message "Une erreur s'est produite".

              Envoyé par joomrom Voir le message
              j'ai la même chose : même erreur persistante, nas synology... je me demande si ca ne viens pas de DSM... Tu peux accéder à la gestion des modules ? Car c'est le seul dysfonctionnement que j'ai
              En effet joomrom, j'ai les mêmes soucis que tu décris.
              J'ai vu que tu avais fait un nouveau post sur le sujet: ici
              Je vais suivre.
              En parallèle je cherche aussi sur le forum de Synology, car je suis un newbie de chez newbie.
              Si tu réussi à trouver une solution, cela m'intéresse. Et inversement, si je trouve je te tiens au courant...
              @+

              Commentaire


              • #8
                Re : Installation et message "Une erreur s'est produite".

                A tout hasard, Loloio, ton firmware nas est à jour ?
                Solidaire avec les dinosaures

                Commentaire


                • #9
                  Re : Installation et message "Une erreur s'est produite".

                  Envoyé par messinmaisoui Voir le message
                  A tout hasard, Loloio, ton firmware nas est à jour ?
                  Oui tout est à jour.
                  Je ne comprends donc pas ce soucis.
                  Rien de probant par recherche sur Google pour le moment.
                  :-(

                  Commentaire


                  • #10
                    Re : Installation et message "Une erreur s'est produite".

                    Envoyé par loloio Voir le message
                    Oui tout est à jour.
                    Je ne comprends donc pas ce soucis.
                    Rien de probant par recherche sur Google pour le moment.
                    :-(
                    Il semble que changer la variable de mySql "sort_buffer-size" résout ce problème.
                    Pour ma part, je l'ai initialisée à 131072 ( = 128k)

                    Commentaire


                    • #11
                      Re : Installation et message "Une erreur s'est produite".

                      Envoyé par eburon_jpbe Voir le message
                      Il semble que changer la variable de mySql "sort_buffer-size" résout ce problème.
                      Pour ma part, je l'ai initialisée à 131072 ( = 128k)
                      eburon_jpbe, peux tu me dire où je trouve le fichier dans lequel je peux modifier cette valeur. Je n'ai pas trouvé. Dans quel fichier, où cela ?
                      D'avance un grand merci car là je suis vraiment bloqué.

                      Commentaire


                      • #12
                        Re : Installation et message "Une erreur s'est produite".

                        Envoyé par loloio Voir le message
                        eburon_jpbe, peux tu me dire où je trouve le fichier dans lequel je peux modifier cette valeur. Je n'ai pas trouvé. Dans quel fichier, où cela ?
                        D'avance un grand merci car là je suis vraiment bloqué.
                        Via phpMyAdmin, onglet "Variables" ==> modifier l'entrée "sort buffer size" et sauvegarder.

                        Par défault, cette variable est à 64k.

                        Par contre, je viens de me rendre compte que cette variable n'est pas conservée après un reboot du Nas (de nouveau 64k après le reboot). Je n'en connais pas la raison.

                        Commentaire


                        • #13
                          Re : Installation et message "Une erreur s'est produite".

                          Envoyé par eburon_jpbe Voir le message
                          Via phpMyAdmin, onglet "Variables" ==> modifier l'entrée "sort buffer size" et sauvegarder.

                          Par défault, cette variable est à 64k.
                          Salut eburon_jpbe
                          Merci pour ton aide.
                          Je viens d'essayer en mettant 128K (131072). Ça marche beaucoup mieux. Je n'ai plus le message "Une erreur s'est produite" dans une zone rose. Ainsi je récupère la gestion des menus. En revanche je n'ai toujours pas la gestion des modules.Là j'ai le message "Erreur: Out of sort memory, consider increasing server sort buffer size SQL=SELECT...."
                          J'ai essayé avec avec 256K (262144). Tout semble fonctionner pour le moment !!

                          Envoyé par eburon_jpbe Voir le message
                          Par contre, je viens de me rendre compte que cette variable n'est pas conservée après un reboot du Nas (de nouveau 64k après le reboot). Je n'en connais pas la raison.
                          En revanche, en effet quand je redémarre le syno, la valeur repasse à 64K :-(
                          J'ai trouvé une info ici : Lien
                          Mais je n'arrive pas à copier un fichier à l'endroit spécifié. J'ai utilisé WinSCP et Putty. Mais sans succès: "Permission denied".

                          Une idée pour mettre un fichier à cet endroit ?

                          Commentaire


                          • #14
                            Re : Installation et message "Une erreur s'est produite".

                            Salut,

                            En effet, il faut les droits de super-utilisateur pour modifier ce fichier.
                            On peut éditer ce fichier directement sur le système du synology. Malheureusement, le seul éditeur est "vim". Je ne sais pas si tu est à l'aise avec ce type d'éditeur....

                            Alors, voici ma solution :

                            - Autoriser la connexion SSH ou TELNET : Voir panneau de configuration / Terminal & SNMP
                            - Se connecter avec un compte administrateur.
                            Par exemple :
                            telnet <hostName du synology ou adresse IP>
                            login <administrateur>
                            password <mot de passe>

                            - Se rendre alors a cet emplacement :
                            cd /var/packages/MariaDB/etc
                            - Normalement, le fichier existe déjà. Confirmation en utilisant cette commande :
                            ls -l

                            - Effectuer une copie de sauvegarde :
                            sudo cp my.cnf my.cnf.bak

                            - Editer ce fichier. Le seul éditeur présent sur le synology est vim.

                            sudo vim my.cnf

                            Passer en mode "Insert" (Tapez i)
                            Entrer la configuration : par exemple

                            [mysqld]
                            sort_buffer_size = 262144

                            Quitter le mode d'insertion à l'aide de la touche <ESC>
                            Sauver le fichier en entrant les caractères :w
                            Quitter en entrant les caratères :q

                            Pour info, on peut quitter le mode édition par <ESC>.
                            On peut sortir sans sauver par :q!

                            Relancer les services :
                            sudo /usr/syno/bin/synopkg restart MariaDB
                            sudo /usr/syno/bin/synopkg restart phpMyAdmin

                            Celà a fonctionné chez moi.

                            Commentaire


                            • #15
                              Re : Installation et message &quot;Une erreur s'est produite&quot;.

                              Un grand merci pour ton aide eburon_jpbe.
                              Grace à toi, j'ai beaucoup appris, et j'ai également pu corriger ce soucis. Maintenant cela fonctionne.
                              Bonne soirée à toi. Et bonne semaine.

                              Commentaire

                              Annonce

                              Réduire
                              1 sur 2 < >

                              C'est [Réglé] et on n'en parle plus ?

                              A quoi ça sert ?
                              La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                              Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                              Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                              Comment ajouter la mention [Réglé] à votre discussion ?
                              1 - Aller sur votre discussion et éditer votre premier message :


                              2 - Cliquer sur la liste déroulante Préfixe.

                              3 - Choisir le préfixe [Réglé].


                              4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                              2 sur 2 < >

                              Assistance au forum - Outil de publication d'infos de votre site

                              Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                              Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                              Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                              UTILISER À VOS PROPRES RISQUES :
                              L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                              Problèmes connus :
                              FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                              Installation :

                              1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                              Archive zip : https://github.com/AFUJ/FPA/zipball/master

                              2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                              3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                              4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                              5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                              6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                              et remplacer www. votresite .com par votre nom de domaine


                              Exemples:
                              Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/
                              Pour executer le script: http://www..com/fpa-fr.php

                              Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                              Télécharger le script fpa-fr.php dans: /public_html/cms/
                              Pour executer le script: http://www..com/cms/fpa-fr.php

                              En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                              Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                              Voir plus
                              Voir moins
                              Travaille ...
                              X