Erreur de Réécriture au 'vol' des URL après migration de serveur.

Réduire
X
 
  • Filtrer
  • Heure
  • Afficher
Tout effacer
nouveaux messages

  • [RÉGLÉ] Erreur de Réécriture au 'vol' des URL après migration de serveur.

    Bonjour à tous.
    Je rencontre un petit problème suite à la migration d'un site Intranet sur un nouveau serveur.
    Historiquement notre site Intranet tournait sur un serveur Debian6 dédié.
    J'ai voulu changé de serveur et migrer sur un serveur Debian8.5 dédié.
    dans les deux cas c'est moi qui est installé les serveurs.

    J'ai copié le répertoire dans \var\www\monsite
    J'ai fait une sauvegarde de la bases monsite.sql et je l'ai injecté sur le nouveau serveur.

    Je rencontre un problème avec la Réécriture au 'vol' des URL
    Celle ci ne fonctionne pas sur le nouveau serveur alors qu'elle fonctionnait sur l'ancien serveur.
    Le fichier .htaccess et donc le même sur les deux serveur

    Est-ce que quelqu'un aurait un idée ?
    Merci d'avance.

    - - - Mise à jour - - -

    Les info sur les serveurs :

    L'ancien serveur : 2.6.32-5-686 #1 SMP Mon Feb 29 00:51:35 UTC 2016 i686 GNU/Linux 6.0.10
    version php : PHP 5.4.33-1~dotdeb.0
    version mysql : Ver 14.14 Distrib 5.5.38, for debian-linux-gnu (x86_64) using readline 6.1
    version apache2 : Server version: Apache/2.2.16 (Debian)

    Le nouveau serveur : 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u1 (2016-09-03) x86_64 GNU/Linux 8.5
    version php : PHP 5.6.24-0+deb8u1
    version mysql :Ver 14.14 Distrib 5.5.50, for debian-linux-gnu (x86_64) using readline 6.3
    version apache2 : Server version: Apache/2.4.10 (Debian)
    Dernière édition par yannix63 à 27/09/2016, 09h53 Raison: Résolu
    Yannick

  • #2
    Re : Erreur de Réécriture au 'vol' des URL après migration de serveur.

    Bonjour

    Pour que la réécriture d'URLs fonctionne sur un site Joomla!, il faut que le module mod_rewrite du serveur soit chargé de mémoire.
    Site d'entraide pour les utilisateur francophones de la CRM Vtiger https://aide-crm-vt.fr/
    Pour des extensions au top : http://joomlack.fr
    Pour la sécurité et l'optimisation : http://www.aesecure.com/ <--- Incontournable !
    Pour des petites choses sympa : http://lomart.fr

    Commentaire


    • #3
      Re : Erreur de Réécriture au 'vol' des URL après migration de serveur.

      Envoyé par Casper17 Voir le message
      Bonjour

      Pour que la réécriture d'URLs fonctionne sur un site Joomla!, il faut que le module mod_rewrite du serveur soit chargé de mémoire.
      Bonjour et merci pour votre réponse.
      A première vu le module est bien chargé et la réécriture fonctionne correctement.

      root@monservuer:/etc/apache2/sites-available# a2enmod rewrite
      Module rewrite already enabled

      Cliquez sur l'image pour l'afficher en taille normale

Nom : seo.png 
Affichages : 1 
Taille : 8,7 Ko 
ID : 1805795

      Dans joomla, quand j'active la réécriture d'URL (Réécriture d'URL en clair (SEF)), le lien se transforme en
      http://www.monsite.fr/index.php/rubrique/article

      C'est la deuxième option que je n'arrive pas à activer : Réécriture au 'vol' des URL
      qui permet d'enlever le index.php
      Je tombe à chaque fois sur du 404

      Merci a tous pour vos retours
      Yannick

      Commentaire


      • #4
        Re : Erreur de Réécriture au 'vol' des URL après migration de serveur.

        As-tu un fichier .htaccess à la racine de ton site ?
        Lorsque l'on se cogne la tête contre un pot et que cela sonne creux, ça n'est pas forcément le pot qui est vide.
        Confucius

        Commentaire


        • #5
          Re : Erreur de Réécriture au 'vol' des URL après migration de serveur.

          oui j'ai le fichier d'origine (.txt) que j'ai renomé en .htaccess

          ##
          # @package Joomla
          # @copyright Copyright (C) 2005 - 2014 Open Source Matters. All rights reserved.
          # @license GNU General Public License version 2 or later; see LICENSE.txt
          ##

          ##
          # READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
          #
          # The line just below this section: 'Options +FollowSymLinks' may cause problems
          # with some server configurations. It is required for use of mod_rewrite, but may already
          # be set by your server administrator in a way that dissallows changing it in
          # your .htaccess file. If using it causes your server to error out, comment it out (add # to
          # beginning of line), reload your site in your browser and test your sef url's. If they work,
          # it has been set by your server administrator and you do not need it set here.
          ##

          ## Can be commented out if causes errors, see notes above.
          Options +FollowSymLinks

          ## Mod_rewrite in use.

          RewriteEngine On

          ## Begin - Rewrite rules to block out some common exploits.
          # If you experience problems on your site block out the operations listed below
          # This attempts to block the most common type of exploit `attempts` to Joomla!
          #
          # Block out any script trying to base64_encode data within the URL.
          RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
          # Block out any script that includes a <script> tag in URL.
          RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
          # Block out any script trying to set a PHP GLOBALS variable via URL.
          RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
          # Block out any script trying to modify a _REQUEST variable via URL.
          RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
          # Return 403 Forbidden header and show the content of the root homepage
          RewriteRule .* index.php [F]
          #
          ## End - Rewrite rules to block out some common exploits.

          ## Begin - Custom redirects
          #
          # If you need to redirect some pages, or set a canonical non-www to
          # www redirect (or vice versa), place that code here. Ensure those
          # redirects use the correct RewriteRule syntax and the [R=301,L] flags.
          #
          ## End - Custom redirects

          ##
          # Uncomment following line if your webserver's URL
          # is not directly related to physical file paths.
          # Update Your Joomla! Directory (just / for root).
          ##

          RewriteBase /

          ## Begin - Joomla! core SEF Section.
          #
          RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
          #
          # If the requested path and file is not /index.php and the request
          # has not already been internally rewritten to the index.php script
          RewriteCond %{REQUEST_URI} !^/index\.php
          # and the requested path and file doesn't directly match a physical file
          RewriteCond %{REQUEST_FILENAME} !-f
          # and the requested path and file doesn't directly match a physical folder
          RewriteCond %{REQUEST_FILENAME} !-d
          # internally rewrite the request to the index.php script
          RewriteRule .* index.php [L]
          #
          ## End - Joomla! core SEF Section.
          Yannick

          Commentaire


          • #6
            Re : Erreur de Réécriture au 'vol' des URL après migration de serveur.

            Ils sont pas très inspirés les gas ... et moi je désespère !
            Yannick

            Commentaire


            • #7
              Re : Erreur de Réécriture au 'vol' des URL après migration de serveur.

              Bonjour,

              Quel résultat à l'activation du rewriting ? Erreur 404 directement ou La page d'accueil s'affiche mais les liens ne fonctionnent pas ?

              Dans le fichier .htaccess :

              - La directive FollowSymLinks fonctionne sur la nouvelle configuration où c'est SymLinksIfOwnerMatch qui doit être appliquée ?
              - Vous avez testé en supprimant le # devant : RewriteBase / ?
              Dernière édition par daneel à 19/09/2016, 10h01
              Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

              Commentaire


              • #8
                Re : Erreur de Réécriture au 'vol' des URL après migration de serveur.

                Tout d'abord merci daneel pour ton retour !
                Lorsque j'active la réécriture d'URL SEF ou la réécriture au vol dans l'administration joomla je n'ai aucun problème coté admin
                et aucun problème coté page d'accueil mais effectivement aucun lien ne fonctionne.

                - Concernant les directives je ne connait pas les différences entre les deux
                - J'ai testé en enlevant le # de RewritBase / mais pas de différence !

                En fait je ne sais plus trop ou cherché étant donné que cela fonctionne sur l'ancien serveur avec le même .htaccess
                Yannick

                Commentaire


                • #9
                  Re : Erreur de Réécriture au 'vol' des URL après migration de serveur.

                  Ce paramètre SEO ne nécessite-t-il pas un paquet en plus a installer sur mon Debian ou un autre module que le mod_rewrite ???
                  Dernière édition par yannix63 à 19/09/2016, 11h17
                  Yannick

                  Commentaire


                  • #10
                    Re : Erreur de Réécriture au 'vol' des URL après migration de serveur.

                    Envoyé par yannix63 Voir le message
                    Ce paramètre SEO ne nécessite-t-il pas un paquet en plus a installer sur mon Debian ou un autre module que le mod_rewrite ???
                    Normalement non, il faut vérifier si je ne me trompe pas que
                    Code:
                    AllowOverride all
                    soit précisé dans le fichier config de ton vhost afin que le fichier htaccess soit interprété par apache.
                    Joomla User Group (JUG) Lille : https://www.facebook.com/groups/JUGLille/

                    Commentaire


                    • #11
                      Re : Erreur de Réécriture au 'vol' des URL après migration de serveur.

                      C'est effectivement le cas :

                      <VirtualHost *:80>
                      ServerAdmin informatique@mondomaine.fr
                      DocumentRoot /var/www/monsite

                      <Directory />
                      Options FollowSymLinks
                      AllowOverride all
                      </Directory>

                      #LogLevel info ssl:warn


                      ErrorLog ${APACHE_LOG_DIR}/error.log
                      CustomLog ${APACHE_LOG_DIR}/access.log combined
                      #Include conf-available/serve-cgi-bin.conf
                      </VirtualHost>
                      Yannick

                      Commentaire


                      • #12
                        Re : Erreur de Réécriture au 'vol' des URL après migration de serveur.

                        Merci pour toute vos réponses.
                        Hélas je ne suis pas arrivé à résoudre mon problème...
                        Je ne vois vraiment pas d'ou cela peut venir sur un débina neuf fraîchement installé.

                        Voici la définition du virtual host 000.default


                        <VirtualHost *:80>
                        ServerAdmin informatique@masociété
                        DocumentRoot /var/www/monsite

                        <Directory />
                        Options FollowSymLinks
                        AllowOverride all
                        </Directory>

                        #LogLevel info ssl:warn

                        ErrorLog ${APACHE_LOG_DIR}/error.log
                        CustomLog ${APACHE_LOG_DIR}/access.log combined
                        #Include conf-available/serve-cgi-bin.conf
                        </VirtualHost>


                        Personne à une autre idée ?
                        Yannick

                        Commentaire


                        • #13
                          Re : Erreur de Réécriture au 'vol' des URL après migration de serveur.

                          Envoyé par yannix63 Voir le message

                          Personne à une autre idée ?
                          Si Moi !!!!

                          Je me répond à moi même en espérant que cela pourra aider quelqu'un

                          En fait le problème venait de la définition du virtualhost

                          Voici à quoi resemble mon virtualhost désormais et cela fonctionne

                          <VirtualHost *:80>
                          ServerAdmin webmaster@localhost

                          DocumentRoot /var/www/monsite
                          <Directory /var/www/monsite/>
                          Options FollowSymLinks Multiviews
                          AllowOverride All
                          </Directory>

                          Je vais marqué le sujet en résolu
                          Merci à tout ceux qui m'ont répondu !
                          Yannick

                          Commentaire

                          Annonce

                          Réduire
                          1 sur 2 < >

                          C'est [Réglé] et on n'en parle plus ?

                          A quoi ça sert ?
                          La mention [Réglé] permet aux visiteurs d'identifier rapidement les messages qui ont trouvé une solution.

                          Merci donc d'utiliser cette fonctionnalité afin de faciliter la navigation et la recherche d'informations de tous sur le forum.

                          Si vous deviez oublier de porter cette mention, nous nous permettrons de le faire à votre place... mais seulement une fois
                          Comment ajouter la mention [Réglé] à votre discussion ?
                          1 - Aller sur votre discussion et éditer votre premier message :


                          2 - Cliquer sur la liste déroulante Préfixe.

                          3 - Choisir le préfixe [Réglé].


                          4 - Et voilà… votre discussion est désormais identifiée comme réglée.

                          2 sur 2 < >

                          Assistance au forum - Outil de publication d'infos de votre site

                          Compatibilité: PHP 4.1,PHP4, 5, 6DEV MySQL 3.2 - 5.5 MySQLi from 4.1 ( @ >=PHP 4.4.9)

                          Support Version de Joomla! : | J!3.0 | J!2.5.xx | J!1.7.xx | J!1.6.xx | J1.5.xx | J!1.0.xx |

                          Version française (FR) D'autres versions sont disponibles depuis la version originale de FPA

                          UTILISER À VOS PROPRES RISQUES :
                          L'exactitude et l'exhaustivité de ce script ainsi que la documentation ne sont pas garanties et aucune responsabilité ne sera acceptée pour tout dommage, questions ou confusion provoquée par l'utilisation de ce script.

                          Problèmes connus :
                          FPA n'est actuellement pas compatible avec des sites Joomla qui ont eu leur fichier configuration.php déplacé en dehors du répertoire public_html.

                          Installation :

                          1. Téléchargez l'archive souhaitée : http://afuj.github.io/FPA/

                          Archive zip : https://github.com/AFUJ/FPA/zipball/master

                          2. Décompressez le fichier de package téléchargé sur votre propre ordinateur (à l'aide de WinZip ou d'un outil de décompression natif).

                          3. Lisez le fichier LISEZMOI inclus pour toutes les notes de versions spécifiques.

                          4. LIRE le fichier de documentation inclus pour obtenir des instructions d'utilisation détaillées.

                          5. Téléchargez le script fpa-fr.php à la racine de votre site Joomla!. C'est l'endroit que vous avez installé Joomla et ce n'est pas la racine principale de votre serveur. Voir les exemples ci-dessous.

                          6. Exécutez le script via votre navigateur en tapant: http:// www. votresite .com/ fpa-fr.php
                          et remplacer www. votresite .com par votre nom de domaine


                          Exemples:
                          Joomla! est installé dans votre répertoire web et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/
                          Pour executer le script: http://www..com/fpa-fr.php

                          Joomla! est installé dans un sous-répertoire nommé "cms" et vous avez installé la version française du fichier FPA:
                          Télécharger le script fpa-fr.php dans: /public_html/cms/
                          Pour executer le script: http://www..com/cms/fpa-fr.php

                          En raison de la nature très sensible de l'information affichée par le script FPA, il doit être retiré immédiatement du serveur après son utilisation.

                          Pour supprimer le script de votre site, utilisez le lien de script de suppression fourni en haut de la page du script. Si le lien de suppression échoue pour supprimer le script, utilisez votre programme FTP pour le supprimer manuellement ou changer le nom une fois que le script a généré les données du site et le message publié sur le forum. Si le script est toujours présent sur le site, il peut être utilisé pour recueillir suffisamment d'informations pour pirater votre site. Le retrait du script empêche des étrangers de l'utiliser pour jeter un oeil à la façon dont votre site est structuré et de détecter les défauts qui peuvent être utilisé à vos dépends.
                          Voir plus
                          Voir moins

                          Partenaire de l'association

                          Réduire

                          Hébergeur Web PlanetHoster
                          Travaille ...
                          X